summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-neutronclient_git.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2013-10-31 00:22:52 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2013-11-25 15:25:34 -0500
commita5a59d040b5db77a06346a516d30566a21d41586 (patch)
tree4de8d0e5f26396e1a66f668eec38d7b3bbb1465f /meta-openstack/recipes-devtools/python/python-neutronclient_git.bb
parent0a962a285a529def3d3649544214bc36c9292d18 (diff)
downloadmeta-cloud-services-a5a59d040b5db77a06346a516d30566a21d41586.tar.gz
python-quantum/python-neutron: update to havana version
Updating the OpenStack networking component to the havana release version. As part of this switch, we rename the components from quantum to neutron and switch to a git based build for the client and servers. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-neutronclient_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-neutronclient_git.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-neutronclient_git.bb b/meta-openstack/recipes-devtools/python/python-neutronclient_git.bb
new file mode 100644
index 0000000..7bcd057
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-neutronclient_git.bb
@@ -0,0 +1,23 @@
1DESCRIPTION = "CLI and python client library for OpenStack Neutron"
2HOMEPAGE = "https://launchpad.net/neutron"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
6
7RDEPENDS_${PN} +="python-cliff \
8 python-httplib2 \
9 python-iso8601 \
10 python-prettytable \
11 python-pyparsing \
12 python-simplejson \
13 "
14
15PR = "r0"
16
17SRC_URI = "git://github.com/openstack/python-neutronclient.git;branch=master"
18
19PV="git${SRCPV}"
20SRCREV="1598fc0f75503f8c357ac4b58f77edf6e0443a69"
21S = "${WORKDIR}/git"
22
23inherit setuptools