summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-lockfile_0.12.2.bb
diff options
context:
space:
mode:
authorHuang Qiyu <huangqy.fnst@cn.fujitsu.com>2017-01-23 13:04:46 +0800
committerBruce Ashfield <bruce.ashfield@windriver.com>2017-01-25 14:30:00 -0500
commita00306edc391d247eedd33037e31c19c3ec8d076 (patch)
tree5384b41b93581b48f860b8a4959028b1659053bb /meta-openstack/recipes-devtools/python/python-lockfile_0.12.2.bb
parent337a2d8c7d795e3a12b4c1bbd1f3b790fcaf2e4c (diff)
downloadmeta-cloud-services-a00306edc391d247eedd33037e31c19c3ec8d076.tar.gz
python-lockfile: 0.10.2 -> 0.12.2
Upgrade python-lockfile from 0.10.2 to 0.12.2. Signed-off-by: Huang Qiyu <huangqy.fnst@cn.fujitsu.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-lockfile_0.12.2.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-lockfile_0.12.2.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-lockfile_0.12.2.bb b/meta-openstack/recipes-devtools/python/python-lockfile_0.12.2.bb
new file mode 100644
index 0000000..98f2f98
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-lockfile_0.12.2.bb
@@ -0,0 +1,29 @@
1DESCRIPTION = "Platform-independent file locking module"
2HOMEPAGE = "http://code.google.com/p/pylockfile/"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=2340dffbbfea534b58f1349984eeef72"
6
7SRCNAME = "lockfile"
8
9SRC_URI = "https://pypi.python.org/packages/source/l/lockfile/${SRCNAME}-${PV}.tar.gz"
10
11SRC_URI[md5sum] = "a6a1a82957a23afdf44cfdd039b65ff9"
12SRC_URI[sha256sum] = "6aed02de03cba24efabcd600b30540140634fc06cfa603822d508d5361e9f799"
13
14S = "${WORKDIR}/${SRCNAME}-${PV}"
15
16inherit distutils
17
18DEPENDS += "\
19 python-pbr \
20 "
21
22# Satisfy setup.py 'setup_requires'
23DEPENDS += " \
24 python-pbr-native \
25 "
26
27RDEPENDS_${PN} += "\
28 python-pbr \
29 "