diff options
author | Bruce Ashfield <bruce.ashfield@windriver.com> | 2013-10-31 00:44:28 -0400 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@windriver.com> | 2013-11-25 15:25:35 -0500 |
commit | 2366317a61248a09c7261adac6a6abfe15ef4ca1 (patch) | |
tree | 377b4835ddd7ad6b451d701776513a9efb40eea0 /meta-openstack/recipes-devtools/python/python-lesscpy_0.9j.bb | |
parent | 38c09e8209d510b5cf4261727de00a05946e090f (diff) | |
download | meta-cloud-services-2366317a61248a09c7261adac6a6abfe15ef4ca1.tar.gz |
python-lesscpy: python LESS compiler
To provide compression and template capabilities the havana release of
horizon requires lesscpy.
But lesscpy is typically a python3 acript, so not only do we introduce
the recipe, we make it compatible with python2.
Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-lesscpy_0.9j.bb')
-rw-r--r-- | meta-openstack/recipes-devtools/python/python-lesscpy_0.9j.bb | 28 |
1 files changed, 28 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-lesscpy_0.9j.bb b/meta-openstack/recipes-devtools/python/python-lesscpy_0.9j.bb new file mode 100644 index 0000000..3bee660 --- /dev/null +++ b/meta-openstack/recipes-devtools/python/python-lesscpy_0.9j.bb | |||
@@ -0,0 +1,28 @@ | |||
1 | DESCRIPTION = "Python lesscpy: Python LESS Compiler" | ||
2 | HOMEPAGE = "https://pypi.python.org/pypi/lesscpy" | ||
3 | SECTION = "devel/python" | ||
4 | LICENSE = "Apache-2.0" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=a01aae31681ac25b4c46f98d627b9b5d" | ||
6 | |||
7 | PR = "r0" | ||
8 | SRCNAME = "lesscpy" | ||
9 | |||
10 | SRC_URI = "https://pypi.python.org/packages/source/l/${SRCNAME}/${SRCNAME}-${PV}.tar.gz \ | ||
11 | file://0001-lesscpy-remove-explicit-python3.patch \ | ||
12 | file://0002-Description-Fixup-for-python3.3-compat.patch \ | ||
13 | " | ||
14 | |||
15 | DEPENDS += "python-ply" | ||
16 | RDEPENDS_${PN} += "python-ply" | ||
17 | |||
18 | SRC_URI[md5sum] = "a9587da0148463d6521f386294c9d6f3" | ||
19 | SRC_URI[sha256sum] = "fa01d435a1ab3abafba683519bdc7aca5e19399e96225e1a8bc1d660b566364d" | ||
20 | |||
21 | S = "${WORKDIR}/${SRCNAME}-${PV}" | ||
22 | |||
23 | inherit distutils | ||
24 | |||
25 | DISTUTILS_INSTALL_ARGS = "--root=${D} \ | ||
26 | --prefix=${prefix} \ | ||
27 | --install-lib=${PYTHON_SITEPACKAGES_DIR} \ | ||
28 | --install-data=${datadir}" | ||