summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-kazoo_2.0.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2014-09-29 00:46:04 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-09-29 00:46:04 -0400
commit3c67c3601db5d9510ff8bb1082aed703e4125092 (patch)
treefc1e3b8d395008616e43a7d88b1f37ce837891e1 /meta-openstack/recipes-devtools/python/python-kazoo_2.0.bb
parent054a2823ebfd763c411a343ad3d5c70005abe0a5 (diff)
downloadmeta-cloud-services-3c67c3601db5d9510ff8bb1082aed703e4125092.tar.gz
ceilometer: update to juno dependencies
Ceilometer requires oslo.serialization and kazoo (plus its depdencies), so we add them here, and ceilometer-api works again. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-kazoo_2.0.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-kazoo_2.0.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-kazoo_2.0.bb b/meta-openstack/recipes-devtools/python/python-kazoo_2.0.bb
new file mode 100644
index 0000000..7c25e03
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-kazoo_2.0.bb
@@ -0,0 +1,27 @@
1DESCRIPTION = "Higher Level Zookeeper Client"
2HOMEPAGE = "https://kazoo.readthedocs.org"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
6
7PR = "r0"
8
9SRCNAME = "kazoo"
10SRC_URI = "http://pypi.python.org/packages/source/k/${SRCNAME}/${SRCNAME}-${PV}.zip"
11
12SRC_URI[md5sum] = "4b172de456c102b0e33f661e7e2b3583"
13SRC_URI[sha256sum] = "f0c42cc7752a331ba59269827bd19cb271210399a9dcab32b6a91465b4431a18"
14
15S = "${WORKDIR}/${SRCNAME}-${PV}"
16
17inherit setuptools
18
19# DEPENDS_default: python-pip
20
21DEPENDS += " \
22 python-pip \
23 "
24
25# RDEPENDS_default:
26RDEPENDS_${PN} += " \
27 "