diff options
author | Mark Asselstine <mark.asselstine@windriver.com> | 2014-03-17 12:25:04 -0400 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@windriver.com> | 2014-03-17 13:12:55 -0400 |
commit | d370e70c089c06241a739b47916a5c6d6c37226b (patch) | |
tree | 7241f47e4871abf9bb23011aadea5826fa217542 /meta-openstack/recipes-devtools/python/python-heatclient_git.bb | |
parent | 54c9a71b7f00c7dd35ecff6aad86cd47d83280d6 (diff) | |
download | meta-cloud-services-d370e70c089c06241a739b47916a5c6d6c37226b.tar.gz |
python-*: prevent setuptools from fetching required eggs
Several python packages require 'python-pbr' both at build and
runtime, as listed in their respective setup.py files, yet this
dependency is not included in their recipe. Adding python-pbr
to the RDEPENDS to correct this.
In addition this situation is complicated by the fact that the
setuptools will actually fetch python-pip and python-pbr eggs,
regardless of the value of BB_NO_NETWORK, if any of these packages are
built before python-pip and python-pbr are in the sysroot. Most
dramitically if you were to attempt to build any of these packages
with no network connectivity the do_compile() task will fail with the
following:
| DEBUG: Executing shell function do_compile
| Download error: [Errno 110] Connection timed out -- Some packages may not be found!
| Couldn't find index page for 'pip' (maybe misspelled?)
| Download error: [Errno 110] Connection timed out -- Some packages may not be found!
| No local packages or download links found for pip>=1.0
| Traceback (most recent call last):
| File "setup.py", line 21, in <module>
| pbr=True)
Adding the missing DEPENDS will ensure these packages are available
without the need for setuptools to fetch them, and avoid possible
build issues due to network connectivity.
In order to test these modifications all of these packages have been
built with a populated sstate cache and the network crippled using:
iptables -A OUTPUT -p tcp --destination-port 80 -j DROP
to ensure no extra fetches are taking place.
Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com>
Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-heatclient_git.bb')
-rw-r--r-- | meta-openstack/recipes-devtools/python/python-heatclient_git.bb | 6 |
1 files changed, 6 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-heatclient_git.bb b/meta-openstack/recipes-devtools/python/python-heatclient_git.bb index 2f3262c..fc9f020 100644 --- a/meta-openstack/recipes-devtools/python/python-heatclient_git.bb +++ b/meta-openstack/recipes-devtools/python/python-heatclient_git.bb | |||
@@ -4,12 +4,18 @@ SECTION = "devel/python" | |||
4 | LICENSE = "Apache-2.0" | 4 | LICENSE = "Apache-2.0" |
5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=34400b68072d710fecd0a2940a0d1658" | 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=34400b68072d710fecd0a2940a0d1658" |
6 | 6 | ||
7 | DEPENDS += " \ | ||
8 | python-pip \ | ||
9 | python-pbr \ | ||
10 | " | ||
11 | |||
7 | RDEPENDS_${PN} +="python-cliff \ | 12 | RDEPENDS_${PN} +="python-cliff \ |
8 | python-httplib2 \ | 13 | python-httplib2 \ |
9 | python-iso8601 \ | 14 | python-iso8601 \ |
10 | python-prettytable \ | 15 | python-prettytable \ |
11 | python-pyparsing \ | 16 | python-pyparsing \ |
12 | python-simplejson \ | 17 | python-simplejson \ |
18 | python-pbr \ | ||
13 | " | 19 | " |
14 | 20 | ||
15 | PR = "r0" | 21 | PR = "r0" |