diff options
author | Vu Tran <vu.tran@windriver.com> | 2014-02-28 09:11:13 -0500 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@windriver.com> | 2014-03-17 14:24:31 -0400 |
commit | e617d0205fc566ef70b61a75c484d78c540ef791 (patch) | |
tree | c5969046b73ea732f01c692ddfeef599ecb00eeb /meta-openstack/recipes-devtools/python/python-heat_git.bb | |
parent | 2c14cdfb9c34c541a1b3a180ad2a625514300977 (diff) | |
download | meta-cloud-services-e617d0205fc566ef70b61a75c484d78c540ef791.tar.gz |
Readjust the start level of openstack components
Currently all the openstack components have default start level
of 20. There are other services such as glusterfs, rabbbitmq,
database... are also starting at the same start level. On some
platform, this can cause racing condition between services which
in turn causes some of openstack components not started.
By adjusting the openstack components start level to higher will
ensure that system services start in the determistic way.
Signed-off-by: Vu Tran <vu.tran@windriver.com>
Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-heat_git.bb')
-rw-r--r-- | meta-openstack/recipes-devtools/python/python-heat_git.bb | 5 |
1 files changed, 4 insertions, 1 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-heat_git.bb b/meta-openstack/recipes-devtools/python/python-heat_git.bb index 4c12551..6fa6c36 100644 --- a/meta-openstack/recipes-devtools/python/python-heat_git.bb +++ b/meta-openstack/recipes-devtools/python/python-heat_git.bb | |||
@@ -80,7 +80,7 @@ pkg_postinst_${SRCNAME}-setup () { | |||
80 | heat-manage db_sync | 80 | heat-manage db_sync |
81 | } | 81 | } |
82 | 82 | ||
83 | inherit setuptools identity hosts update-rc.d | 83 | inherit setuptools identity hosts update-rc.d default_configs |
84 | 84 | ||
85 | PACKAGES += "${SRCNAME}-tests ${SRCNAME}-common ${SRCNAME}-api ${SRCNAME}-api-cfn ${SRCNAME}-engine" | 85 | PACKAGES += "${SRCNAME}-tests ${SRCNAME}-common ${SRCNAME}-api ${SRCNAME}-api-cfn ${SRCNAME}-engine" |
86 | PACKAGES += "${SRCNAME}-setup" | 86 | PACKAGES += "${SRCNAME}-setup" |
@@ -164,6 +164,9 @@ RDEPENDS_${SRCNAME}-setup = "postgresql sudo ${SRCNAME}-engine" | |||
164 | 164 | ||
165 | INITSCRIPT_PACKAGES = "${SRCNAME}-api ${SRCNAME}-api-cfn ${SRCNAME}-engine" | 165 | INITSCRIPT_PACKAGES = "${SRCNAME}-api ${SRCNAME}-api-cfn ${SRCNAME}-engine" |
166 | INITSCRIPT_NAME_${SRCNAME}-api = "${SRCNAME}-api" | 166 | INITSCRIPT_NAME_${SRCNAME}-api = "${SRCNAME}-api" |
167 | INITSCRIPT_PARAMS_${SRCNAME}-api = "${OS_DEFAULT_INITSCRIPT_PARAMS}" | ||
167 | INITSCRIPT_NAME_${SRCNAME}-api-cfn = "${SRCNAME}-api-cfn" | 168 | INITSCRIPT_NAME_${SRCNAME}-api-cfn = "${SRCNAME}-api-cfn" |
169 | INITSCRIPT_PARAMS_${SRCNAME}-api-cfn = "${OS_DEFAULT_INITSCRIPT_PARAMS}" | ||
168 | INITSCRIPT_NAME_${SRCNAME}-engine = "${SRCNAME}-engine" | 170 | INITSCRIPT_NAME_${SRCNAME}-engine = "${SRCNAME}-engine" |
171 | INITSCRIPT_PARAMS_${SRCNAME}-engine = "${OS_DEFAULT_INITSCRIPT_PARAMS}" | ||
169 | 172 | ||