summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-heat_git.bb
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2014-03-17 12:25:04 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-03-17 13:12:55 -0400
commitd370e70c089c06241a739b47916a5c6d6c37226b (patch)
tree7241f47e4871abf9bb23011aadea5826fa217542 /meta-openstack/recipes-devtools/python/python-heat_git.bb
parent54c9a71b7f00c7dd35ecff6aad86cd47d83280d6 (diff)
downloadmeta-cloud-services-d370e70c089c06241a739b47916a5c6d6c37226b.tar.gz
python-*: prevent setuptools from fetching required eggs
Several python packages require 'python-pbr' both at build and runtime, as listed in their respective setup.py files, yet this dependency is not included in their recipe. Adding python-pbr to the RDEPENDS to correct this. In addition this situation is complicated by the fact that the setuptools will actually fetch python-pip and python-pbr eggs, regardless of the value of BB_NO_NETWORK, if any of these packages are built before python-pip and python-pbr are in the sysroot. Most dramitically if you were to attempt to build any of these packages with no network connectivity the do_compile() task will fail with the following: | DEBUG: Executing shell function do_compile | Download error: [Errno 110] Connection timed out -- Some packages may not be found! | Couldn't find index page for 'pip' (maybe misspelled?) | Download error: [Errno 110] Connection timed out -- Some packages may not be found! | No local packages or download links found for pip>=1.0 | Traceback (most recent call last): | File "setup.py", line 21, in <module> | pbr=True) Adding the missing DEPENDS will ensure these packages are available without the need for setuptools to fetch them, and avoid possible build issues due to network connectivity. In order to test these modifications all of these packages have been built with a populated sstate cache and the network crippled using: iptables -A OUTPUT -p tcp --destination-port 80 -j DROP to ensure no extra fetches are taking place. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-heat_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-heat_git.bb7
1 files changed, 7 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-heat_git.bb b/meta-openstack/recipes-devtools/python/python-heat_git.bb
index 7fa798c..4c12551 100644
--- a/meta-openstack/recipes-devtools/python/python-heat_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-heat_git.bb
@@ -105,6 +105,12 @@ FILES_${SRCNAME}-engine = "${bindir}/heat-engine \
105 ${bindir}/* \ 105 ${bindir}/* \
106 ${sysconfdir}/init.d/heat-engine \ 106 ${sysconfdir}/init.d/heat-engine \
107" 107"
108
109DEPENDS += " \
110 python-pip \
111 python-pbr \
112 "
113
108RDEPENDS_${PN} += " \ 114RDEPENDS_${PN} += " \
109 python-heatclient \ 115 python-heatclient \
110 python-sqlalchemy \ 116 python-sqlalchemy \
@@ -148,6 +154,7 @@ RDEPENDS_${PN} += " \
148 python-pyyaml \ 154 python-pyyaml \
149 python-pip \ 155 python-pip \
150 python-pytz \ 156 python-pytz \
157 python-pbr \
151 " 158 "
152 159
153RDEPENDS_${SRCNAME}-engine = "${PN} ${SRCNAME}-common postgresql postgresql-client python-psycopg2 tgt" 160RDEPENDS_${SRCNAME}-engine = "${PN} ${SRCNAME}-common postgresql postgresql-client python-psycopg2 tgt"