summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-dogpile.core_0.4.1.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2013-10-31 00:29:38 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2013-11-25 15:25:34 -0500
commit5e1c122d1c43bc29873a5830b756cb24330bccf5 (patch)
tree410414ac91ff2e89c0d29f372676a210751017fc /meta-openstack/recipes-devtools/python/python-dogpile.core_0.4.1.bb
parent3df2532ad417923338b07e138a9047b9ce0d82fe (diff)
downloadmeta-cloud-services-5e1c122d1c43bc29873a5830b756cb24330bccf5.tar.gz
python-dogpile: add core and cache packages
In the havana release, keystone depends on dogpile to provide locking and cachine functionality. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-dogpile.core_0.4.1.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-dogpile.core_0.4.1.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-dogpile.core_0.4.1.bb b/meta-openstack/recipes-devtools/python/python-dogpile.core_0.4.1.bb
new file mode 100644
index 0000000..3079c39
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-dogpile.core_0.4.1.bb
@@ -0,0 +1,19 @@
1DESCRIPTION = "Python Dogpile Core: Dogpile is basically the locking code extracted from the Beaker package, for simple and generic usage."
2HOMEPAGE = "https://pypi.python.org/pypi/dogpile.core"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=0401fd56584d7b3d4be91690672ec433"
6
7PR = "r0"
8SRCNAME = "dogpile.core"
9
10SRC_URI = "https://pypi.python.org/packages/source/d/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
11
12SRC_URI[md5sum] = "5f76cce023d505a5375b07e094c3260f"
13SRC_URI[sha256sum] = "af2555702811d56846778d39451cf822b04b3f13347080c121a4977fefdfcbff"
14
15S = "${WORKDIR}/${SRCNAME}-${PV}"
16
17inherit setuptools
18
19