summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-beautifulsoup4_4.4.0.bb
diff options
context:
space:
mode:
authorLei Maohui <leimaohui@cn.fujitsu.com>2015-12-08 18:33:22 +0100
committerBruce Ashfield <bruce.ashfield@windriver.com>2015-12-11 12:11:28 -0500
commit8b5352fcd6910d87e8332a3394277f425ce1c9e9 (patch)
treecf241a2abd2c5c4236b425c48860e9e57e568a7f /meta-openstack/recipes-devtools/python/python-beautifulsoup4_4.4.0.bb
parent64d109a81a68baecc2bdb54a43dc291ca939c7d3 (diff)
downloadmeta-cloud-services-8b5352fcd6910d87e8332a3394277f425ce1c9e9.tar.gz
python-beautifulsoup4: upgrade 4.3.2 -> 4.4.0
Signed-off-by: Lei Maohui <leimaohui@cn.fujitsu.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-beautifulsoup4_4.4.0.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-beautifulsoup4_4.4.0.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-beautifulsoup4_4.4.0.bb b/meta-openstack/recipes-devtools/python/python-beautifulsoup4_4.4.0.bb
new file mode 100644
index 0000000..0b67b80
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-beautifulsoup4_4.4.0.bb
@@ -0,0 +1,23 @@
1DESCRIPTION = "Screen-scraping library"
2HOMEPAGE = "https://pypi.python.org/pypi/beautifulsoup4/"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://COPYING.txt;md5=39dacabe5494f61c8680f6fa7323b596"
6
7PR = "r0"
8SRCNAME = "beautifulsoup4"
9
10SRC_URI = "https://pypi.python.org/packages/source/b/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
11
12SRC_URI[md5sum] = "63d1f33e6524f408cb6efbc5da1ae8a5"
13SRC_URI[sha256sum] = "fad91da88f69438b9ba939ab1b2cabaa31b1d914f1cccb4bb157a993ed2917f6"
14
15S = "${WORKDIR}/${SRCNAME}-${PV}"
16
17inherit setuptools
18
19# avoid "error: option --single-version-externally-managed not recognized"
20DISTUTILS_INSTALL_ARGS = "--root=${D} \
21 --prefix=${prefix} \
22 --install-lib=${PYTHON_SITEPACKAGES_DIR} \
23 --install-data=${datadir}"