summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/erlang/erlang_R16B03-1.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2014-03-28 01:18:43 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-03-28 01:20:25 -0400
commit4bd68f289df9690c43c3484bdd464ed7411e051b (patch)
tree061e4c6b7985c716d75929022575ca3b461ecee9 /meta-openstack/recipes-devtools/erlang/erlang_R16B03-1.bb
parent689fe68f23a83a1d03d1ccdf383c0dd1028d83b8 (diff)
downloadmeta-cloud-services-4bd68f289df9690c43c3484bdd464ed7411e051b.tar.gz
erlang: update to R16B
Updating to the R16B erlang version from: https://github.com/joaohf/meta-erlang This is a cherry pick of the latest to avoid adding a new layer dependency. Eventually, this will be dropped and the layer used directly. We also update rabbitmq-server to depend on erlang-modules to get the proper support on target. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/erlang/erlang_R16B03-1.bb')
-rw-r--r--meta-openstack/recipes-devtools/erlang/erlang_R16B03-1.bb61
1 files changed, 61 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/erlang/erlang_R16B03-1.bb b/meta-openstack/recipes-devtools/erlang/erlang_R16B03-1.bb
new file mode 100644
index 0000000..4c2b947
--- /dev/null
+++ b/meta-openstack/recipes-devtools/erlang/erlang_R16B03-1.bb
@@ -0,0 +1,61 @@
1include erlang.inc
2DEPENDS += "erlang-native openssl"
3
4require erlang-${PV}-manifest.inc
5
6PR = "r0"
7
8TARGET_CC_ARCH += "${LDFLAGS}"
9
10EXTRA_OEMAKE = "BUILD_CC='${BUILD_CC}'"
11
12EXTRA_OECONF_append_arm = " --disable-smp-support --disable-hipe"
13EXTRA_OECONF_append_armeb = " --disable-smp-support --disable-hipe"
14EXTRA_OECONF_append_mipsel = " --disable-smp-support --disable-hipe"
15EXTRA_OECONF_append_sh3 = " --disable-smp-support --disable-hipe"
16EXTRA_OECONF_append_sh4 = " --disable-smp-support --disable-hipe"
17
18NATIVE_BIN = "${STAGING_LIBDIR_NATIVE}/erlang/bin"
19
20do_configure() {
21
22 cd ${S}/erts; autoreconf; cd -
23 cd ${S}/lib/wx; autoreconf; cd -
24
25 touch ${S}/lib/wx/SKIP
26 touch ${S}/lib/odbc/SKIP
27
28 . ${CONFIG_SITE}
29
30 ac_cv_prog_javac_ver_1_2=no \
31 ac_cv_prog_javac_ver_1_5=no \
32 SHLIB_LD='${CC}' \
33 erl_xcomp_sysroot=${STAGING_DIR_HOST} \
34 oe_runconf
35
36 sed -i -e 's|$(ERL_TOP)/bin/dialyzer|${NATIVE_BIN}/dialyzer --output_plt $@ -pa $(ERL_TOP)/lib/kernel/ebin -pa $(ERL_TOP)/lib/stdlib/ebin|' lib/dialyzer/src/Makefile
37}
38
39do_compile() {
40 TARGET=${TARGET_SYS} \
41 PATH=${NATIVE_BIN}:$PATH \
42 oe_runmake noboot
43}
44
45do_install() {
46 TARGET=${TARGET_SYS} \
47 PATH=${NATIVE_BIN}:$PATH \
48 oe_runmake 'INSTALL_PREFIX=${D}' install
49 for f in erl start
50 do sed -i -e 's:ROOTDIR=.*:ROOTDIR=${libdir}/erlang:' \
51 ${D}/${libdir}/erlang/erts-*/bin/$f ${D}/${libdir}/erlang/bin/$f
52 done
53
54 rm -f ${D}/${libdir}/erlang/Install
55
56 # Actually wx is not suitable with erlang embedded
57 rm -rf ${D}/${libdir}/erlang/lib/wx-*
58}
59
60SRC_URI[md5sum] = "e5ece977375197338c1b93b3d88514f8"
61SRC_URI[sha256sum] = "17ce53459bc5ceb34fc2da412e15ac8c23835a15fbd84e62c8d1852704747ee7"