summaryrefslogtreecommitdiffstats
path: root/meta-openstack-controller-deploy
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2013-10-02 09:21:44 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2013-10-03 01:15:42 -0400
commitcfb803391031a0b7f5971df14d1616bc3e3d8c07 (patch)
treed0ab9e30b6d67d38be113200116ade75e2410a5e /meta-openstack-controller-deploy
parente575ce2c01028a2b4c0273ca04fd6dbb8d9ece76 (diff)
downloadmeta-cloud-services-cfb803391031a0b7f5971df14d1616bc3e3d8c07.tar.gz
openstack-controller-deploy: cirros simple guest support
It is often desireable to test a OpenStack controller and compute node pair with a small, well known image. The cirros simple cloud image fits this bill. To enable the inclusion of this image, add: IMAGE_INSTALL_append = " cirros-guest-image" to local.conf (or relevant configuration file). Once the build completes, the cirros image can be found in /root/images/ Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack-controller-deploy')
-rw-r--r--meta-openstack-controller-deploy/recipes-extended/guest-images/cirros_0.3.0.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-openstack-controller-deploy/recipes-extended/guest-images/cirros_0.3.0.bb b/meta-openstack-controller-deploy/recipes-extended/guest-images/cirros_0.3.0.bb
new file mode 100644
index 0000000..c3fad1f
--- /dev/null
+++ b/meta-openstack-controller-deploy/recipes-extended/guest-images/cirros_0.3.0.bb
@@ -0,0 +1,19 @@
1SUMMARY = "An image containing the cirros cloud guest"
2DESCRIPTION = "CirrOS a tiny cloud guest"
3HOMEPAGE = "https://launchpad.net/cirros"
4
5LICENSE="GPLv2"
6
7SRC_URI = "https://launchpad.net/cirros/trunk/0.3.0/+download/${PN}-${PV}-x86_64-disk.img"
8SRC_URI[md5sum] = "5005e29ebadd0644af9008657fead245"
9SRC_URI[sha256sum] = "4820b23e33f388f3b95766fb67a6a211b111ab8349f41e2274b471bd288be21a"
10LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
11
12
13do_install() {
14 install -d ${D}/root/images
15 install -m 755 ${WORKDIR}/${PN}-${PV}-x86_64-disk.img ${D}/root/images
16}
17
18PACKAGES = "cirros-guest-image"
19FILES_cirros-guest-image = "/root/images/*"