summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorzangrc <zangrc.fnst@cn.fujitsu.com>2020-09-19 05:21:05 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-09-21 17:34:21 -0400
commitec061b0d71384842e74446df7da5de32fb1191a1 (patch)
treea2670378ecc361d1a78a3abff434a2d2eb1df99c
parent9737298bba752ba295860e60868b7b16bc83a9c7 (diff)
downloadmeta-cloud-services-ec061b0d71384842e74446df7da5de32fb1191a1.tar.gz
python3-keyring: Change to python3
Because python2 is no longer maintained, bb file is changed to python3 version. -License-Update:Because CONTRIBUTIRS.txt file does not exist in the latest version, choose LICENSE file to verify. Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--meta-openstack/recipes-devtools/python/python-keyring_5.3.bb14
-rw-r--r--meta-openstack/recipes-devtools/python/python3-keyring_21.4.0.bb21
2 files changed, 21 insertions, 14 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-keyring_5.3.bb b/meta-openstack/recipes-devtools/python/python-keyring_5.3.bb
deleted file mode 100644
index e137fc6..0000000
--- a/meta-openstack/recipes-devtools/python/python-keyring_5.3.bb
+++ /dev/null
@@ -1,14 +0,0 @@
1DESCRIPTION = "Store and access your passwords safely"
2HOMEPAGE = "https://pypi.python.org/pypi/keyring/"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://CONTRIBUTORS.txt;md5=50793e96bcc5250698eddfef509a2061"
6
7PYPI_PACKAGE_EXT = "zip"
8
9SRC_URI[md5sum] = "fd50a2be4a44a78efb09a7c046b6410d"
10SRC_URI[sha256sum] = "ac2b4dc17e6edfb804b09ade15df79f251522e442976ea0c8ea0051474502cf5"
11
12inherit setuptools3 pypi
13
14DEPENDS += " python-hgtools"
diff --git a/meta-openstack/recipes-devtools/python/python3-keyring_21.4.0.bb b/meta-openstack/recipes-devtools/python/python3-keyring_21.4.0.bb
new file mode 100644
index 0000000..569a546
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-keyring_21.4.0.bb
@@ -0,0 +1,21 @@
1DESCRIPTION = "Store and access your passwords safely"
2HOMEPAGE = "https://pypi.python.org/pypi/keyring/"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=7a7126e068206290f3fe9f8d6c713ea6"
6
7SRC_URI[md5sum] = "c9691de646eced3b15e888e5b410d6a1"
8SRC_URI[sha256sum] = "9aeadd006a852b78f4b4ef7c7556c2774d2432bbef8ee538a3e9089ac8b11466"
9
10inherit setuptools3 pypi
11
12DEPENDS += " \
13 python3-hgtools \
14 python3-setuptools-scm-native \
15 python3-toml-native \
16"
17
18RDEPENDS_${PN} = " \
19 python3-logging \
20 python3-importlib-metadata \
21"