summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorzangrc <zangrc.fnst@cn.fujitsu.com>2020-09-01 11:23:58 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-09-02 16:33:20 -0400
commite8bc055161fd31c38db48e66aad62aef34fceb91 (patch)
tree6ef0e822d853690f7c0970b63bce952ab8e0cdaf
parent63ea0fd0161b55deecec1a0f55fd1aa31ea4d5e8 (diff)
downloadmeta-cloud-services-e8bc055161fd31c38db48e66aad62aef34fceb91.tar.gz
python3-cursive: Change to python3
Because python2 is no longer maintained, bb file is changed to python3 version. Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--meta-openstack/recipes-devtools/python/python-cursive_git.bb37
-rw-r--r--meta-openstack/recipes-devtools/python/python3-cursive_0.2.2.bb31
2 files changed, 31 insertions, 37 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-cursive_git.bb b/meta-openstack/recipes-devtools/python/python-cursive_git.bb
deleted file mode 100644
index ce82998..0000000
--- a/meta-openstack/recipes-devtools/python/python-cursive_git.bb
+++ /dev/null
@@ -1,37 +0,0 @@
1DESCRIPTION = "Library for validation of digital signatures."
2HOMEPAGE = "https://github.com/openstack/cursive"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
6
7SRC_URI = "\
8 git://git.openstack.org/openstack/cursive.git;branch=master \
9 "
10
11PV="0.2.0+git${SRCPV}"
12SRCREV="ad25a4016c56eeceb85764c7ac4501def2b5445a"
13S = "${WORKDIR}/git"
14
15inherit setuptools3
16
17DEPENDS += " \
18 python-pbr \
19 "
20
21# Satisfy setup.py 'setup_requires'
22DEPENDS += " \
23 python-pbr-native \
24 "
25
26RDEPENDS_${PN} += " \
27 python-pbr \
28 python-lxml \
29 python-cryptography \
30 python-netifaces \
31 python-six \
32 python-oslo.serialization \
33 python-oslo.utils \
34 python-oslo.i18n \
35 python-oslo.log \
36 python-castellan \
37 "
diff --git a/meta-openstack/recipes-devtools/python/python3-cursive_0.2.2.bb b/meta-openstack/recipes-devtools/python/python3-cursive_0.2.2.bb
new file mode 100644
index 0000000..770acdc
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-cursive_0.2.2.bb
@@ -0,0 +1,31 @@
1DESCRIPTION = "Library for validation of digital signatures."
2HOMEPAGE = "https://github.com/openstack/cursive"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
6
7inherit setuptools3 pypi
8
9SRC_URI[sha256sum] = "fbdc2b088bf0b9a69b1897d726e6027e8fba8f21f0a881344f70e7a407d9abda"
10
11DEPENDS += " \
12 python3-pbr \
13 "
14
15# Satisfy setup.py 'setup_requires'
16DEPENDS += " \
17 python3-pbr-native \
18 "
19
20RDEPENDS_${PN} += " \
21 python3-pbr \
22 python3-lxml \
23 python3-cryptography \
24 python3-netifaces \
25 python3-six \
26 python3-oslo.serialization \
27 python3-oslo.utils \
28 python3-oslo.i18n \
29 python3-oslo.log \
30 python3-castellan \
31 "