summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2020-01-22 17:45:03 +0000
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-01-22 17:45:03 +0000
commitce38cb391c9108168ab574463b7ef745b739bcc9 (patch)
treea763ff9f68a0ae513183fa4e9c42c6ac3612c3e8
parent9d632de8d0e109e342fe580cf4b2423a51c890c3 (diff)
downloadmeta-cloud-services-ce38cb391c9108168ab574463b7ef745b739bcc9.tar.gz
openstack: packages: update for python3
Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--meta-openstack/recipes-extended/cloud-init/cloud-init_0.7.6.bb4
-rw-r--r--meta-openstack/recipes-extended/qpid/qpid-python_0.20.bb2
-rw-r--r--meta-openstack/recipes-extended/qpid/qpid_0.20.bb4
-rw-r--r--meta-openstack/recipes-extended/tempest/tempest_git.bb64
-rw-r--r--meta-openstack/recipes-extended/uwsgi/uwsgi_git.bb6
-rw-r--r--meta-openstack/recipes-support/mod-wsgi/mod-wsgi_git.bb6
-rw-r--r--meta-openstack/recipes-support/salt/salt_2018.3.0.bb48
7 files changed, 67 insertions, 67 deletions
diff --git a/meta-openstack/recipes-extended/cloud-init/cloud-init_0.7.6.bb b/meta-openstack/recipes-extended/cloud-init/cloud-init_0.7.6.bb
index c6b3529..8bbbef1 100644
--- a/meta-openstack/recipes-extended/cloud-init/cloud-init_0.7.6.bb
+++ b/meta-openstack/recipes-extended/cloud-init/cloud-init_0.7.6.bb
@@ -36,7 +36,7 @@ do_install_append() {
36 ln -s ${libdir}/${BPN}/write-ssh-key-fingerprints ${D}${sysconfdir}/cloud/write-ssh-key-fingerprints 36 ln -s ${libdir}/${BPN}/write-ssh-key-fingerprints ${D}${sysconfdir}/cloud/write-ssh-key-fingerprints
37} 37}
38 38
39inherit setuptools update-rc.d 39inherit setuptools3 update-rc.d
40 40
41PACKAGES += "${PN}-systemd" 41PACKAGES += "${PN}-systemd"
42 42
@@ -49,5 +49,5 @@ INITSCRIPT_PACKAGES = "${PN}"
49INITSCRIPT_NAME_${BPN} = "cloud-init" 49INITSCRIPT_NAME_${BPN} = "cloud-init"
50 50
51RDEPENDS_${PN} = "sysklogd \ 51RDEPENDS_${PN} = "sysklogd \
52 python \ 52 python3 \
53 " 53 "
diff --git a/meta-openstack/recipes-extended/qpid/qpid-python_0.20.bb b/meta-openstack/recipes-extended/qpid/qpid-python_0.20.bb
index 888bb09..9db4685 100644
--- a/meta-openstack/recipes-extended/qpid/qpid-python_0.20.bb
+++ b/meta-openstack/recipes-extended/qpid/qpid-python_0.20.bb
@@ -12,4 +12,4 @@ SRC_URI[sha256sum] = "3ca55a5aa11fbbd4e26cb4cdafc9658489c159acadceac60c89d4bfb5c
12 12
13S = "${WORKDIR}/qpid-${PV}/python" 13S = "${WORKDIR}/qpid-${PV}/python"
14 14
15inherit distutils 15inherit distutils3
diff --git a/meta-openstack/recipes-extended/qpid/qpid_0.20.bb b/meta-openstack/recipes-extended/qpid/qpid_0.20.bb
index b76f76d..933f5ef 100644
--- a/meta-openstack/recipes-extended/qpid/qpid_0.20.bb
+++ b/meta-openstack/recipes-extended/qpid/qpid_0.20.bb
@@ -3,7 +3,7 @@ HOMEPAGE = "http://qpid.apache.org/"
3LICENSE = "Apache-2.0" 3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=7ab4c208aa62d92d7a03cc8e0a89c12b" 4LIC_FILES_CHKSUM = "file://LICENSE;md5=7ab4c208aa62d92d7a03cc8e0a89c12b"
5SECTION = "mq" 5SECTION = "mq"
6DEPENDS = "boost perl-native python util-linux cyrus-sasl" 6DEPENDS = "boost perl-native python3 util-linux cyrus-sasl"
7RDEPENDS_${PN} = "cyrus-sasl-bin" 7RDEPENDS_${PN} = "cyrus-sasl-bin"
8PR = "r0" 8PR = "r0"
9 9
@@ -17,7 +17,7 @@ SRC_URI[sha256sum] = "31b80ba3c4773d288b4e6245e3b2048438386331d460f7a7b0794cbd20
17 17
18S = "${WORKDIR}/${PN}c-${PV}" 18S = "${WORKDIR}/${PN}c-${PV}"
19 19
20inherit autotools python-dir perlnative cpan-base update-rc.d pkgconfig 20inherit autotools python3-dir perlnative cpan-base update-rc.d pkgconfig
21 21
22# Env var which tells perl if it should use host (no) or target (yes) settings 22# Env var which tells perl if it should use host (no) or target (yes) settings
23export PERLCONFIGTARGET = "${@is_target(d)}" 23export PERLCONFIGTARGET = "${@is_target(d)}"
diff --git a/meta-openstack/recipes-extended/tempest/tempest_git.bb b/meta-openstack/recipes-extended/tempest/tempest_git.bb
index c7d1dd0..48a286c 100644
--- a/meta-openstack/recipes-extended/tempest/tempest_git.bb
+++ b/meta-openstack/recipes-extended/tempest/tempest_git.bb
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
7PR = "r0" 7PR = "r0"
8SRCNAME = "tempest" 8SRCNAME = "tempest"
9 9
10inherit setuptools identity hosts 10inherit setuptools3 identity hosts
11 11
12SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=master \ 12SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=master \
13 file://tempest.conf \ 13 file://tempest.conf \
@@ -122,36 +122,36 @@ RDEPENDS_${PN} += " \
122 ${SRCNAME}-setup \ 122 ${SRCNAME}-setup \
123 ${SRCNAME}-setup-altdemo \ 123 ${SRCNAME}-setup-altdemo \
124 ${SRCNAME}-setup-admin \ 124 ${SRCNAME}-setup-admin \
125 python-mox \ 125 python3-mox \
126 python-mock \ 126 python3-mock \
127 python-hp3parclient \ 127 python3-hp3parclient \
128 python-oauth2 \ 128 python3-oauth2 \
129 python-testrepository \ 129 python3-testrepository \
130 python-fixtures \ 130 python3-fixtures \
131 python-keyring \ 131 python3-keyring \
132 python-glanceclient \ 132 python3-glanceclient \
133 python-keystoneclient \ 133 python3-keystoneclient \
134 python-swiftclient \ 134 python3-swiftclient \
135 python-novaclient \ 135 python3-novaclient \
136 python-cinderclient \ 136 python3-cinderclient \
137 python-heatclient \ 137 python3-heatclient \
138 python-pbr \ 138 python3-pbr \
139 python-anyjson \ 139 python3-anyjson \
140 python-nose \ 140 python3-nose \
141 python-httplib2 \ 141 python3-httplib2 \
142 python-jsonschema \ 142 python3-jsonschema \
143 python-testtools \ 143 python3-testtools \
144 python-lxml \ 144 python3-lxml \
145 python-boto \ 145 python3-boto \
146 python-paramiko \ 146 python3-paramiko \
147 python-netaddr \ 147 python3-netaddr \
148 python-testresources \ 148 python3-testresources \
149 python-oslo.config \ 149 python3-oslo.config \
150 python-eventlet \ 150 python3-eventlet \
151 python-six \ 151 python3-six \
152 python-iso8601 \ 152 python3-iso8601 \
153 python-mimeparse \ 153 python3-mimeparse \
154 python-flake8 \ 154 python3-flake8 \
155 python-tox \ 155 python3-tox \
156 " 156 "
157 157
diff --git a/meta-openstack/recipes-extended/uwsgi/uwsgi_git.bb b/meta-openstack/recipes-extended/uwsgi/uwsgi_git.bb
index f0c535f..bf6b30f 100644
--- a/meta-openstack/recipes-extended/uwsgi/uwsgi_git.bb
+++ b/meta-openstack/recipes-extended/uwsgi/uwsgi_git.bb
@@ -14,15 +14,15 @@ SRCREV="af44211739136e22471a2897383f34586284bf86"
14PV="2.0.14+git${SRCPV}" 14PV="2.0.14+git${SRCPV}"
15S = "${WORKDIR}/git" 15S = "${WORKDIR}/git"
16 16
17inherit setuptools pkgconfig 17inherit setuptools3 pkgconfig
18 18
19# prevent host contamination and remove local search paths 19# prevent host contamination and remove local search paths
20export UWSGI_REMOVE_INCLUDES = "/usr/include,/usr/local/include" 20export UWSGI_REMOVE_INCLUDES = "/usr/include,/usr/local/include"
21 21
22DEPENDS += " \ 22DEPENDS += " \
23 e2fsprogs \ 23 e2fsprogs \
24 python-pip \ 24 python3-pip \
25 python-six \ 25 python3-six \
26 yajl \ 26 yajl \
27 " 27 "
28 28
diff --git a/meta-openstack/recipes-support/mod-wsgi/mod-wsgi_git.bb b/meta-openstack/recipes-support/mod-wsgi/mod-wsgi_git.bb
index eab28b0..4a1048e 100644
--- a/meta-openstack/recipes-support/mod-wsgi/mod-wsgi_git.bb
+++ b/meta-openstack/recipes-support/mod-wsgi/mod-wsgi_git.bb
@@ -20,10 +20,10 @@ SRC_URI = "\
20 file://configure.ac-allow-PYTHON-values-to-be-passed-via-en.patch \ 20 file://configure.ac-allow-PYTHON-values-to-be-passed-via-en.patch \
21 " 21 "
22 22
23inherit autotools-brokensep distutils-base 23inherit autotools-brokensep distutils3-base
24 24
25DEPENDS += "apache2-native apache2 python" 25DEPENDS += "apache2-native apache2 python3"
26RDEPENDS_${PN} = "python" 26RDEPENDS_${PN} = "python3"
27 27
28EXTRA_OECONF = "\ 28EXTRA_OECONF = "\
29 --with-apxs=${STAGING_BINDIR_CROSS}/apxs \ 29 --with-apxs=${STAGING_BINDIR_CROSS}/apxs \
diff --git a/meta-openstack/recipes-support/salt/salt_2018.3.0.bb b/meta-openstack/recipes-support/salt/salt_2018.3.0.bb
index a4022be..fb75872 100644
--- a/meta-openstack/recipes-support/salt/salt_2018.3.0.bb
+++ b/meta-openstack/recipes-support/salt/salt_2018.3.0.bb
@@ -3,15 +3,15 @@ SECTION = "admin"
3LICENSE = "Apache-2.0" 3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=fb92f464675f6b5df90f540d60237915" 4LIC_FILES_CHKSUM = "file://LICENSE;md5=fb92f464675f6b5df90f540d60237915"
5DEPENDS = "\ 5DEPENDS = "\
6 python-msgpack \ 6 python3-msgpack \
7 python-pyyaml \ 7 python3-pyyaml \
8 python-jinja2 \ 8 python3-jinja2 \
9 python-markupsafe \ 9 python3-markupsafe \
10" 10"
11 11
12PACKAGECONFIG ??= "zeromq" 12PACKAGECONFIG ??= "zeromq"
13PACKAGECONFIG[zeromq] = ",,python-pyzmq python-pycrypto," 13PACKAGECONFIG[zeromq] = ",,python3-pyzmq python3-pycrypto,"
14PACKAGECONFIG[tcp] = ",,python-pycrypto" 14PACKAGECONFIG[tcp] = ",,python3-pycrypto"
15 15
16SRC_URI = "https://files.pythonhosted.org/packages/source/s/${PN}/${PN}-${PV}.tar.gz \ 16SRC_URI = "https://files.pythonhosted.org/packages/source/s/${PN}/${PN}-${PV}.tar.gz \
17 file://set_python_location_hashbang.patch \ 17 file://set_python_location_hashbang.patch \
@@ -32,7 +32,7 @@ SRC_URI[sha256sum] = "a0a45d22fdf6961542a419b7e09568a3118e2b019ffe7bab9dee5aeb55
32 32
33S = "${WORKDIR}/${PN}-${PV}" 33S = "${WORKDIR}/${PN}-${PV}"
34 34
35inherit setuptools update-rc.d 35inherit setuptools3 update-rc.d
36 36
37# Avoid a QA Warning triggered by the test package including a file 37# Avoid a QA Warning triggered by the test package including a file
38# with a .a extension 38# with a .a extension
@@ -88,11 +88,11 @@ Between the remote execution system, and state management Salt addresses the bac
88 88
89SUMMARY_${PN}-minion = "client package for salt, the distributed remote execution system" 89SUMMARY_${PN}-minion = "client package for salt, the distributed remote execution system"
90DESCRIPTION_${PN}-minion = "${DESCRIPTION_COMMON} This particular package provides the worker agent for salt." 90DESCRIPTION_${PN}-minion = "${DESCRIPTION_COMMON} This particular package provides the worker agent for salt."
91RDEPENDS_${PN}-minion = "${PN}-common (= ${EXTENDPKGV}) python-msgpack" 91RDEPENDS_${PN}-minion = "${PN}-common (= ${EXTENDPKGV}) python3-msgpack"
92RDEPENDS_${PN}-minion += "${@bb.utils.contains('PACKAGECONFIG', 'zeromq', 'python-pycrypto python-pyzmq (>= 13.1.0)', '',d)}" 92RDEPENDS_${PN}-minion += "${@bb.utils.contains('PACKAGECONFIG', 'zeromq', 'python3-pycrypto python3-pyzmq (>= 13.1.0)', '',d)}"
93RDEPENDS_${PN}-minion += "${@bb.utils.contains('PACKAGECONFIG', 'tcp', 'python-pycrypto', '',d)}" 93RDEPENDS_${PN}-minion += "${@bb.utils.contains('PACKAGECONFIG', 'tcp', 'python3-pycrypto', '',d)}"
94RRECOMMENDS_${PN}-minion_append_x64 = "dmidecode" 94RRECOMMENDS_${PN}-minion_append_x64 = "dmidecode"
95RSUGGESTS_${PN}-minion = "python-augeas" 95RSUGGESTS_${PN}-minion = "python3-augeas"
96CONFFILES_${PN}-minion = "${sysconfdir}/${PN}/minion ${sysconfdir}/init.d/${PN}-minion" 96CONFFILES_${PN}-minion = "${sysconfdir}/${PN}/minion ${sysconfdir}/init.d/${PN}-minion"
97FILES_${PN}-minion = "${bindir}/${PN}-minion ${sysconfdir}/${PN}/minion.d/ ${CONFFILES_${PN}-minion} ${bindir}/${PN}-proxy" 97FILES_${PN}-minion = "${bindir}/${PN}-minion ${sysconfdir}/${PN}/minion.d/ ${CONFFILES_${PN}-minion} ${bindir}/${PN}-proxy"
98INITSCRIPT_NAME_${PN}-minion = "${PN}-minion" 98INITSCRIPT_NAME_${PN}-minion = "${PN}-minion"
@@ -101,18 +101,18 @@ INITSCRIPT_PARAMS_${PN}-minion = "defaults"
101SUMMARY_${PN}-common = "shared libraries that salt requires for all packages" 101SUMMARY_${PN}-common = "shared libraries that salt requires for all packages"
102DESCRIPTION_${PN}-common ="${DESCRIPTION_COMMON} This particular package provides shared libraries that \ 102DESCRIPTION_${PN}-common ="${DESCRIPTION_COMMON} This particular package provides shared libraries that \
103salt-master, salt-minion, and salt-syndic require to function." 103salt-master, salt-minion, and salt-syndic require to function."
104RDEPENDS_${PN}-common = "python-dateutil python-jinja2 python-pyyaml python-requests (>= 1.0.0) python-tornado (>= 4.2.1)" 104RDEPENDS_${PN}-common = "python3-dateutil python3-jinja2 python3-pyyaml python3-requests (>= 1.0.0) python3-tornado (>= 4.2.1)"
105RRECOMMENDS_${PN}-common = "lsb python-futures" 105RRECOMMENDS_${PN}-common = "lsb python3-futures"
106RSUGGESTS_${PN}-common = "python-mako python-git" 106RSUGGESTS_${PN}-common = "python3-mako python3-git"
107RCONFLICTS_${PN}-common = "python-mako (< 0.7.0)" 107RCONFLICTS_${PN}-common = "python3-mako (< 0.7.0)"
108CONFFILES_${PN}-common="${sysconfdir}/logrotate.d/${PN}-common" 108CONFFILES_${PN}-common="${sysconfdir}/logrotate.d/${PN}-common"
109FILES_${PN}-common = "${bindir}/${PN}-call ${libdir}/python2.7/ ${CONFFILES_${PN}-common}" 109FILES_${PN}-common = "${bindir}/${PN}-call ${libdir}/python${PYTHON_BASEVERSION}/ ${CONFFILES_${PN}-common}"
110 110
111SUMMARY_${PN}-ssh = "remote manager to administer servers via salt" 111SUMMARY_${PN}-ssh = "remote manager to administer servers via salt"
112DESCRIPTION_${PN}-ssh = "${DESCRIPTION_COMMON} This particular package provides the salt ssh controller. It \ 112DESCRIPTION_${PN}-ssh = "${DESCRIPTION_COMMON} This particular package provides the salt ssh controller. It \
113is able to run salt modules and states on remote hosts via ssh. No minion or other salt specific software needs\ 113is able to run salt modules and states on remote hosts via ssh. No minion or other salt specific software needs\
114 to be installed on the remote host." 114 to be installed on the remote host."
115RDEPENDS_${PN}-ssh = "${PN}-common (= ${EXTENDPKGV}) python-msgpack" 115RDEPENDS_${PN}-ssh = "${PN}-common (= ${EXTENDPKGV}) python3-msgpack"
116CONFFILES_${PN}-ssh="${sysconfdir}/${PN}/roster" 116CONFFILES_${PN}-ssh="${sysconfdir}/${PN}/roster"
117FILES_${PN}-ssh = "${bindir}/${PN}-ssh ${CONFFILES_${PN}-ssh}" 117FILES_${PN}-ssh = "${bindir}/${PN}-ssh ${CONFFILES_${PN}-ssh}"
118 118
@@ -123,7 +123,7 @@ even a Websocket API. The Salt API system is used to expose the fundamental aspe
123 sources. salt-api acts as the bridge between Salt itself and REST, Websockets, etc. Documentation is available\ 123 sources. salt-api acts as the bridge between Salt itself and REST, Websockets, etc. Documentation is available\
124 on Read the Docs: http://salt-api.readthedocs.org/" 124 on Read the Docs: http://salt-api.readthedocs.org/"
125RDEPENDS_${PN}-api = "${PN}-master" 125RDEPENDS_${PN}-api = "${PN}-master"
126RSUGGESTS_${PN}-api = "python-cherrypy" 126RSUGGESTS_${PN}-api = "python3-cherrypy"
127CONFFILES_${PN}-api = "${sysconfdir}/init.d/${PN}-api" 127CONFFILES_${PN}-api = "${sysconfdir}/init.d/${PN}-api"
128FILES_${PN}-api = "${bindir}/${PN}-api ${CONFFILES_${PN}-api}" 128FILES_${PN}-api = "${bindir}/${PN}-api ${CONFFILES_${PN}-api}"
129INITSCRIPT_NAME_${PN}-api = "${PN}-api" 129INITSCRIPT_NAME_${PN}-api = "${PN}-api"
@@ -131,11 +131,11 @@ INITSCRIPT_PARAMS_${PN}-api = "defaults"
131 131
132SUMMARY_${PN}-master = "remote manager to administer servers via salt" 132SUMMARY_${PN}-master = "remote manager to administer servers via salt"
133DESCRIPTION_${PN}-master ="${DESCRIPTION_COMMON} This particular package provides the salt controller." 133DESCRIPTION_${PN}-master ="${DESCRIPTION_COMMON} This particular package provides the salt controller."
134RDEPENDS_${PN}-master = "${PN}-common (= ${EXTENDPKGV}) python-msgpack" 134RDEPENDS_${PN}-master = "${PN}-common (= ${EXTENDPKGV}) python3-msgpack"
135RDEPENDS_${PN}-master += "${@bb.utils.contains('PACKAGECONFIG', 'zeromq', 'python-pycrypto python-pyzmq (>= 13.1.0)', '',d)}" 135RDEPENDS_${PN}-master += "${@bb.utils.contains('PACKAGECONFIG', 'zeromq', 'python3-pycrypto python3-pyzmq (>= 13.1.0)', '',d)}"
136RDEPENDS_${PN}-master += "${@bb.utils.contains('PACKAGECONFIG', 'tcp', 'python-pycrypto', '',d)}" 136RDEPENDS_${PN}-master += "${@bb.utils.contains('PACKAGECONFIG', 'tcp', 'python3-pycrypto', '',d)}"
137CONFFILES_${PN}-master="${sysconfdir}/init.d/${PN}-master ${sysconfdir}/${PN}/master" 137CONFFILES_${PN}-master="${sysconfdir}/init.d/${PN}-master ${sysconfdir}/${PN}/master"
138RSUGGESTS_${PN}-master = "python-git" 138RSUGGESTS_${PN}-master = "python3-git"
139FILES_${PN}-master = "${bindir}/${PN} ${bindir}/${PN}-cp ${bindir}/${PN}-key ${bindir}/${PN}-master ${bindir}/${PN}-run ${bindir}/${PN}-unity ${bindir}/spm ${CONFFILES_${PN}-master}" 139FILES_${PN}-master = "${bindir}/${PN} ${bindir}/${PN}-cp ${bindir}/${PN}-key ${bindir}/${PN}-master ${bindir}/${PN}-run ${bindir}/${PN}-unity ${bindir}/spm ${CONFFILES_${PN}-master}"
140INITSCRIPT_NAME_${PN}-master = "${PN}-master" 140INITSCRIPT_NAME_${PN}-master = "${PN}-master"
141INITSCRIPT_PARAMS_${PN}-master = "defaults" 141INITSCRIPT_PARAMS_${PN}-master = "defaults"
@@ -152,13 +152,13 @@ INITSCRIPT_PARAMS_${PN}-syndic = "defaults"
152SUMMARY_${PN}-cloud = "public cloud VM management system" 152SUMMARY_${PN}-cloud = "public cloud VM management system"
153DESCRIPTION_${PN}-cloud = "provision virtual machines on various public clouds via a cleanly controlled profile and mapping system." 153DESCRIPTION_${PN}-cloud = "provision virtual machines on various public clouds via a cleanly controlled profile and mapping system."
154RDEPENDS_${PN}-cloud = "${PN}-common (= ${EXTENDPKGV})" 154RDEPENDS_${PN}-cloud = "${PN}-common (= ${EXTENDPKGV})"
155RSUGGESTS_${PN}-cloud = "python-netaddr python-botocore" 155RSUGGESTS_${PN}-cloud = "python3-netaddr python3-botocore"
156CONFFILES_${PN}-cloud = "${sysconfdir}/${PN}/cloud" 156CONFFILES_${PN}-cloud = "${sysconfdir}/${PN}/cloud"
157FILES_${PN}-cloud = "${bindir}/${PN}-cloud ${sysconfdir}/${PN}/cloud.conf.d/ ${sysconfdir}/${PN}/cloud.profiles.d/ ${sysconfdir}/${PN}/cloud.providers.d/ ${CONFFILES_${PN}-cloud}" 157FILES_${PN}-cloud = "${bindir}/${PN}-cloud ${sysconfdir}/${PN}/cloud.conf.d/ ${sysconfdir}/${PN}/cloud.profiles.d/ ${sysconfdir}/${PN}/cloud.providers.d/ ${CONFFILES_${PN}-cloud}"
158 158
159SUMMARY_${PN}-tests = "salt stack test suite" 159SUMMARY_${PN}-tests = "salt stack test suite"
160DESCRIPTION_${PN}-tests ="${DESCRIPTION_COMMON} This particular package provides the salt unit test suite." 160DESCRIPTION_${PN}-tests ="${DESCRIPTION_COMMON} This particular package provides the salt unit test suite."
161RDEPENDS_${PN}-tests = "${PN}-common python-pytest-salt python-tests python-image bash" 161RDEPENDS_${PN}-tests = "${PN}-common python3-pytest-salt python3-tests python3-image bash"
162FILES_${PN}-tests = "${PYTHON_SITEPACKAGES_DIR}/salt-tests/tests/" 162FILES_${PN}-tests = "${PYTHON_SITEPACKAGES_DIR}/salt-tests/tests/"
163 163
164FILES_${PN}-bash-completion = "${sysconfdir}/bash_completion.d/${PN}-common" 164FILES_${PN}-bash-completion = "${sysconfdir}/bash_completion.d/${PN}-common"