summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2020-01-22 16:21:37 +0000
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-01-22 16:21:37 +0000
commitba0ca845af46a5d9c05dbd8943744a4e78d268d5 (patch)
tree0e78afe950c5d53c59c7a39fa504c4a09a5bedc9
parentb7c8e26df83991f4f84114956b4e6a07109d108d (diff)
downloadmeta-cloud-services-ba0ca845af46a5d9c05dbd8943744a4e78d268d5.tar.gz
misc: python3 readiness
Updating the packages in m-c-s to be python3 parse safe. These are not runtime tested, but will pass layer inclusion and parsing. Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--recipes-devtools/python/python-ansible_2.3.1.0.bb4
-rw-r--r--recipes-devtools/python/python-greenlet_0.4.9.bb11
-rw-r--r--recipes-devtools/python/python-pyparsing_2.0.1.bb10
-rw-r--r--recipes-extended/glusterfs/glusterfs.inc7
-rw-r--r--recipes-support/spice/spice_git.bb6
5 files changed, 7 insertions, 31 deletions
diff --git a/recipes-devtools/python/python-ansible_2.3.1.0.bb b/recipes-devtools/python/python-ansible_2.3.1.0.bb
deleted file mode 100644
index b6659fc..0000000
--- a/recipes-devtools/python/python-ansible_2.3.1.0.bb
+++ /dev/null
@@ -1,4 +0,0 @@
1inherit setuptools
2require python-ansible.inc
3
4RDEPENDS_${PN} += "python-pyyaml python-jinja2 python-modules"
diff --git a/recipes-devtools/python/python-greenlet_0.4.9.bb b/recipes-devtools/python/python-greenlet_0.4.9.bb
deleted file mode 100644
index 49c2551..0000000
--- a/recipes-devtools/python/python-greenlet_0.4.9.bb
+++ /dev/null
@@ -1,11 +0,0 @@
1SUMMARY = "Python lightweight in-process concurrent programming"
2HOMEPAGE = "http://pypi.python.org/pypi/greenlet"
3SECTION = "devel/python"
4LICENSE = "MIT & PSF"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=03143d7a1a9f5d8a0fee825f24ca9c36 \
6 file://LICENSE.PSF;md5=c106931d9429eda0492617f037b8f69a"
7
8SRC_URI[md5sum] = "00bb1822d8511cc85f052e89d1fd919b"
9SRC_URI[sha256sum] = "79f9b8bbbb1c599c66aed5e643e8b53bae697cae46e0acfc4ee461df48a90012"
10
11inherit distutils pypi
diff --git a/recipes-devtools/python/python-pyparsing_2.0.1.bb b/recipes-devtools/python/python-pyparsing_2.0.1.bb
deleted file mode 100644
index c19f137..0000000
--- a/recipes-devtools/python/python-pyparsing_2.0.1.bb
+++ /dev/null
@@ -1,10 +0,0 @@
1DESCRIPTION = "Python parsing module"
2HOMEPAGE = "http://pyparsing.wikispaces.com/"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=fb46329938e6bc829b256e37d5c1e31a"
6
7SRC_URI[md5sum] = "37adec94104b98591507218bc82e7c31"
8SRC_URI[sha256sum] = "0007cd3f008eba4a203f1f6b4b133ddc352552c8808b694c88c23db56416e4e4"
9
10inherit distutils pypi
diff --git a/recipes-extended/glusterfs/glusterfs.inc b/recipes-extended/glusterfs/glusterfs.inc
index 1ac5123..4eb325f 100644
--- a/recipes-extended/glusterfs/glusterfs.inc
+++ b/recipes-extended/glusterfs/glusterfs.inc
@@ -26,7 +26,8 @@ LIC_FILES_CHKSUM = "file://COPYING-GPLV2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
26 file://COPYING-LGPLV3;md5=e6a600fd5e1d9cbde2d983680233ad02 \ 26 file://COPYING-LGPLV3;md5=e6a600fd5e1d9cbde2d983680233ad02 \
27 file://contrib/fuse-util/COPYING;md5=94d55d512a9ba36caa9b7df079bae19f" 27 file://contrib/fuse-util/COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
28 28
29inherit autotools pkgconfig distutils-base update-rc.d systemd 29inherit autotools pkgconfig distutils3-base update-rc.d systemd
30inherit python3-dir
30 31
31DEPENDS += "bison-native flex-native python3-native fuse libaio libtirpc libxml2 ncurses \ 32DEPENDS += "bison-native flex-native python3-native fuse libaio libtirpc libxml2 ncurses \
32 openssl python3 readline zlib liburcu util-linux glib-2.0 acl" 33 openssl python3 readline zlib liburcu util-linux glib-2.0 acl"
@@ -42,8 +43,8 @@ EXTRA_OECONF = "ac_cv_file__etc_debian_version=no \
42 ac_cv_file__etc_centos_release=no \ 43 ac_cv_file__etc_centos_release=no \
43 --with-mountutildir=${sbindir} \ 44 --with-mountutildir=${sbindir} \
44 --disable-fusermount \ 45 --disable-fusermount \
45 TARGET_PYTHON=${bindir}/python \ 46 TARGET_PYTHON=${bindir}/python3 \
46 PYTHON=${STAGING_BINDIR_NATIVE}/python-native/python \ 47 PYTHON=${PYTHON} \
47 BUILD_PYTHON_INC=${STAGING_INCDIR}/python${PYTHON_BASEVERSION} \ 48 BUILD_PYTHON_INC=${STAGING_INCDIR}/python${PYTHON_BASEVERSION} \
48 BUILD_PYTHON_LIB=python${PYTHON_BASEVERSION} \ 49 BUILD_PYTHON_LIB=python${PYTHON_BASEVERSION} \
49 BUILD_PYTHON_SITE_PACKAGES=${PYTHON_SITEPACKAGES_DIR} \ 50 BUILD_PYTHON_SITE_PACKAGES=${PYTHON_SITEPACKAGES_DIR} \
diff --git a/recipes-support/spice/spice_git.bb b/recipes-support/spice/spice_git.bb
index c0fdd9c..7198ce0 100644
--- a/recipes-support/spice/spice_git.bb
+++ b/recipes-support/spice/spice_git.bb
@@ -45,12 +45,12 @@ SRC_URI += " \
45 45
46S = "${WORKDIR}/git" 46S = "${WORKDIR}/git"
47 47
48inherit autotools gettext pythonnative python-dir pkgconfig 48inherit autotools gettext python3native python3-dir pkgconfig
49 49
50DEPENDS += "python-native celt051 python-pyparsing jpeg pixman alsa-lib glib-2.0" 50DEPENDS += "python3-native celt051 python3-pyparsing jpeg pixman alsa-lib glib-2.0"
51 51
52export PYTHON="${STAGING_BINDIR_NATIVE}/python-native/python" 52export PYTHON="${STAGING_BINDIR_NATIVE}/python-native/python"
53export PYTHONPATH="${PKG_CONFIG_SYSROOT_DIR}${libdir}/python2.7/site-packages" 53export PYTHONPATH="${PKG_CONFIG_SYSROOT_DIR}${libdir}/python${PYTHON_BASEVERSION}/site-packages"
54 54
55PACKAGECONFIG ?= "sasl" 55PACKAGECONFIG ?= "sasl"
56 56