summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorzangrc <zangrc.fnst@cn.fujitsu.com>2020-01-14 10:54:47 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-01-15 16:23:54 -0500
commitb49169124a2b61294b6843183f4212ef17fb932e (patch)
treeb16108a9c626196894fe9f1ed34cc51d1b2eb2ff
parentda0019928cbf6751aa964b286c267b5b457d9a57 (diff)
downloadmeta-cloud-services-b49169124a2b61294b6843183f4212ef17fb932e.tar.gz
python-wsgiref: Add python3 version
Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--meta-openstack/recipes-devtools/python/python-wsgiref.inc23
-rw-r--r--meta-openstack/recipes-devtools/python/python-wsgiref_0.1.2.bb25
-rw-r--r--meta-openstack/recipes-devtools/python/python3-wsgiref_0.1.2.bb2
3 files changed, 27 insertions, 23 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-wsgiref.inc b/meta-openstack/recipes-devtools/python/python-wsgiref.inc
new file mode 100644
index 0000000..1449bea
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-wsgiref.inc
@@ -0,0 +1,23 @@
1DESCRIPTION = "WSGI (PEP 333) Reference Library"
2HOMEPAGE = "http://cheeseshop.python.org/pypi/wsgiref"
3SECTION = "devel/python"
4LICENSE = "PSF"
5LIC_FILES_CHKSUM = "file://PKG-INFO;md5=fe761dfec1d54629c6b9a3bbc7b1baf5"
6
7# Archived version so we need to overwrite what the pypi class will derive
8PYPI_SRC_URI = "https://pypi.python.org/packages/source/w/wsgiref/wsgiref-${PV}.zip"
9
10SRC_URI[md5sum] = "29b146e6ebd0f9fb119fe321f7bcf6cb"
11SRC_URI[sha256sum] = "c7e610c800957046c04c8014aab8cce8f0b9f0495c8cd349e57c1f7cabf40e79"
12
13inherit pypi
14
15# DEPENDS_default: python-pip
16
17DEPENDS += " \
18 ${PYTHON_PN}-pip \
19 "
20
21# RDEPENDS_default:
22RDEPENDS_${PN} += " \
23 "
diff --git a/meta-openstack/recipes-devtools/python/python-wsgiref_0.1.2.bb b/meta-openstack/recipes-devtools/python/python-wsgiref_0.1.2.bb
index dc02a44..3ec8264 100644
--- a/meta-openstack/recipes-devtools/python/python-wsgiref_0.1.2.bb
+++ b/meta-openstack/recipes-devtools/python/python-wsgiref_0.1.2.bb
@@ -1,23 +1,2 @@
1DESCRIPTION = "WSGI (PEP 333) Reference Library" 1require python-wsgiref.inc
2HOMEPAGE = "http://cheeseshop.python.org/pypi/wsgiref" 2inherit setuptools
3SECTION = "devel/python"
4LICENSE = "PSF"
5LIC_FILES_CHKSUM = "file://PKG-INFO;md5=fe761dfec1d54629c6b9a3bbc7b1baf5"
6
7# Archived version so we need to overwrite what the pypi class will derive
8PYPI_SRC_URI = "https://pypi.python.org/packages/source/w/wsgiref/wsgiref-${PV}.zip"
9
10SRC_URI[md5sum] = "29b146e6ebd0f9fb119fe321f7bcf6cb"
11SRC_URI[sha256sum] = "c7e610c800957046c04c8014aab8cce8f0b9f0495c8cd349e57c1f7cabf40e79"
12
13inherit setuptools pypi
14
15# DEPENDS_default: python-pip
16
17DEPENDS += " \
18 python-pip \
19 "
20
21# RDEPENDS_default:
22RDEPENDS_${PN} += " \
23 "
diff --git a/meta-openstack/recipes-devtools/python/python3-wsgiref_0.1.2.bb b/meta-openstack/recipes-devtools/python/python3-wsgiref_0.1.2.bb
new file mode 100644
index 0000000..0fa887a
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-wsgiref_0.1.2.bb
@@ -0,0 +1,2 @@
1require python-wsgiref.inc
2inherit setuptools3