summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorzangrc <zangrc.fnst@cn.fujitsu.com>2020-09-19 05:19:29 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-09-21 17:34:22 -0400
commita0c0b876255ea6be4f6f44f4297fe4f954d62978 (patch)
tree7ee7a0a147291929daad8200b52151010463f66e
parent775e8bd1cac034e2641cf0aa3cd3cdf5bc3900af (diff)
downloadmeta-cloud-services-a0c0b876255ea6be4f6f44f4297fe4f954d62978.tar.gz
python3-httpretty: upgrade 0.9.7 -> 1.0.2
-License-Update: Copyright year updated to 2020. Consolidate inc and bb files into a single bb file. Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--meta-openstack/recipes-devtools/python/python-httpretty.inc18
-rw-r--r--meta-openstack/recipes-devtools/python/python3-httpretty_0.9.7.bb3
-rw-r--r--meta-openstack/recipes-devtools/python/python3-httpretty_1.0.2.bb24
3 files changed, 24 insertions, 21 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-httpretty.inc b/meta-openstack/recipes-devtools/python/python-httpretty.inc
deleted file mode 100644
index 97bd6b3..0000000
--- a/meta-openstack/recipes-devtools/python/python-httpretty.inc
+++ /dev/null
@@ -1,18 +0,0 @@
1#
2# Copyright (C) 2014 Wind River Systems, Inc.
3#
4DESCRIPTION = "HTTP client mock for Python"
5HOMEPAGE = "https://pypi.python.org/pypi/httpretty"
6SECTION = "devel/python"
7LICENSE = "MIT"
8LIC_FILES_CHKSUM = "file://COPYING;md5=113a91608a1d89039af9393c39bcaa2c"
9
10SRC_URI[md5sum] = "2fc3d0dc986200be95ce8ad3ef56bc04"
11SRC_URI[sha256sum] = "66216f26b9d2c52e81808f3e674a6fb65d4bf719721394a1a9be926177e55fbe"
12
13inherit pypi
14
15DEPENDS += " \
16 ${PYTHON_PN}-pip \
17 "
18
diff --git a/meta-openstack/recipes-devtools/python/python3-httpretty_0.9.7.bb b/meta-openstack/recipes-devtools/python/python3-httpretty_0.9.7.bb
deleted file mode 100644
index b9f7699..0000000
--- a/meta-openstack/recipes-devtools/python/python3-httpretty_0.9.7.bb
+++ /dev/null
@@ -1,3 +0,0 @@
1inherit setuptools3
2require python-httpretty.inc
3
diff --git a/meta-openstack/recipes-devtools/python/python3-httpretty_1.0.2.bb b/meta-openstack/recipes-devtools/python/python3-httpretty_1.0.2.bb
new file mode 100644
index 0000000..0b8f192
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-httpretty_1.0.2.bb
@@ -0,0 +1,24 @@
1#
2# Copyright (C) 2014 Wind River Systems, Inc.
3#
4DESCRIPTION = "HTTP client mock for Python"
5HOMEPAGE = "https://pypi.python.org/pypi/httpretty"
6SECTION = "devel/python"
7LICENSE = "MIT"
8LIC_FILES_CHKSUM = "file://COPYING;md5=d87f7868a62b8d598eab40164594d21b"
9
10SRC_URI[md5sum] = "1f6b9b64818837134b93839e5c7051bb"
11SRC_URI[sha256sum] = "24a6fd2fe1c76e94801b74db8f52c0fb42718dc4a199a861b305b1a492b9d868"
12
13inherit setuptools3 pypi
14
15DEPENDS += " \
16 ${PYTHON_PN}-pip \
17 "
18
19RDEPENDS_${PN} = " \
20 ${PYTHON_PN}-crypt \
21 ${PYTHON_PN}-logging \
22 ${PYTHON_PN}-json \
23 ${PYTHON_PN}-typing \
24"