summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorzangrc <zangrc.fnst@cn.fujitsu.com>2020-01-06 11:24:34 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-01-08 16:24:33 -0500
commit9f20e83d6cb2c0937e62d5971e7e4d3586c700e9 (patch)
treea3ad285712f02e2408af610594556ebb4155bd7b
parentc114cb3bc9651d5783c825072154d039c5fd3c30 (diff)
downloadmeta-cloud-services-9f20e83d6cb2c0937e62d5971e7e4d3586c700e9.tar.gz
python-django-appconf: Add python3 version
Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--meta-openstack/recipes-devtools/python/python-django-appconf.inc13
-rw-r--r--meta-openstack/recipes-devtools/python/python-django-appconf_1.0.1.bb15
-rw-r--r--meta-openstack/recipes-devtools/python/python3-django-appconf_1.0.1.bb2
3 files changed, 17 insertions, 13 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-django-appconf.inc b/meta-openstack/recipes-devtools/python/python-django-appconf.inc
new file mode 100644
index 0000000..00f2e3e
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-django-appconf.inc
@@ -0,0 +1,13 @@
1DESCRIPTION = "A helper class for handling configuration defaults of packaged apps gracefully."
2HOMEPAGE = "http://django-appconf.readthedocs.org/"
3SECTION = "devel/python"
4LICENSE = "BSD"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=3f34b9b2f6413fd5f91869fa7e992457"
6
7SRC_URI[md5sum] = "29c87a00f0d098b90f3ac6113ae6e52d"
8SRC_URI[sha256sum] = "ba1375fb1024e8e91547504d4392321795c989fde500b96ebc7c93884f786e60"
9
10inherit pypi
11
12#RDEPENDS_${PN} += "${PYTHON_PN}-six \
13# "
diff --git a/meta-openstack/recipes-devtools/python/python-django-appconf_1.0.1.bb b/meta-openstack/recipes-devtools/python/python-django-appconf_1.0.1.bb
index 2eed747..98aa8f4 100644
--- a/meta-openstack/recipes-devtools/python/python-django-appconf_1.0.1.bb
+++ b/meta-openstack/recipes-devtools/python/python-django-appconf_1.0.1.bb
@@ -1,13 +1,2 @@
1DESCRIPTION = "A helper class for handling configuration defaults of packaged apps gracefully." 1require python-django-appconf.inc
2HOMEPAGE = "http://django-appconf.readthedocs.org/" 2inherit setuptools
3SECTION = "devel/python"
4LICENSE = "BSD"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=3f34b9b2f6413fd5f91869fa7e992457"
6
7SRC_URI[md5sum] = "29c87a00f0d098b90f3ac6113ae6e52d"
8SRC_URI[sha256sum] = "ba1375fb1024e8e91547504d4392321795c989fde500b96ebc7c93884f786e60"
9
10inherit setuptools pypi
11
12#RDEPENDS_${PN} += "python-six \
13# "
diff --git a/meta-openstack/recipes-devtools/python/python3-django-appconf_1.0.1.bb b/meta-openstack/recipes-devtools/python/python3-django-appconf_1.0.1.bb
new file mode 100644
index 0000000..6cc57ba
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-django-appconf_1.0.1.bb
@@ -0,0 +1,2 @@
1require python-django-appconf.inc
2inherit setuptools3