summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorzhengruoqin <zhengrq.fnst@cn.fujitsu.com>2020-09-01 10:46:45 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-09-02 16:34:43 -0400
commit90d9ac9af352458fe591cb1038510c8ce115726d (patch)
tree831ce768aabcd09c0b86f3226b8b8e8d0ed6be2e
parente72c7a5fd8477e155c9044435359cb01bbd43aac (diff)
downloadmeta-cloud-services-90d9ac9af352458fe591cb1038510c8ce115726d.tar.gz
python3-django-openstack-auth: Change to python3
Because python is no longer maintained, delete the python2 version of the recipe and change to python3. Signed-off-by: Zheng Ruoqin <zhengrq.fnst@cn.fujitsu.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--meta-openstack/recipes-devtools/python/python-django-openstack-auth_git.bb32
-rw-r--r--meta-openstack/recipes-devtools/python/python3-django-openstack-auth_3.6.1.bb26
2 files changed, 26 insertions, 32 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-django-openstack-auth_git.bb b/meta-openstack/recipes-devtools/python/python-django-openstack-auth_git.bb
deleted file mode 100644
index 75c26b0..0000000
--- a/meta-openstack/recipes-devtools/python/python-django-openstack-auth_git.bb
+++ /dev/null
@@ -1,32 +0,0 @@
1DESCRIPTION = "A Django authentication backend for use with the OpenStack Keystone backend."
2HOMEPAGE = "http://django_openstack_auth.readthedocs.org/"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
6
7SRCNAME = "django_openstack_auth"
8
9PV = "3.5.0+git${SRCPV}"
10SRCREV = "9e108ed426a5a1e5c9dd394b197c27d046754d0c"
11
12SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=stable/pike \
13"
14
15S = "${WORKDIR}/git"
16
17inherit setuptools3
18
19DEPENDS += " \
20 python-pip \
21 python-pbr \
22 "
23
24RDEPENDS_${PN} += " \
25 python-pbr \
26 python-django \
27 python-oslo.config \
28 python-oslo.policy \
29 python-keystoneclient \
30 python-keystoneauth1 \
31 python-six \
32 "
diff --git a/meta-openstack/recipes-devtools/python/python3-django-openstack-auth_3.6.1.bb b/meta-openstack/recipes-devtools/python/python3-django-openstack-auth_3.6.1.bb
new file mode 100644
index 0000000..4e6c2d2
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-django-openstack-auth_3.6.1.bb
@@ -0,0 +1,26 @@
1DESCRIPTION = "A Django authentication backend for use with the OpenStack Keystone backend."
2HOMEPAGE = "http://django_openstack_auth.readthedocs.org/"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
6
7PYPI_PACKAGE = "django_openstack_auth"
8
9SRC_URI[sha256sum] = "9a441fdea3f662fd727f020f479b3e89c96a2cc442c49539634c996a967dd378"
10
11inherit setuptools3 pypi
12
13DEPENDS += " \
14 python3-pip \
15 python3-pbr-native \
16 "
17
18RDEPENDS_${PN} += " \
19 python3-pbr \
20 python3-django \
21 python3-oslo.config \
22 python3-oslo.policy \
23 python3-keystoneclient \
24 python3-keystoneauth1 \
25 python3-six \
26 "