summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorzangrc <zangrc.fnst@cn.fujitsu.com>2020-09-01 09:57:44 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-09-02 16:33:20 -0400
commit63ea0fd0161b55deecec1a0f55fd1aa31ea4d5e8 (patch)
tree7fd5219834f8002cf811a34ed9ee241c611f2a57
parentc13d33a4bb7cfc39c9bea7a1085e045d6fea3ff8 (diff)
downloadmeta-cloud-services-63ea0fd0161b55deecec1a0f55fd1aa31ea4d5e8.tar.gz
python3-castellan: Change to python3
Because python2 is no longer maintained, bb file is changed to python3 version. Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--meta-openstack/recipes-devtools/python/python-castellan_git.bb40
-rw-r--r--meta-openstack/recipes-devtools/python/python3-castellan_3.4.0.bb33
2 files changed, 33 insertions, 40 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-castellan_git.bb b/meta-openstack/recipes-devtools/python/python-castellan_git.bb
deleted file mode 100644
index 9cc56d7..0000000
--- a/meta-openstack/recipes-devtools/python/python-castellan_git.bb
+++ /dev/null
@@ -1,40 +0,0 @@
1DESCRIPTION = "Generic Key Manager interface for OpenStack"
2HOMEPAGE = "https://github.com/openstack/castellan"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
6
7SRCNAME = "castellan"
8
9SRC_URI = "\
10 git://git.openstack.org/openstack/${SRCNAME}.git;branch=stable/pike \
11 "
12
13PV="0.12.1+git${SRCPV}"
14SRCREV="124e9296fe79412b510c73b35936a6be91267d18"
15S = "${WORKDIR}/git"
16
17inherit setuptools3
18
19DEPENDS += " \
20 python-pip \
21 python-pbr \
22 "
23
24# Satisfy setup.py 'setup_requires'
25DEPENDS += " \
26 python-pbr-native \
27 "
28
29RDEPENDS_${PN} += " \
30 python-pbr \
31 python-babel \
32 python-cryptography \
33 python-barbicanclient \
34 python-oslo.config \
35 python-oslo.context \
36 python-oslo.i18n \
37 python-oslo.log \
38 python-oslo.utils \
39 python-keystoneauth1 \
40 "
diff --git a/meta-openstack/recipes-devtools/python/python3-castellan_3.4.0.bb b/meta-openstack/recipes-devtools/python/python3-castellan_3.4.0.bb
new file mode 100644
index 0000000..062d375
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-castellan_3.4.0.bb
@@ -0,0 +1,33 @@
1DESCRIPTION = "Generic Key Manager interface for OpenStack"
2HOMEPAGE = "https://github.com/openstack/castellan"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
6
7SRC_URI[sha256sum] = "53d39a4ae93c48d26f904f36ae2f3dedde6ad40d34b5f031c23055fff2a1d7f6"
8
9inherit setuptools3 pypi
10
11DEPENDS += " \
12 python3-pip \
13 python3-pbr \
14 "
15
16# Satisfy setup.py 'setup_requires'
17DEPENDS += " \
18 python3-pbr-native \
19 "
20
21RDEPENDS_${PN} += " \
22 python3-pbr \
23 python3-babel \
24 python3-cryptography \
25 python3-barbicanclient \
26 python3-oslo.config \
27 python3-oslo.context \
28 python3-oslo.i18n \
29 python3-oslo.log \
30 python3-oslo.utils \
31 python3-keystoneauth1 \
32 bash \
33 "