summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorzangrc <zangrc.fnst@cn.fujitsu.com>2020-01-14 09:59:37 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-01-15 16:23:55 -0500
commit4b7a13ec30d6a83ddd6527ea55f73168963c5886 (patch)
treea1248e17a6a51417978a4cff446ffcc27076e71c
parent5a98de8c6596433829545483f676c4d56afa44f6 (diff)
downloadmeta-cloud-services-4b7a13ec30d6a83ddd6527ea55f73168963c5886.tar.gz
python-testrepository: Add python3 version
Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--meta-openstack/recipes-devtools/python/python-testrepository.inc17
-rw-r--r--meta-openstack/recipes-devtools/python/python-testrepository_0.0.20.bb18
-rw-r--r--meta-openstack/recipes-devtools/python/python3-testrepository_0.0.20.bb3
3 files changed, 22 insertions, 16 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-testrepository.inc b/meta-openstack/recipes-devtools/python/python-testrepository.inc
new file mode 100644
index 0000000..673141d
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-testrepository.inc
@@ -0,0 +1,17 @@
1DESCRIPTION = "A repository of test results"
2HOMEPAGE = "https://pypi.python.org/pypi/testrepository/"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://COPYING;md5=f19071a777e237c55ec3ab83284b31b8"
6
7SRC_URI[md5sum] = "f648b0aceeca4fcd5f8a62eeedea289b"
8SRC_URI[sha256sum] = "752449bc98c20253ec4611c40564aea93d435a5bf3ff672208e01cc10e5858eb"
9
10inherit pypi
11
12RDEPENDS_${PN} += "${PYTHON_PN}-subunit \
13 ${PYTHON_PN}-extras \
14"
15
16CLEANBROKEN = "1"
17
diff --git a/meta-openstack/recipes-devtools/python/python-testrepository_0.0.20.bb b/meta-openstack/recipes-devtools/python/python-testrepository_0.0.20.bb
index 79be868..3788ce1 100644
--- a/meta-openstack/recipes-devtools/python/python-testrepository_0.0.20.bb
+++ b/meta-openstack/recipes-devtools/python/python-testrepository_0.0.20.bb
@@ -1,17 +1,3 @@
1DESCRIPTION = "A repository of test results" 1require python-testrepository.inc
2HOMEPAGE = "https://pypi.python.org/pypi/testrepository/" 2inherit setuptools
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://COPYING;md5=f19071a777e237c55ec3ab83284b31b8"
6
7SRC_URI[md5sum] = "f648b0aceeca4fcd5f8a62eeedea289b"
8SRC_URI[sha256sum] = "752449bc98c20253ec4611c40564aea93d435a5bf3ff672208e01cc10e5858eb"
9
10inherit setuptools pypi
11
12RDEPENDS_${PN} += "python-subunit \
13 python-extras \
14"
15
16CLEANBROKEN = "1"
17 3
diff --git a/meta-openstack/recipes-devtools/python/python3-testrepository_0.0.20.bb b/meta-openstack/recipes-devtools/python/python3-testrepository_0.0.20.bb
new file mode 100644
index 0000000..a01b4c2
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-testrepository_0.0.20.bb
@@ -0,0 +1,3 @@
1require python-testrepository.inc
2inherit setuptools3
3