summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNathan Hartman <hnathan918@gmail.com>2020-02-20 11:58:00 -0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-02-27 17:15:33 -0500
commit407f66b93514b54f8bf892053054bc8ac7de0abc (patch)
treefd7ff9f74671006af2d023c54e22a791fb820d02
parentef9bc1b0d9664eae819b196f410fc301b456cd02 (diff)
downloadmeta-cloud-services-407f66b93514b54f8bf892053054bc8ac7de0abc.tar.gz
Initial concurrent-ruby, tzinfo and tzinfo-data ruby recipes
Signed-off-by: Nathan Hartman <hnathan918@gmail.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--meta-openstack/recipes-devtools/ruby/concurrent-ruby/0001-Removed-check-for-concurrent_ruby.jar.patch26
-rw-r--r--meta-openstack/recipes-devtools/ruby/concurrent-ruby_1.1.6.bb12
-rw-r--r--meta-openstack/recipes-devtools/ruby/tzinfo-data_1.2019.3.bb11
-rw-r--r--meta-openstack/recipes-devtools/ruby/tzinfo_2.0.1.bb13
4 files changed, 62 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/ruby/concurrent-ruby/0001-Removed-check-for-concurrent_ruby.jar.patch b/meta-openstack/recipes-devtools/ruby/concurrent-ruby/0001-Removed-check-for-concurrent_ruby.jar.patch
new file mode 100644
index 0000000..777dc31
--- /dev/null
+++ b/meta-openstack/recipes-devtools/ruby/concurrent-ruby/0001-Removed-check-for-concurrent_ruby.jar.patch
@@ -0,0 +1,26 @@
1From becf55b5d1ffe7a2856e0c4b240d08a90b2ed573 Mon Sep 17 00:00:00 2001
2From: Nathan Hartman <nathan.hartman@windriver.com>
3Date: Thu, 20 Feb 2020 13:10:02 -0500
4Subject: [PATCH] Removed jar file check
5
6---
7 concurrent-ruby.gemspec | 3 +--
8 1 file changed, 1 insertion(+), 2 deletions(-)
9
10diff --git a/concurrent-ruby.gemspec b/concurrent-ruby.gemspec
11index ad5d0489..1b2aa04e 100644
12--- a/concurrent-ruby.gemspec
13+++ b/concurrent-ruby.gemspec
14@@ -16,8 +16,7 @@ Gem::Specification.new do |s|
15 s.files = [*Dir['lib/concurrent-ruby/**/*.rb'] & git_files,
16 *Dir['ext/concurrent-ruby/**/*'] & git_files,
17 'Rakefile',
18- 'Gemfile',
19- 'lib/concurrent-ruby/concurrent/concurrent_ruby.jar'
20+ 'Gemfile'
21 ]
22 s.extra_rdoc_files = Dir['README*', 'LICENSE*', 'CHANGELOG*']
23 s.require_paths = ['lib/concurrent-ruby']
24--
252.20.1
26
diff --git a/meta-openstack/recipes-devtools/ruby/concurrent-ruby_1.1.6.bb b/meta-openstack/recipes-devtools/ruby/concurrent-ruby_1.1.6.bb
new file mode 100644
index 0000000..a328203
--- /dev/null
+++ b/meta-openstack/recipes-devtools/ruby/concurrent-ruby_1.1.6.bb
@@ -0,0 +1,12 @@
1SUMMARY = "Modern concurrency tools including agents, futures, promises, thread pools, supervisors, and more. Inspired by Erlang, Clojure, Scala, Go, Java, JavaScript, and classic concurrency patterns."
2HOMEPAGE = "http://www.concurrent-ruby.com"
3
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE.md;md5=fde65ae93d18826f70c6fe125aa04297"
6
7SRC_URI = "git://github.com/ruby-concurrency/concurrent-ruby.git;protocol=https;tag=v1.1.6\
8 file://0001-Removed-check-for-concurrent_ruby.jar.patch"
9
10S = "${WORKDIR}/git"
11
12inherit ruby
diff --git a/meta-openstack/recipes-devtools/ruby/tzinfo-data_1.2019.3.bb b/meta-openstack/recipes-devtools/ruby/tzinfo-data_1.2019.3.bb
new file mode 100644
index 0000000..5fb6005
--- /dev/null
+++ b/meta-openstack/recipes-devtools/ruby/tzinfo-data_1.2019.3.bb
@@ -0,0 +1,11 @@
1SUMMARY = "TZInfo::Data - Timezone Data for TZInfo"
2HOMEPAGE = "https://tzinfo.github.io/"
3
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=c326926e773a4e99e89820f5d8a0966f"
6
7SRC_URI = "git://github.com/tzinfo/tzinfo-data.git;protocol=https;tag=v1.2019.3"
8
9S = "${WORKDIR}/git"
10
11inherit ruby
diff --git a/meta-openstack/recipes-devtools/ruby/tzinfo_2.0.1.bb b/meta-openstack/recipes-devtools/ruby/tzinfo_2.0.1.bb
new file mode 100644
index 0000000..2ea1f2d
--- /dev/null
+++ b/meta-openstack/recipes-devtools/ruby/tzinfo_2.0.1.bb
@@ -0,0 +1,13 @@
1SUMMARY = "TZInfo - Ruby Timezone Library"
2HOMEPAGE = "https://tzinfo.github.io/"
3
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=c326926e773a4e99e89820f5d8a0966f"
6
7SRC_URI = "git://github.com/tzinfo/tzinfo.git;protocol=https;tag=v2.0.1"
8
9S = "${WORKDIR}/git"
10
11RDEPENDS_${PN} = "concurrent-ruby"
12
13inherit ruby