summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorzangrc <zangrc.fnst@cn.fujitsu.com>2020-09-19 05:20:55 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-09-21 17:34:21 -0400
commit261526041d2daea7705589202665fbd42a64bf2e (patch)
treed05bedf177917da1a1c116285da9a6b0f75adbb8
parentec061b0d71384842e74446df7da5de32fb1191a1 (diff)
downloadmeta-cloud-services-261526041d2daea7705589202665fbd42a64bf2e.tar.gz
python3-kafka: upgrade 1.4.7 -> 2.0.1
Consolidate inc and bb files into a single bb file. Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--meta-openstack/recipes-devtools/python/python-kafka.inc23
-rw-r--r--meta-openstack/recipes-devtools/python/python3-kafka_git.bb26
2 files changed, 25 insertions, 24 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-kafka.inc b/meta-openstack/recipes-devtools/python/python-kafka.inc
deleted file mode 100644
index 0b360c1..0000000
--- a/meta-openstack/recipes-devtools/python/python-kafka.inc
+++ /dev/null
@@ -1,23 +0,0 @@
1SUMMARY = "Python client for Apache Kafka"
2HOMEPAGE = "https://github.com/mumrah/kafka-python"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5
6PV = "1.4.7+git${SRCPV}"
7SRCREV = "0552b04326c73be29f209c12920ef4cbaceb9818"
8
9SRCNAME = "kafka-python"
10
11LIC_FILES_CHKSUM = "file://LICENSE;md5=22efebb1e053dcc946f4b9d17f3cbbea"
12SRC_URI = "git://github.com/mumrah/${SRCNAME}.git"
13
14S = "${WORKDIR}/git"
15
16DEPENDS += " \
17 ${PYTHON_PN}-pbr \
18 "
19
20RDEPENDS_${PN} += " \
21 ${PYTHON_PN}-six \
22 "
23
diff --git a/meta-openstack/recipes-devtools/python/python3-kafka_git.bb b/meta-openstack/recipes-devtools/python/python3-kafka_git.bb
index 55c9fcb..4fa5c2f 100644
--- a/meta-openstack/recipes-devtools/python/python3-kafka_git.bb
+++ b/meta-openstack/recipes-devtools/python/python3-kafka_git.bb
@@ -1,3 +1,27 @@
1require python-kafka.inc 1SUMMARY = "Python client for Apache Kafka"
2HOMEPAGE = "https://github.com/mumrah/kafka-python"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5
6PV = "2.0.1+git${SRCPV}"
7SRCREV = "fcc9a30c62662cee7aa2c1f69c0d06a9741e2700"
8
9SRCNAME = "kafka-python"
10
11LIC_FILES_CHKSUM = "file://LICENSE;md5=22efebb1e053dcc946f4b9d17f3cbbea"
12SRC_URI = "git://github.com/mumrah/${SRCNAME}.git"
13
14S = "${WORKDIR}/git"
15
2inherit setuptools3 16inherit setuptools3
3 17
18DEPENDS += " \
19 ${PYTHON_PN}-pbr \
20 "
21
22RDEPENDS_${PN} += " \
23 ${PYTHON_PN}-six \
24 ${PYTHON_PN}-logging \
25 ${PYTHON_PN}-compression \
26 "
27