summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2020-01-22 18:02:40 +0000
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-01-22 18:02:40 +0000
commit1d174d4e851b1dc74c4c4778cf7d0c52d1f38142 (patch)
treeb02bc6399a9bb5dfabd6dff33da1a1c41a6b3e0a
parenta401a1c3d86eb00bab8bfccba83c12cc67ce06a1 (diff)
downloadmeta-cloud-services-1d174d4e851b1dc74c4c4778cf7d0c52d1f38142.tar.gz
bbappends: make distro feature safe
Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--meta-openstack/recipes-connectivity/openssh/openssh_%.bbappend11
-rw-r--r--meta-openstack/recipes-connectivity/openssh/openssh_openstack.inc11
-rw-r--r--meta-openstack/recipes-core/base-files/base-files_3.0.14.bbappend14
-rw-r--r--meta-openstack/recipes-core/base-files/base-files_openstack.inc13
-rw-r--r--meta-openstack/recipes-core/initscripts/initscripts_1.0.bbappend11
-rw-r--r--meta-openstack/recipes-core/initscripts/initscripts_openstack.inc10
-rw-r--r--meta-openstack/recipes-extended/iptables/iptables_1.8.%.bbappend4
-rw-r--r--meta-openstack/recipes-extended/iptables/iptables_openstack.inc3
-rw-r--r--meta-openstack/recipes-extended/libpam/libpam_1.%.bbappend22
-rw-r--r--meta-openstack/recipes-extended/libpam/libpam_openstack.inc21
-rw-r--r--meta-openstack/recipes-extended/libvirt/libvirt_5.%.bbappend14
-rw-r--r--meta-openstack/recipes-extended/libvirt/libvirt_openstack.inc13
-rw-r--r--meta-openstack/recipes-extended/lighttpd/lighttpd_1.4.%.bbappend4
-rw-r--r--meta-openstack/recipes-extended/lighttpd/lighttpd_openstack.inc3
-rw-r--r--meta-openstack/recipes-extended/sysklogd/sysklogd_2.%.bbappend7
-rw-r--r--meta-openstack/recipes-extended/sysklogd/sysklogd_openstack.inc6
-rw-r--r--meta-openstack/recipes-kernel/linux/linux-yocto_4.19.bbappend10
-rw-r--r--meta-openstack/recipes-kernel/linux/linux-yocto_5.2.bbappend10
-rw-r--r--meta-openstack/recipes-kernel/linux/linux-yocto_openstack.inc9
-rw-r--r--meta-openstack/recipes-support/bash-completion/bash-completion_2.%.bbappend1
-rw-r--r--meta-openstack/recipes-support/dnsmasq/dnsmasq_2.%.bbappend5
-rw-r--r--meta-openstack/recipes-support/dnsmasq/dnsmasq_openstack.inc4
-rw-r--r--meta-openstack/recipes-support/ebtables/ebtables_2.0.10-4.bbappend8
-rw-r--r--meta-openstack/recipes-support/ebtables/ebtables_openstack.inc7
-rw-r--r--meta-openstack/recipes-support/iproute2/iproute2_5.%.bbappend5
-rw-r--r--meta-openstack/recipes-support/iproute2/iproute2_openstack.inc4
-rw-r--r--meta-openstack/recipes-support/openldap/openldap_2.4.39.bbappend74
-rw-r--r--meta-openstack/recipes-support/openldap/openldap_openstack.inc73
-rw-r--r--meta-openstack/recipes-support/xmlto/xmlto_0.%.bbappend1
29 files changed, 191 insertions, 187 deletions
diff --git a/meta-openstack/recipes-connectivity/openssh/openssh_%.bbappend b/meta-openstack/recipes-connectivity/openssh/openssh_%.bbappend
index 5c0d724..7233019 100644
--- a/meta-openstack/recipes-connectivity/openssh/openssh_%.bbappend
+++ b/meta-openstack/recipes-connectivity/openssh/openssh_%.bbappend
@@ -1,11 +1,2 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/files:" 1require ${@bb.utils.contains('DISTRO_FEATURES', 'openstack', '${BPN}_openstack.inc', '', d)}
2 2
3SRC_URI += "file://mcs-sshd"
4SRC_URI += "file://mcs-sshd_config"
5
6do_install_append() {
7 if ${@bb.utils.contains('DISTRO_FEATURES', 'OpenLDAP', 'true', 'false', d)}; then
8 install -D -m 644 ${WORKDIR}/mcs-sshd ${D}/etc/pam.d/sshd
9 install -D -m 644 ${WORKDIR}/mcs-sshd_config ${D}/etc/ssh/sshd_config
10 fi
11}
diff --git a/meta-openstack/recipes-connectivity/openssh/openssh_openstack.inc b/meta-openstack/recipes-connectivity/openssh/openssh_openstack.inc
new file mode 100644
index 0000000..5c0d724
--- /dev/null
+++ b/meta-openstack/recipes-connectivity/openssh/openssh_openstack.inc
@@ -0,0 +1,11 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
2
3SRC_URI += "file://mcs-sshd"
4SRC_URI += "file://mcs-sshd_config"
5
6do_install_append() {
7 if ${@bb.utils.contains('DISTRO_FEATURES', 'OpenLDAP', 'true', 'false', d)}; then
8 install -D -m 644 ${WORKDIR}/mcs-sshd ${D}/etc/pam.d/sshd
9 install -D -m 644 ${WORKDIR}/mcs-sshd_config ${D}/etc/ssh/sshd_config
10 fi
11}
diff --git a/meta-openstack/recipes-core/base-files/base-files_3.0.14.bbappend b/meta-openstack/recipes-core/base-files/base-files_3.0.14.bbappend
index 0a1b160..025ee4e 100644
--- a/meta-openstack/recipes-core/base-files/base-files_3.0.14.bbappend
+++ b/meta-openstack/recipes-core/base-files/base-files_3.0.14.bbappend
@@ -1,13 +1 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/files:" require ${@bb.utils.contains('DISTRO_FEATURES', 'openstack', '${BPN}_openstack.inc', '', d)}
2
3SRC_URI += "file://nsswitch.conf"
4
5PACKAGECONFIG ?= "${@bb.utils.contains('DISTRO_FEATURES', 'OpenLDAP', 'OpenLDAP', '', d)}"
6PACKAGECONFIG[OpenLDAP] = ",,,nss-pam-ldapd"
7
8do_install_append() {
9 if ${@bb.utils.contains('DISTRO_FEATURES', 'OpenLDAP', 'true', 'false', d)}; then
10 install -m 755 -d ${D}/etc/
11 install -m 644 ${WORKDIR}/nsswitch.conf ${D}/etc/
12 fi
13}
diff --git a/meta-openstack/recipes-core/base-files/base-files_openstack.inc b/meta-openstack/recipes-core/base-files/base-files_openstack.inc
new file mode 100644
index 0000000..0a1b160
--- /dev/null
+++ b/meta-openstack/recipes-core/base-files/base-files_openstack.inc
@@ -0,0 +1,13 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
2
3SRC_URI += "file://nsswitch.conf"
4
5PACKAGECONFIG ?= "${@bb.utils.contains('DISTRO_FEATURES', 'OpenLDAP', 'OpenLDAP', '', d)}"
6PACKAGECONFIG[OpenLDAP] = ",,,nss-pam-ldapd"
7
8do_install_append() {
9 if ${@bb.utils.contains('DISTRO_FEATURES', 'OpenLDAP', 'true', 'false', d)}; then
10 install -m 755 -d ${D}/etc/
11 install -m 644 ${WORKDIR}/nsswitch.conf ${D}/etc/
12 fi
13}
diff --git a/meta-openstack/recipes-core/initscripts/initscripts_1.0.bbappend b/meta-openstack/recipes-core/initscripts/initscripts_1.0.bbappend
index 2174997..025ee4e 100644
--- a/meta-openstack/recipes-core/initscripts/initscripts_1.0.bbappend
+++ b/meta-openstack/recipes-core/initscripts/initscripts_1.0.bbappend
@@ -1,10 +1 @@
1do_install_append() { require ${@bb.utils.contains('DISTRO_FEATURES', 'openstack', '${BPN}_openstack.inc', '', d)}
2
3 echo >> ${D}${sysconfdir}/init.d/functions
4 echo init_is_upstart \(\) \{ >> ${D}${sysconfdir}/init.d/functions
5 echo \ \ \ \ false >> ${D}${sysconfdir}/init.d/functions
6 echo \} >> ${D}${sysconfdir}/init.d/functions
7 echo log_daemon_msg \(\) \{ >> ${D}${sysconfdir}/init.d/functions
8 echo \ \ \ \ echo \$* >> ${D}${sysconfdir}/init.d/functions
9 echo \} >> ${D}${sysconfdir}/init.d/functions
10}
diff --git a/meta-openstack/recipes-core/initscripts/initscripts_openstack.inc b/meta-openstack/recipes-core/initscripts/initscripts_openstack.inc
new file mode 100644
index 0000000..2174997
--- /dev/null
+++ b/meta-openstack/recipes-core/initscripts/initscripts_openstack.inc
@@ -0,0 +1,10 @@
1do_install_append() {
2
3 echo >> ${D}${sysconfdir}/init.d/functions
4 echo init_is_upstart \(\) \{ >> ${D}${sysconfdir}/init.d/functions
5 echo \ \ \ \ false >> ${D}${sysconfdir}/init.d/functions
6 echo \} >> ${D}${sysconfdir}/init.d/functions
7 echo log_daemon_msg \(\) \{ >> ${D}${sysconfdir}/init.d/functions
8 echo \ \ \ \ echo \$* >> ${D}${sysconfdir}/init.d/functions
9 echo \} >> ${D}${sysconfdir}/init.d/functions
10}
diff --git a/meta-openstack/recipes-extended/iptables/iptables_1.8.%.bbappend b/meta-openstack/recipes-extended/iptables/iptables_1.8.%.bbappend
index 2a53557..025ee4e 100644
--- a/meta-openstack/recipes-extended/iptables/iptables_1.8.%.bbappend
+++ b/meta-openstack/recipes-extended/iptables/iptables_1.8.%.bbappend
@@ -1,3 +1 @@
1RRECOMMENDS_${PN} += "kernel-module-xt-conntrack \ require ${@bb.utils.contains('DISTRO_FEATURES', 'openstack', '${BPN}_openstack.inc', '', d)}
2 kernel-module-xt-redirect \
3 "
diff --git a/meta-openstack/recipes-extended/iptables/iptables_openstack.inc b/meta-openstack/recipes-extended/iptables/iptables_openstack.inc
new file mode 100644
index 0000000..2a53557
--- /dev/null
+++ b/meta-openstack/recipes-extended/iptables/iptables_openstack.inc
@@ -0,0 +1,3 @@
1RRECOMMENDS_${PN} += "kernel-module-xt-conntrack \
2 kernel-module-xt-redirect \
3 "
diff --git a/meta-openstack/recipes-extended/libpam/libpam_1.%.bbappend b/meta-openstack/recipes-extended/libpam/libpam_1.%.bbappend
index ec858a7..025ee4e 100644
--- a/meta-openstack/recipes-extended/libpam/libpam_1.%.bbappend
+++ b/meta-openstack/recipes-extended/libpam/libpam_1.%.bbappend
@@ -1,21 +1 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/files:" require ${@bb.utils.contains('DISTRO_FEATURES', 'openstack', '${BPN}_openstack.inc', '', d)}
2
3SRC_URI += "file://common-account"
4SRC_URI += "file://common-auth"
5SRC_URI += "file://common-password"
6SRC_URI += "file://common-session"
7SRC_URI += "file://common-session-noninteractive"
8
9PACKAGECONFIG ?= "${@bb.utils.contains('DISTRO_FEATURES', 'OpenLDAP', 'OpenLDAP', '', d)}"
10PACKAGECONFIG[OpenLDAP] = ",,,pam-plugin-mkhomedir nss-pam-ldapd"
11
12do_install_append() {
13 if ${@bb.utils.contains('DISTRO_FEATURES', 'OpenLDAP', 'true', 'false', d)}; then
14 install -m 755 -d ${D}/etc/pam.d/
15 install -m 644 ${WORKDIR}/common-account ${D}/etc/pam.d/
16 install -m 644 ${WORKDIR}/common-auth ${D}/etc/pam.d/
17 install -m 644 ${WORKDIR}/common-password ${D}/etc/pam.d/
18 install -m 644 ${WORKDIR}/common-session ${D}/etc/pam.d/
19 install -m 644 ${WORKDIR}/common-session-noninteractive ${D}/etc/pam.d/
20 fi
21}
diff --git a/meta-openstack/recipes-extended/libpam/libpam_openstack.inc b/meta-openstack/recipes-extended/libpam/libpam_openstack.inc
new file mode 100644
index 0000000..ec858a7
--- /dev/null
+++ b/meta-openstack/recipes-extended/libpam/libpam_openstack.inc
@@ -0,0 +1,21 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
2
3SRC_URI += "file://common-account"
4SRC_URI += "file://common-auth"
5SRC_URI += "file://common-password"
6SRC_URI += "file://common-session"
7SRC_URI += "file://common-session-noninteractive"
8
9PACKAGECONFIG ?= "${@bb.utils.contains('DISTRO_FEATURES', 'OpenLDAP', 'OpenLDAP', '', d)}"
10PACKAGECONFIG[OpenLDAP] = ",,,pam-plugin-mkhomedir nss-pam-ldapd"
11
12do_install_append() {
13 if ${@bb.utils.contains('DISTRO_FEATURES', 'OpenLDAP', 'true', 'false', d)}; then
14 install -m 755 -d ${D}/etc/pam.d/
15 install -m 644 ${WORKDIR}/common-account ${D}/etc/pam.d/
16 install -m 644 ${WORKDIR}/common-auth ${D}/etc/pam.d/
17 install -m 644 ${WORKDIR}/common-password ${D}/etc/pam.d/
18 install -m 644 ${WORKDIR}/common-session ${D}/etc/pam.d/
19 install -m 644 ${WORKDIR}/common-session-noninteractive ${D}/etc/pam.d/
20 fi
21}
diff --git a/meta-openstack/recipes-extended/libvirt/libvirt_5.%.bbappend b/meta-openstack/recipes-extended/libvirt/libvirt_5.%.bbappend
index 0b0f011..025ee4e 100644
--- a/meta-openstack/recipes-extended/libvirt/libvirt_5.%.bbappend
+++ b/meta-openstack/recipes-extended/libvirt/libvirt_5.%.bbappend
@@ -1,13 +1 @@
1PACKAGECONFIG ?= "qemu lxc test remote macvtap libvirtd udev yajl \ require ${@bb.utils.contains('DISTRO_FEATURES', 'openstack', '${BPN}_openstack.inc', '', d)}
2 python ebtables \
3 ${@bb.utils.contains('DISTRO_FEATURES', 'selinux', 'selinux', '', d)} \
4 "
5
6inherit useradd
7USERADD_PACKAGES = "${PN}"
8GROUPADD_PARAM_${PN}_append = " ;--system libvirt"
9
10do_install_append() {
11 sed -e "s:^#unix_sock_group =:unix_sock_group =:g" -i ${D}/etc/libvirt/libvirtd.conf
12 sed -e "s:^#unix_sock_rw_perms =:unix_sock_rw_perms =:g" -i ${D}/etc/libvirt/libvirtd.conf
13}
diff --git a/meta-openstack/recipes-extended/libvirt/libvirt_openstack.inc b/meta-openstack/recipes-extended/libvirt/libvirt_openstack.inc
new file mode 100644
index 0000000..0b0f011
--- /dev/null
+++ b/meta-openstack/recipes-extended/libvirt/libvirt_openstack.inc
@@ -0,0 +1,13 @@
1PACKAGECONFIG ?= "qemu lxc test remote macvtap libvirtd udev yajl \
2 python ebtables \
3 ${@bb.utils.contains('DISTRO_FEATURES', 'selinux', 'selinux', '', d)} \
4 "
5
6inherit useradd
7USERADD_PACKAGES = "${PN}"
8GROUPADD_PARAM_${PN}_append = " ;--system libvirt"
9
10do_install_append() {
11 sed -e "s:^#unix_sock_group =:unix_sock_group =:g" -i ${D}/etc/libvirt/libvirtd.conf
12 sed -e "s:^#unix_sock_rw_perms =:unix_sock_rw_perms =:g" -i ${D}/etc/libvirt/libvirtd.conf
13}
diff --git a/meta-openstack/recipes-extended/lighttpd/lighttpd_1.4.%.bbappend b/meta-openstack/recipes-extended/lighttpd/lighttpd_1.4.%.bbappend
index 33b1f61..025ee4e 100644
--- a/meta-openstack/recipes-extended/lighttpd/lighttpd_1.4.%.bbappend
+++ b/meta-openstack/recipes-extended/lighttpd/lighttpd_1.4.%.bbappend
@@ -1,3 +1 @@
1do_install_append() { require ${@bb.utils.contains('DISTRO_FEATURES', 'openstack', '${BPN}_openstack.inc', '', d)}
2 sed -i '2i port=`grep "^server.port" /etc/lighttpd.conf`; if [ -z $port ]; then echo "server port not configured, not running lighttpd..."; exit 0; fi' ${D}/etc/init.d/lighttpd
3}
diff --git a/meta-openstack/recipes-extended/lighttpd/lighttpd_openstack.inc b/meta-openstack/recipes-extended/lighttpd/lighttpd_openstack.inc
new file mode 100644
index 0000000..33b1f61
--- /dev/null
+++ b/meta-openstack/recipes-extended/lighttpd/lighttpd_openstack.inc
@@ -0,0 +1,3 @@
1do_install_append() {
2 sed -i '2i port=`grep "^server.port" /etc/lighttpd.conf`; if [ -z $port ]; then echo "server port not configured, not running lighttpd..."; exit 0; fi' ${D}/etc/init.d/lighttpd
3}
diff --git a/meta-openstack/recipes-extended/sysklogd/sysklogd_2.%.bbappend b/meta-openstack/recipes-extended/sysklogd/sysklogd_2.%.bbappend
index 8da640f..025ee4e 100644
--- a/meta-openstack/recipes-extended/sysklogd/sysklogd_2.%.bbappend
+++ b/meta-openstack/recipes-extended/sysklogd/sysklogd_2.%.bbappend
@@ -1,6 +1 @@
1# require ${@bb.utils.contains('DISTRO_FEATURES', 'openstack', '${BPN}_openstack.inc', '', d)}
2# Copyright (C) 2014 Wind River Systems, Inc.
3#
4
5require recipes-extended/syslog/syslog-user.inc
6
diff --git a/meta-openstack/recipes-extended/sysklogd/sysklogd_openstack.inc b/meta-openstack/recipes-extended/sysklogd/sysklogd_openstack.inc
new file mode 100644
index 0000000..8da640f
--- /dev/null
+++ b/meta-openstack/recipes-extended/sysklogd/sysklogd_openstack.inc
@@ -0,0 +1,6 @@
1#
2# Copyright (C) 2014 Wind River Systems, Inc.
3#
4
5require recipes-extended/syslog/syslog-user.inc
6
diff --git a/meta-openstack/recipes-kernel/linux/linux-yocto_4.19.bbappend b/meta-openstack/recipes-kernel/linux/linux-yocto_4.19.bbappend
index 843546c..025ee4e 100644
--- a/meta-openstack/recipes-kernel/linux/linux-yocto_4.19.bbappend
+++ b/meta-openstack/recipes-kernel/linux/linux-yocto_4.19.bbappend
@@ -1,9 +1 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" require ${@bb.utils.contains('DISTRO_FEATURES', 'openstack', '${BPN}_openstack.inc', '', d)}
2
3SRC_URI += "file://enable-veth.cfg \
4 file://enable-iscsi-tcp.cfg \
5 file://enable-nbd.cfg \
6 file://enable-rtlink.cfg \
7 file://nf.scc \
8 file://nfs.scc \
9 "
diff --git a/meta-openstack/recipes-kernel/linux/linux-yocto_5.2.bbappend b/meta-openstack/recipes-kernel/linux/linux-yocto_5.2.bbappend
index 843546c..025ee4e 100644
--- a/meta-openstack/recipes-kernel/linux/linux-yocto_5.2.bbappend
+++ b/meta-openstack/recipes-kernel/linux/linux-yocto_5.2.bbappend
@@ -1,9 +1 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" require ${@bb.utils.contains('DISTRO_FEATURES', 'openstack', '${BPN}_openstack.inc', '', d)}
2
3SRC_URI += "file://enable-veth.cfg \
4 file://enable-iscsi-tcp.cfg \
5 file://enable-nbd.cfg \
6 file://enable-rtlink.cfg \
7 file://nf.scc \
8 file://nfs.scc \
9 "
diff --git a/meta-openstack/recipes-kernel/linux/linux-yocto_openstack.inc b/meta-openstack/recipes-kernel/linux/linux-yocto_openstack.inc
new file mode 100644
index 0000000..843546c
--- /dev/null
+++ b/meta-openstack/recipes-kernel/linux/linux-yocto_openstack.inc
@@ -0,0 +1,9 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3SRC_URI += "file://enable-veth.cfg \
4 file://enable-iscsi-tcp.cfg \
5 file://enable-nbd.cfg \
6 file://enable-rtlink.cfg \
7 file://nf.scc \
8 file://nfs.scc \
9 "
diff --git a/meta-openstack/recipes-support/bash-completion/bash-completion_2.%.bbappend b/meta-openstack/recipes-support/bash-completion/bash-completion_2.%.bbappend
deleted file mode 100644
index 7447c56..0000000
--- a/meta-openstack/recipes-support/bash-completion/bash-completion_2.%.bbappend
+++ /dev/null
@@ -1 +0,0 @@
1inherit autotools-brokensep
diff --git a/meta-openstack/recipes-support/dnsmasq/dnsmasq_2.%.bbappend b/meta-openstack/recipes-support/dnsmasq/dnsmasq_2.%.bbappend
index 0c979fe..025ee4e 100644
--- a/meta-openstack/recipes-support/dnsmasq/dnsmasq_2.%.bbappend
+++ b/meta-openstack/recipes-support/dnsmasq/dnsmasq_2.%.bbappend
@@ -1,4 +1 @@
1do_install_append() { require ${@bb.utils.contains('DISTRO_FEATURES', 'openstack', '${BPN}_openstack.inc', '', d)}
2 # Remove /var/run as it is created on startup
3 rm -rf ${D}${localstatedir}/run
4}
diff --git a/meta-openstack/recipes-support/dnsmasq/dnsmasq_openstack.inc b/meta-openstack/recipes-support/dnsmasq/dnsmasq_openstack.inc
new file mode 100644
index 0000000..0c979fe
--- /dev/null
+++ b/meta-openstack/recipes-support/dnsmasq/dnsmasq_openstack.inc
@@ -0,0 +1,4 @@
1do_install_append() {
2 # Remove /var/run as it is created on startup
3 rm -rf ${D}${localstatedir}/run
4}
diff --git a/meta-openstack/recipes-support/ebtables/ebtables_2.0.10-4.bbappend b/meta-openstack/recipes-support/ebtables/ebtables_2.0.10-4.bbappend
index 9f6f2e6..025ee4e 100644
--- a/meta-openstack/recipes-support/ebtables/ebtables_2.0.10-4.bbappend
+++ b/meta-openstack/recipes-support/ebtables/ebtables_2.0.10-4.bbappend
@@ -1,7 +1 @@
1RRECOMMENDS_${PN} += " \ require ${@bb.utils.contains('DISTRO_FEATURES', 'openstack', '${BPN}_openstack.inc', '', d)}
2 kernel-module-ebtables \
3 kernel-module-ebtable-nat \
4 kernel-module-ebt-arp \
5 kernel-module-ebt-ip \
6 "
7
diff --git a/meta-openstack/recipes-support/ebtables/ebtables_openstack.inc b/meta-openstack/recipes-support/ebtables/ebtables_openstack.inc
new file mode 100644
index 0000000..9f6f2e6
--- /dev/null
+++ b/meta-openstack/recipes-support/ebtables/ebtables_openstack.inc
@@ -0,0 +1,7 @@
1RRECOMMENDS_${PN} += " \
2 kernel-module-ebtables \
3 kernel-module-ebtable-nat \
4 kernel-module-ebt-arp \
5 kernel-module-ebt-ip \
6 "
7
diff --git a/meta-openstack/recipes-support/iproute2/iproute2_5.%.bbappend b/meta-openstack/recipes-support/iproute2/iproute2_5.%.bbappend
index 2fde00d..025ee4e 100644
--- a/meta-openstack/recipes-support/iproute2/iproute2_5.%.bbappend
+++ b/meta-openstack/recipes-support/iproute2/iproute2_5.%.bbappend
@@ -1,4 +1 @@
1FILESEXTRAPATHS_append := "${THISDIR}/${PN}" require ${@bb.utils.contains('DISTRO_FEATURES', 'openstack', '${BPN}_openstack.inc', '', d)}
2
3RRECOMMENDS_${PN} += "kernel-module-veth \
4 "
diff --git a/meta-openstack/recipes-support/iproute2/iproute2_openstack.inc b/meta-openstack/recipes-support/iproute2/iproute2_openstack.inc
new file mode 100644
index 0000000..2fde00d
--- /dev/null
+++ b/meta-openstack/recipes-support/iproute2/iproute2_openstack.inc
@@ -0,0 +1,4 @@
1FILESEXTRAPATHS_append := "${THISDIR}/${PN}"
2
3RRECOMMENDS_${PN} += "kernel-module-veth \
4 "
diff --git a/meta-openstack/recipes-support/openldap/openldap_2.4.39.bbappend b/meta-openstack/recipes-support/openldap/openldap_2.4.39.bbappend
index 63f6064..025ee4e 100644
--- a/meta-openstack/recipes-support/openldap/openldap_2.4.39.bbappend
+++ b/meta-openstack/recipes-support/openldap/openldap_2.4.39.bbappend
@@ -1,73 +1 @@
1DEPEND_${PN} += "cyrus-sasl" require ${@bb.utils.contains('DISTRO_FEATURES', 'openstack', '${BPN}_openstack.inc', '', d)}
2RDEPEND_${PN} += "libsasl2-modules"
3
4FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
5SRC_URI += "file://initscript"
6SRC_URI += "file://ops-base.ldif"
7
8LDAP_DN ?= "dc=my-domain,dc=com"
9LDAP_DATADIR ?= "/etc/openldap-data/"
10
11OPENLDAP_LIBEXECDIR = "${libexecdir}"
12
13EXTRA_OECONF += "--libexecdir=${OPENLDAP_LIBEXECDIR}"
14
15do_install_append() {
16 install -D -m 0755 ${WORKDIR}/initscript ${D}${sysconfdir}/init.d/openldap
17 sed -i -e 's/%DEFAULT_DN%/${LDAP_DN}/g' ${D}${sysconfdir}/init.d/openldap
18 sed -i -e 's#%LDAP_DATADIR%#${LDAP_DATADIR}#g' ${D}${sysconfdir}/init.d/openldap
19 # Base openldat bb installs slapd under ${sbin}
20 sed -i -e 's#%LIBEXEC%#${sbindir}#g' ${D}${sysconfdir}/init.d/openldap
21
22 # This is duplicated in /etc/openldap and is for slapd
23 rm -f ${D}${localstatedir}/openldap-data/DB_CONFIG.example
24 rm -rf "${D}${localstatedir}/run"
25 rmdir --ignore-fail-on-non-empty "${D}${localstatedir}"
26
27 # remove symlinks for backends, recreating in postinstall
28 rm -f ${D}/${OPENLDAP_LIBEXECDIR}/openldap/*.so
29
30 sed -i -e '/^include\s*/a \
31include /etc/openldap/schema/cosine.schema \
32include /etc/openldap/schema/nis.schema \
33include /etc/openldap/schema/inetorgperson.schema \
34include /etc/openldap/schema/misc.schema' \
35 ${D}/etc/openldap/slapd.conf
36
37 sed -i -e '/^# Load dynamic backend modules:/a \
38modulepath ${OPENLDAP_LIBEXECDIR}/openldap \
39moduleload back_bdb.la' \
40 ${D}/etc/openldap/slapd.conf
41
42 sed -i -e 's#^pidfile\s*.*$#pidfile ${LDAP_DATADIR}/slapd.pid#' ${D}/etc/openldap/slapd.conf
43 sed -i -e 's#^argsfile\s*.*$#argsfile ${LDAP_DATADIR}/slapd.args#' ${D}/etc/openldap/slapd.conf
44 sed -i -e 's#^directory\s*.*$#directory ${LDAP_DATADIR}/#' ${D}/etc/openldap/slapd.conf
45
46 sed -i -e 's/dc=my-domain,dc=com/${LDAP_DN}/g' ${D}/etc/openldap/slapd.conf
47
48 # modify access perms for ldap/authentication
49 sed -i -e '$a\
50\
51access to attrs=userPassword \
52 by self write \
53 by anonymous auth \
54 by * none \
55\
56access to * \
57 by self write \
58 by * read' \
59 ${D}/etc/openldap/slapd.conf
60
61 install -D -m 0644 ${WORKDIR}/ops-base.ldif ${D}/etc/openldap/ops-base.ldif
62 sed -i -e 's/dc=my-domain,dc=com/${LDAP_DN}/g' ${D}/etc/openldap/ops-base.ldif
63
64 mkdir ${D}/${LDAP_DATADIR}
65}
66
67inherit update-rc.d
68
69INITSCRIPT_NAME = "openldap"
70INITSCRIPT_PARAMS = "defaults"
71
72FILES_${PN} += "${OPENLDAP_LIBEXECDIR}/* ${sysconfdir}/openldap/ops-base.ldif"
73FILES_${PN}-dbg += "${OPENLDAP_LIBEXECDIR}/openldap/.debug ${OPENLDAP_LIBEXECDIR}/.debug"
diff --git a/meta-openstack/recipes-support/openldap/openldap_openstack.inc b/meta-openstack/recipes-support/openldap/openldap_openstack.inc
new file mode 100644
index 0000000..63f6064
--- /dev/null
+++ b/meta-openstack/recipes-support/openldap/openldap_openstack.inc
@@ -0,0 +1,73 @@
1DEPEND_${PN} += "cyrus-sasl"
2RDEPEND_${PN} += "libsasl2-modules"
3
4FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
5SRC_URI += "file://initscript"
6SRC_URI += "file://ops-base.ldif"
7
8LDAP_DN ?= "dc=my-domain,dc=com"
9LDAP_DATADIR ?= "/etc/openldap-data/"
10
11OPENLDAP_LIBEXECDIR = "${libexecdir}"
12
13EXTRA_OECONF += "--libexecdir=${OPENLDAP_LIBEXECDIR}"
14
15do_install_append() {
16 install -D -m 0755 ${WORKDIR}/initscript ${D}${sysconfdir}/init.d/openldap
17 sed -i -e 's/%DEFAULT_DN%/${LDAP_DN}/g' ${D}${sysconfdir}/init.d/openldap
18 sed -i -e 's#%LDAP_DATADIR%#${LDAP_DATADIR}#g' ${D}${sysconfdir}/init.d/openldap
19 # Base openldat bb installs slapd under ${sbin}
20 sed -i -e 's#%LIBEXEC%#${sbindir}#g' ${D}${sysconfdir}/init.d/openldap
21
22 # This is duplicated in /etc/openldap and is for slapd
23 rm -f ${D}${localstatedir}/openldap-data/DB_CONFIG.example
24 rm -rf "${D}${localstatedir}/run"
25 rmdir --ignore-fail-on-non-empty "${D}${localstatedir}"
26
27 # remove symlinks for backends, recreating in postinstall
28 rm -f ${D}/${OPENLDAP_LIBEXECDIR}/openldap/*.so
29
30 sed -i -e '/^include\s*/a \
31include /etc/openldap/schema/cosine.schema \
32include /etc/openldap/schema/nis.schema \
33include /etc/openldap/schema/inetorgperson.schema \
34include /etc/openldap/schema/misc.schema' \
35 ${D}/etc/openldap/slapd.conf
36
37 sed -i -e '/^# Load dynamic backend modules:/a \
38modulepath ${OPENLDAP_LIBEXECDIR}/openldap \
39moduleload back_bdb.la' \
40 ${D}/etc/openldap/slapd.conf
41
42 sed -i -e 's#^pidfile\s*.*$#pidfile ${LDAP_DATADIR}/slapd.pid#' ${D}/etc/openldap/slapd.conf
43 sed -i -e 's#^argsfile\s*.*$#argsfile ${LDAP_DATADIR}/slapd.args#' ${D}/etc/openldap/slapd.conf
44 sed -i -e 's#^directory\s*.*$#directory ${LDAP_DATADIR}/#' ${D}/etc/openldap/slapd.conf
45
46 sed -i -e 's/dc=my-domain,dc=com/${LDAP_DN}/g' ${D}/etc/openldap/slapd.conf
47
48 # modify access perms for ldap/authentication
49 sed -i -e '$a\
50\
51access to attrs=userPassword \
52 by self write \
53 by anonymous auth \
54 by * none \
55\
56access to * \
57 by self write \
58 by * read' \
59 ${D}/etc/openldap/slapd.conf
60
61 install -D -m 0644 ${WORKDIR}/ops-base.ldif ${D}/etc/openldap/ops-base.ldif
62 sed -i -e 's/dc=my-domain,dc=com/${LDAP_DN}/g' ${D}/etc/openldap/ops-base.ldif
63
64 mkdir ${D}/${LDAP_DATADIR}
65}
66
67inherit update-rc.d
68
69INITSCRIPT_NAME = "openldap"
70INITSCRIPT_PARAMS = "defaults"
71
72FILES_${PN} += "${OPENLDAP_LIBEXECDIR}/* ${sysconfdir}/openldap/ops-base.ldif"
73FILES_${PN}-dbg += "${OPENLDAP_LIBEXECDIR}/openldap/.debug ${OPENLDAP_LIBEXECDIR}/.debug"
diff --git a/meta-openstack/recipes-support/xmlto/xmlto_0.%.bbappend b/meta-openstack/recipes-support/xmlto/xmlto_0.%.bbappend
deleted file mode 100644
index 7447c56..0000000
--- a/meta-openstack/recipes-support/xmlto/xmlto_0.%.bbappend
+++ /dev/null
@@ -1 +0,0 @@
1inherit autotools-brokensep