summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSergey Kizunov <sergey.kizunov@ni.com>2018-08-20 19:00:22 +0300
committerBruce Ashfield <bruce.ashfield@windriver.com>2018-08-28 08:21:28 -0400
commitf363842dd3bd92e0ca5d80543b823fbc8abd5522 (patch)
treea2d108a8244054f64e1dab580ac1f6e13fb3c851
parent0a2c5674f18e76485030339ef27f57e9a807afba (diff)
downloadmeta-cloud-services-f363842dd3bd92e0ca5d80543b823fbc8abd5522.tar.gz
python-pytest-salt: add recipe
Signed-off-by: Sergey Kizunov <sergey.kizunov@ni.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--meta-openstack/recipes-devtools/python/python-pytest-salt_2017.7.0.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-pytest-salt_2017.7.0.bb b/meta-openstack/recipes-devtools/python/python-pytest-salt_2017.7.0.bb
new file mode 100644
index 0000000..e2cf1cd
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-pytest-salt_2017.7.0.bb
@@ -0,0 +1,23 @@
1SUMMARY = "This pytest plugin will allow the Salt Daemons to be used in tests."
2HOMEPAGE = "https://github.com/saltstack/pytest-salt"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=fa818a259cbed7ce8bc2a22d35a464fc"
6
7SRCNAME = "pytest-salt"
8SRC_URI = "git://github.com/saltstack/${SRCNAME}.git;branch=master"
9
10SRC_URI[md5sum] = "c598d7db87ea52cdeb067d7596b3b0b1"
11SRC_URI[sha256sum] = "7052459cda9fbdbbfff9a25b24243b0b96cf56835a2c41135d754cc5b65e2494"
12
13SRCREV = "feb5031f80cf84b113ebe69543cdd44b6a373d21"
14S = "${WORKDIR}/git"
15
16inherit setuptools
17
18RDEPENDS_${PN} = " \
19 python-pytest \
20 python-pytest-tempdir \
21 python-pytest-helpers-namespace \
22 python-psutil \
23 "