summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlejandro del Castillo <alejandro.delcastillo@ni.com>2018-08-27 15:12:26 +0300
committerBruce Ashfield <bruce.ashfield@windriver.com>2018-08-28 08:21:29 -0400
commitdab173f71827a7c3ac2381f08c016bd38ef0665e (patch)
treec74252f973d1a0c7e07989b7fbe72f5fd8b21b8a
parenta15b423499cdbb16fff8b79f7bae2cadc53ccebc (diff)
downloadmeta-cloud-services-dab173f71827a7c3ac2381f08c016bd38ef0665e.tar.gz
python3-avahi: add recipe
Signed-off-by: Alejandro del Castillo <alejandro.delcastillo@ni.com> Signed-off-by: Ioan-Adrian Ratiu <adrian.ratiu@ni.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--meta-openstack/recipes-devtools/python/python-avahi.inc32
-rw-r--r--meta-openstack/recipes-devtools/python/python-avahi_0.6.32.bb33
-rw-r--r--meta-openstack/recipes-devtools/python/python3-avahi_0.6.32.bb5
3 files changed, 39 insertions, 31 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-avahi.inc b/meta-openstack/recipes-devtools/python/python-avahi.inc
new file mode 100644
index 0000000..86cafe5
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-avahi.inc
@@ -0,0 +1,32 @@
1SUMMARY = "Python bindings for the avahi zeroconf client"
2HOMEPAGE = "https://github.com/lathiat/avahi"
3SECTION = "devel/python"
4
5LICENSE = "GPLv2+"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=2d5025d4aa3495befef8f17206a5b0a1"
7
8SRC_URI = "https://github.com/lathiat/avahi/releases/download/v${PV}/avahi-${PV}.tar.gz"
9
10SRC_URI[md5sum] = "22b5e705d3eabb31d26f2e1e7b074013"
11SRC_URI[sha256sum] = "d54991185d514a0aba54ebeb408d7575b60f5818a772e28fa0e18b98bc1db454"
12
13S = "${WORKDIR}/avahi-${PV}"
14
15inherit pythonnative
16
17# we only need the python bindings
18do_install () {
19 install -d ${D}${PYTHON_SITEPACKAGES_DIR}/avahi
20
21 sed -i'' -e "s,@PYTHON\@,${bindir}/${PYTHON_PN},g" \
22 ${S}/avahi-python/avahi/__init__.py \
23 ${S}/avahi-python/avahi-bookmarks.in
24
25 install -m 0775 ${S}/avahi-python/avahi/__init__.py \
26 ${D}${PYTHON_SITEPACKAGES_DIR}/avahi/__init__.py
27
28 install -m 0775 ${S}/avahi-python/avahi-bookmarks.in \
29 ${D}${PYTHON_SITEPACKAGES_DIR}/avahi/avahi-bookmarks
30}
31
32FILES_${PN} = "${PYTHON_SITEPACKAGES_DIR}/avahi"
diff --git a/meta-openstack/recipes-devtools/python/python-avahi_0.6.32.bb b/meta-openstack/recipes-devtools/python/python-avahi_0.6.32.bb
index c129337..7a54211 100644
--- a/meta-openstack/recipes-devtools/python/python-avahi_0.6.32.bb
+++ b/meta-openstack/recipes-devtools/python/python-avahi_0.6.32.bb
@@ -1,34 +1,5 @@
1SUMMARY = "Python bindings for the avahi zeroconf client" 1require python-avahi.inc
2HOMEPAGE = "https://github.com/lathiat/avahi"
3SECTION = "devel/python"
4 2
5LICENSE = "GPLv2+" 3inherit python-dir
6LIC_FILES_CHKSUM = "file://LICENSE;md5=2d5025d4aa3495befef8f17206a5b0a1"
7
8SRC_URI = "https://github.com/lathiat/avahi/releases/download/v${PV}/avahi-${PV}.tar.gz"
9
10SRC_URI[md5sum] = "22b5e705d3eabb31d26f2e1e7b074013"
11SRC_URI[sha256sum] = "d54991185d514a0aba54ebeb408d7575b60f5818a772e28fa0e18b98bc1db454"
12
13S = "${WORKDIR}/avahi-${PV}"
14
15inherit python-dir pythonnative
16
17# we only need the python bindings
18do_install () {
19 install -d ${D}${PYTHON_SITEPACKAGES_DIR}/avahi
20
21 sed -i'' -e "s,@PYTHON\@,${bindir}/python,g" \
22 ${S}/avahi-python/avahi/__init__.py \
23 ${S}/avahi-python/avahi-bookmarks.in
24
25 install -m 0775 ${S}/avahi-python/avahi/__init__.py \
26 ${D}${PYTHON_SITEPACKAGES_DIR}/avahi/__init__.py
27
28 install -m 0775 ${S}/avahi-python/avahi-bookmarks.in \
29 ${D}${PYTHON_SITEPACKAGES_DIR}/avahi/avahi-bookmarks
30}
31 4
32RDEPENDS_${PN} += "python-core python-dbus" 5RDEPENDS_${PN} += "python-core python-dbus"
33
34FILES_${PN} = "${PYTHON_SITEPACKAGES_DIR}/avahi"
diff --git a/meta-openstack/recipes-devtools/python/python3-avahi_0.6.32.bb b/meta-openstack/recipes-devtools/python/python3-avahi_0.6.32.bb
new file mode 100644
index 0000000..4b85cd5
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-avahi_0.6.32.bb
@@ -0,0 +1,5 @@
1require python-avahi.inc
2
3inherit python3-dir
4
5RDEPENDS_${PN} += "python3-core python3-dbus"