summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2018-09-18 16:27:30 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2018-09-25 17:40:49 -0400
commitd684262a05535e41c017fde24a6d5348e8aed3c9 (patch)
tree81b2fe033773c0057328962f619b6e11160a2a86
parent910feebbed4444237fb40d891d008beae0fedfe8 (diff)
downloadmeta-cloud-services-d684262a05535e41c017fde24a6d5348e8aed3c9.tar.gz
consul-migrate: use SRC_URIs not DEPENDS
It is common to have two GO packages, A and B, and they both depend on a GO dependency, C. This can be satisfied using the current technique of writing recipes for each dependency. BUT it is also common for GO packages to not only specify other packages in their GoDeps but also specific dependency versions. In the case that A and B share a dependency on C, but require different versions, there is no easy way to accomplish this using recipes. Since GO dependencies are also source dependencies and these dependencies are overwhelmingly useless on their own, writing recipes for each is overkill. We therefor replace DEPENDS with SRC_URIs and SRCREVs as a mechanism to provide build dependencies. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--recipes-connectivity/consul/consul-migrate_git.bb20
1 files changed, 18 insertions, 2 deletions
diff --git a/recipes-connectivity/consul/consul-migrate_git.bb b/recipes-connectivity/consul/consul-migrate_git.bb
index 4cc53b2..935d663 100644
--- a/recipes-connectivity/consul/consul-migrate_git.bb
+++ b/recipes-connectivity/consul/consul-migrate_git.bb
@@ -3,12 +3,28 @@ HOMEPAGE = "https://github.com/hashicorp/consul-migrate"
3LICENSE = "MPL-2.0" 3LICENSE = "MPL-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=b278a92d2c1509760384428817710378" 4LIC_FILES_CHKSUM = "file://LICENSE;md5=b278a92d2c1509760384428817710378"
5 5
6DEPENDS += "raft raft-boltdb raft-mdb"
7
8PKG_NAME = "github.com/hashicorp/consul-migrate" 6PKG_NAME = "github.com/hashicorp/consul-migrate"
9SRC_URI = "git://${PKG_NAME}.git" 7SRC_URI = "git://${PKG_NAME}.git"
10SRCREV = "678fb10cdeae25ab309e99e655148f0bf65f9710" 8SRCREV = "678fb10cdeae25ab309e99e655148f0bf65f9710"
11 9
10SRCREV_raft = "057b893fd996696719e98b6c44649ea14968c811"
11SRCREV_go-metrics = "f303b03b91d770a11a39677f1d3b55da4002bbcb"
12SRCREV_raft-boltdb = "d1e82c1ec3f15ee991f7cc7ffd5b67ff6f5bbaee"
13SRCREV_raft-mdb = "4ec3694ffbc74d34f7532e70ef2e9c3546a0c0b0"
14SRCREV_gomdb = "151f2e08ef45cb0e57d694b2562f351955dff572"
15SRCREV_bolt = "c6ba97b89e0454fec9aa92e1d33a4e2c5fc1f631"
16SRCREV_go-msgpack = "fa3f63826f7c23912c15263591e65d54d080b458"
17
18SRC_URI += " \
19 git://github.com/hashicorp/raft;name=raft;destsuffix=git/src/github.com/hashicorp/raft \
20 git://github.com/armon/go-metrics;name=go-metrics;destsuffix=git/src/github.com/armon/go-metrics \
21 git://github.com/hashicorp/raft-boltdb;name=raft-boltdb;destsuffix=git/src/github.com/hashicorp/raft-boltdb \
22 git://github.com/hashicorp/raft-mdb;name=raft-mdb;destsuffix=git/src/github.com/hashicorp/raft-mdb \
23 git://github.com/armon/gomdb;name=gomdb;destsuffix=git/src/github.com/armon/gomdb \
24 git://github.com/boltdb/bolt;name=bolt;destsuffix=git/src/github.com/boltdb/bolt \
25 git://github.com/hashicorp/go-msgpack;name=go-msgpack;destsuffix=git/src/github.com/hashicorp/go-msgpack \
26"
27
12inherit golang 28inherit golang
13 29
14SYSROOT_PREPROCESS_FUNCS += "consul_migrate_sysroot_preprocess" 30SYSROOT_PREPROCESS_FUNCS += "consul_migrate_sysroot_preprocess"