summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2018-09-18 16:27:29 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2018-09-25 17:40:49 -0400
commit910feebbed4444237fb40d891d008beae0fedfe8 (patch)
tree68c5a0bbeb6eb93fdcdc89c4f707115c7d0d8064
parent0d3cfe980456267921c145068cd854e1cd60d687 (diff)
downloadmeta-cloud-services-910feebbed4444237fb40d891d008beae0fedfe8.tar.gz
consul: update to use go.bbclass
We don't want meta-cloud-services to have to rely on meta-overc for access to golang.bbclass (which predates go.bbclass in oe-core/yocto) so switch to make use of go.bbclass. This requires the definition of GO_IMPORT and the dropping of some custom handling of 'configure' and others. Since go.bbclass uses a slighly different directory structure than we used with golang.bbclass we have to adjust some paths accordingly, including those in patches. We also need to expand the list of LICENSES to cover licenses of all the GO packages included in consul. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--recipes-connectivity/consul/consul_git.bb22
-rw-r--r--recipes-connectivity/consul/files/0001-prepared_query-make-compatible-with-go1.5.patch8
2 files changed, 11 insertions, 19 deletions
diff --git a/recipes-connectivity/consul/consul_git.bb b/recipes-connectivity/consul/consul_git.bb
index 5f86597..a44e0b2 100644
--- a/recipes-connectivity/consul/consul_git.bb
+++ b/recipes-connectivity/consul/consul_git.bb
@@ -1,30 +1,22 @@
1DESCRIPTION = "A tool for discovering and configuring services in your infrastructure" 1DESCRIPTION = "A tool for discovering and configuring services in your infrastructure"
2HOMEPAGE = "https://www.consul.io/" 2HOMEPAGE = "https://www.consul.io/"
3LICENSE = "MPL-2.0" 3LICENSE = "MPL-2.0 & BSD & Apache-2.0 & BSD-2-Clause & MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=b278a92d2c1509760384428817710378" 4LIC_FILES_CHKSUM = "file://src/github.com/hashicorp/consul/LICENSE;md5=b278a92d2c1509760384428817710378"
5 5
6PKG_NAME = "github.com/hashicorp/consul" 6GO_IMPORT = "github.com/hashicorp/consul"
7SRC_URI = "git://${PKG_NAME}.git \ 7SRCREV = "f97afda8e15046b41d951bf3b4220372c45df7ab"
8SRC_URI = "git://${GO_IMPORT}.git \
8 file://consul.service \ 9 file://consul.service \
9 file://0001-prepared_query-make-compatible-with-go1.5.patch \ 10 file://0001-prepared_query-make-compatible-with-go1.5.patch \
10 " 11 "
11SRCREV = "f97afda8e15046b41d951bf3b4220372c45df7ab"
12
13CCACHE = ""
14 12
15inherit systemd golang 13S = "${WORKDIR}/git"
16 14
17INSANE_SKIP_${PN} += "ldflags" 15inherit systemd go
18 16
19SYSTEMD_SERVICE_${PN} = "consul.service" 17SYSTEMD_SERVICE_${PN} = "consul.service"
20SYSTEMD_AUTO_ENABLE_${PN} = "enable" 18SYSTEMD_AUTO_ENABLE_${PN} = "enable"
21 19
22export GOROOT="${STAGING_DIR_NATIVE}/${nonarch_libdir}/${HOST_SYS}/go"
23
24#Stops go from installing and testing the package
25do_configure(){
26}
27
28do_install_append() { 20do_install_append() {
29 install -d ${D}/${systemd_unitdir}/system 21 install -d ${D}/${systemd_unitdir}/system
30 cp ${WORKDIR}/consul.service ${D}/${systemd_unitdir}/system 22 cp ${WORKDIR}/consul.service ${D}/${systemd_unitdir}/system
diff --git a/recipes-connectivity/consul/files/0001-prepared_query-make-compatible-with-go1.5.patch b/recipes-connectivity/consul/files/0001-prepared_query-make-compatible-with-go1.5.patch
index a66e1dc..324530b 100644
--- a/recipes-connectivity/consul/files/0001-prepared_query-make-compatible-with-go1.5.patch
+++ b/recipes-connectivity/consul/files/0001-prepared_query-make-compatible-with-go1.5.patch
@@ -8,13 +8,13 @@ lock contention, so we drop the copy and use the regex directly.
8 8
9Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> 9Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
10--- 10---
11 consul/prepared_query/template.go | 4 ++-- 11 src/github.com/hashicorp/consul/consul/prepared_query/template.go | 4 ++--
12 1 file changed, 2 insertions(+), 2 deletions(-) 12 1 file changed, 2 insertions(+), 2 deletions(-)
13 13
14diff --git a/consul/prepared_query/template.go b/consul/prepared_query/template.go 14diff --git a/src/github.com/hashicorp/consul/consul/prepared_query/template.go b/src/github.com/hashicorp/consul/consul/prepared_query/template.go
15index 984f0bcf9cc6..1c61910c1526 100644 15index 984f0bcf9cc6..1c61910c1526 100644
16--- a/consul/prepared_query/template.go 16--- a/src/github.com/hashicorp/consul/consul/prepared_query/template.go
17+++ b/consul/prepared_query/template.go 17+++ b/src/github.com/hashicorp/consul/consul/prepared_query/template.go
18@@ -116,8 +116,8 @@ func (ct *CompiledTemplate) Render(name string) (*structs.PreparedQuery, error) 18@@ -116,8 +116,8 @@ func (ct *CompiledTemplate) Render(name string) (*structs.PreparedQuery, error)
19 // from multiple goroutines. 19 // from multiple goroutines.
20 var matches []string 20 var matches []string