summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChangqing Li <changqing.li@windriver.com>2018-10-10 14:59:09 +0800
committerBruce Ashfield <bruce.ashfield@windriver.com>2018-10-11 14:33:36 -0400
commit64d636847a62f76ca8383e83fa4719180e80bacb (patch)
tree6e4f20302ad82f33b831099728056a7eb8826306
parent352220329e1023f1781d9a188a1b06644233ce4b (diff)
downloadmeta-cloud-services-64d636847a62f76ca8383e83fa4719180e80bacb.tar.gz
consul: add INSANE_SKIP for textrel
1. for i586, bitbake consul will have QA error of textrel. consul-git-r0 do_package_qa: QA Issue: ELF binary i 'work/i586-wrs-linux/consul/git-r0/packages-split/consul/usr/bin/consul' has relocations in .text [textrel] according to go doc: -buildmode=pie Build the listed main packages and everything they import into position independent executables (PIE). Packages not named main are ignored. checked use command "eu-findtextrel ./consul", functions not compiled with -fpic/-fPIC are from packages not named main, and also not imported into package main. so -buildmode=pie cannot reslove this problem. so refer commit b689c72a of oe-core, just skip it. 2. This problem is caused since security_flags.inc is used by default. so alternative work around is: SECURITY_CFLAGS_pn-consul = "${SECURITY_NOPIE_CFLAGS}" SECURITY_LDFLAGS_pn-consul = "" Signed-off-by: Changqing Li <changqing.li@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--recipes-connectivity/consul/consul_git.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/recipes-connectivity/consul/consul_git.bb b/recipes-connectivity/consul/consul_git.bb
index a44e0b2..ee49c5e 100644
--- a/recipes-connectivity/consul/consul_git.bb
+++ b/recipes-connectivity/consul/consul_git.bb
@@ -23,3 +23,6 @@ do_install_append() {
23} 23}
24 24
25FILES_${PN} += "${systemd_unitdir}/system" 25FILES_${PN} += "${systemd_unitdir}/system"
26
27#for i586, executable consul contains textrel
28INSANE_SKIP_${PN} += "textrel"