summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2018-09-18 16:27:28 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2018-09-25 17:40:49 -0400
commit0d3cfe980456267921c145068cd854e1cd60d687 (patch)
tree4cf03ddff7372fa85abee14e7873badcef1ba2ef
parentdaaecc315c96f6757a20ca5979c7889c0df02ec9 (diff)
downloadmeta-cloud-services-0d3cfe980456267921c145068cd854e1cd60d687.tar.gz
consul: remove unneeded DEPENDS
GO package dependencies are a tricky beast. They are source dependencies and if you have two packages which share a dependency they could very well require different versions of the dependency. So supplying the dependencies via bitbake recipes is not an easy proposition. As such we are better off populating the build source with the dependencies using SRC_URIs and not traditional DEPENDS. That being said, the consul source repository actually includes copies of the dependencies (and the dependency's dependencies) so having these DEPENDS is actually useless and we can simply drop them. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--recipes-connectivity/consul/consul_git.bb34
1 files changed, 0 insertions, 34 deletions
diff --git a/recipes-connectivity/consul/consul_git.bb b/recipes-connectivity/consul/consul_git.bb
index bcfb5aa..5f86597 100644
--- a/recipes-connectivity/consul/consul_git.bb
+++ b/recipes-connectivity/consul/consul_git.bb
@@ -3,40 +3,6 @@ HOMEPAGE = "https://www.consul.io/"
3LICENSE = "MPL-2.0" 3LICENSE = "MPL-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=b278a92d2c1509760384428817710378" 4LIC_FILES_CHKSUM = "file://LICENSE;md5=b278a92d2c1509760384428817710378"
5 5
6DEPENDS += "circbuf \
7 consul-migrate \
8 go-checkpoint \
9 go-msgpack \
10 go-metrics \
11 go-bindata \
12 go-sys \
13 go-syslog \
14 dockerclient \
15 logutils \
16 memberlist \
17 raft \
18 raft-boltdb \
19 scada-client \
20 serf-go \
21 yamux \
22 muxado \
23 dns \
24 cli \
25 mapstructure \
26 copystructure \
27 reflectwalk \
28 columnize \
29 go-radix \
30 golang-lru \
31 hashicorp-hil \
32 hashicorp-hcl \
33 hashicorp-go-cleanhttp \
34 hashicorp-go-memdb \
35 hashicorp-go-reap \
36 hashicorp-go-uuid \
37 net-rpc-msgpackrpc \
38 "
39
40PKG_NAME = "github.com/hashicorp/consul" 6PKG_NAME = "github.com/hashicorp/consul"
41SRC_URI = "git://${PKG_NAME}.git \ 7SRC_URI = "git://${PKG_NAME}.git \
42 file://consul.service \ 8 file://consul.service \