summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2017-01-23 16:40:14 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2017-01-25 14:30:00 -0500
commitf5db5c4d16a3f009b50b5c585858bf44d7e8ef9a (patch)
treee4ca1c226fb2a38829274266c3b60ad3d47c59dc
parent1bcddac41d7e7fb0a080f25035f19d36c6a39e69 (diff)
downloadmeta-cloud-services-f5db5c4d16a3f009b50b5c585858bf44d7e8ef9a.tar.gz
python-django-compressor: uprev to v2.1
This version is required to support the uprev of python-horizon to stable/newton. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--meta-openstack/recipes-devtools/python/python-django-compressor_1.5.bb22
-rw-r--r--meta-openstack/recipes-devtools/python/python-django-compressor_2.1.bb25
2 files changed, 25 insertions, 22 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-django-compressor_1.5.bb b/meta-openstack/recipes-devtools/python/python-django-compressor_1.5.bb
deleted file mode 100644
index b33aed6..0000000
--- a/meta-openstack/recipes-devtools/python/python-django-compressor_1.5.bb
+++ /dev/null
@@ -1,22 +0,0 @@
1DESCRIPTION = "Compresses linked and inline JavaScript or CSS into single cached files."
2HOMEPAGE = "http://django-compressor.readthedocs.org/en/latest/"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=9f8de96acfc347c41ce7c15f2e918ef6"
6
7SRCNAME = "django_compressor"
8
9SRC_URI = "https://pypi.python.org/packages/source/d/${SRCNAME}/${SRCNAME}-${PV}.tar.gz \
10"
11
12SRC_URI[md5sum] = "274dd82a45ddd13e111852dd101a5924"
13SRC_URI[sha256sum] = "0189fd1dbf87d802f4e4e21ebc9220f29bbb7771b252a958ad6119f61453e22e"
14
15S = "${WORKDIR}/${SRCNAME}-${PV}"
16
17inherit setuptools
18
19RDEPENDS_${PN} += "python-django-appconf \
20 "
21
22CLEANBROKEN = "1"
diff --git a/meta-openstack/recipes-devtools/python/python-django-compressor_2.1.bb b/meta-openstack/recipes-devtools/python/python-django-compressor_2.1.bb
new file mode 100644
index 0000000..4bdb706
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-django-compressor_2.1.bb
@@ -0,0 +1,25 @@
1DESCRIPTION = "Compresses linked and inline JavaScript or CSS into single cached files."
2HOMEPAGE = "http://django-compressor.readthedocs.org/en/latest/"
3SECTION = "devel/python"
4LICENSE = "MIT & BSD-3-Clause & BSD-2-Clause"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=021598d037fd39ab02e53249e1fe4b6f"
6
7SRCNAME = "django_compressor"
8
9SRC_URI = "https://pypi.io/packages/source/d/${SRCNAME}/${SRCNAME}-${PV}.tar.gz \
10"
11
12SRC_URI[md5sum] = "21ecfe4e8615eae64f7068a5599df9af"
13SRC_URI[sha256sum] = "ae0051bc0c7a0660c93434e68d617553fccdd573293dfd15aa33f78d2b4954ef"
14
15S = "${WORKDIR}/${SRCNAME}-${PV}"
16
17inherit setuptools
18
19RDEPENDS_${PN} += " \
20 python-django-appconf \
21 python-rcssmin \
22 python-rjsmin \
23 "
24
25CLEANBROKEN = "1"