summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHe Zhe <zhe.he@windriver.com>2017-06-29 17:49:19 +0800
committerBruce Ashfield <bruce.ashfield@windriver.com>2017-06-29 15:27:41 -0400
commitf41b25b2d1d1e1e7614925e59210d70e650b7a72 (patch)
tree2c35a247d80e8add184edb7f3588138b9dee124f
parent44a3154ba9e0e3e56fb68fddde61ccf74d1ca482 (diff)
downloadmeta-cloud-services-f41b25b2d1d1e1e7614925e59210d70e650b7a72.tar.gz
spice: Fix compilation error
| ../../git/server/red_parse_qxl.c:367:18: error: 'BITMAP_FMT_IS_RGB' defined but not used [-Werror=unused-const-variable=] | static const int BITMAP_FMT_IS_RGB[] = {0, 0, 0, 0, 0, 0, 1, 1, 1, 1, 1}; Signed-off-by: He Zhe <zhe.he@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--recipes-support/spice/files/0001-red_parse_qxl-Fix-BITMAP_FMT_IS_RGB-defined-but-not-.patch29
-rw-r--r--recipes-support/spice/spice_git.bb1
2 files changed, 30 insertions, 0 deletions
diff --git a/recipes-support/spice/files/0001-red_parse_qxl-Fix-BITMAP_FMT_IS_RGB-defined-but-not-.patch b/recipes-support/spice/files/0001-red_parse_qxl-Fix-BITMAP_FMT_IS_RGB-defined-but-not-.patch
new file mode 100644
index 0000000..ccae5f5
--- /dev/null
+++ b/recipes-support/spice/files/0001-red_parse_qxl-Fix-BITMAP_FMT_IS_RGB-defined-but-not-.patch
@@ -0,0 +1,29 @@
1From 85838d4c9f2322aedb99b38fffd7da95a494d8ed Mon Sep 17 00:00:00 2001
2From: He Zhe <zhe.he@windriver.com>
3Date: Thu, 29 Jun 2017 08:26:35 +0000
4Subject: [PATCH] red_parse_qxl: Fix BITMAP_FMT_IS_RGB defined but not used
5
6| ../../git/server/red_parse_qxl.c:367:18: error: 'BITMAP_FMT_IS_RGB'
7defined but not used [-Werror=unused-const-variable=]
8| static const int BITMAP_FMT_IS_RGB[] = {0, 0, 0, 0, 0, 0, 1, 1, 1, 1, 1};
9
10Signed-off-by: He Zhe <zhe.he@windriver.com>
11---
12 server/red_parse_qxl.c | 1 -
13 1 file changed, 1 deletion(-)
14
15diff --git a/server/red_parse_qxl.c b/server/red_parse_qxl.c
16index 6c0b0658..cfc2da95 100644
17--- a/server/red_parse_qxl.c
18+++ b/server/red_parse_qxl.c
19@@ -364,7 +364,6 @@ static int bitmap_consistent(SpiceBitmap *bitmap)
20
21 // This is based on SPICE_BITMAP_FMT_*, copied from server/red_worker.c
22 // to avoid a possible unoptimization from making it non static.
23-static const int BITMAP_FMT_IS_RGB[] = {0, 0, 0, 0, 0, 0, 1, 1, 1, 1, 1};
24
25 static SpiceImage *red_get_image(RedMemSlotInfo *slots, int group_id,
26 QXLPHYSICAL addr, uint32_t flags, int is_mask)
27--
282.11.0
29
diff --git a/recipes-support/spice/spice_git.bb b/recipes-support/spice/spice_git.bb
index 828087a..6f1be3a 100644
--- a/recipes-support/spice/spice_git.bb
+++ b/recipes-support/spice/spice_git.bb
@@ -35,6 +35,7 @@ SRC_URI += " \
35 file://spice-fix-CVE-2013-4282.patch \ 35 file://spice-fix-CVE-2013-4282.patch \
36 file://configure.ac-add-subdir-objects-to-AM_INIT_AUTOMAKE.patch \ 36 file://configure.ac-add-subdir-objects-to-AM_INIT_AUTOMAKE.patch \
37 file://build-allow-separated-src-and-build-dirs.patch \ 37 file://build-allow-separated-src-and-build-dirs.patch \
38 file://0001-red_parse_qxl-Fix-BITMAP_FMT_IS_RGB-defined-but-not-.patch \
38 " 39 "
39 40
40S = "${WORKDIR}/git" 41S = "${WORKDIR}/git"