summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2017-01-17 10:56:01 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2017-01-17 14:37:48 -0500
commitbe8a24d60cc68e2c2a47f290201abe5ed2f062d8 (patch)
tree2325e944d6f306077b3bce516bfa57edb3e10094
parent39087ecc8581227a7c469260485229f71511215d (diff)
downloadmeta-cloud-services-be8a24d60cc68e2c2a47f290201abe5ed2f062d8.tar.gz
python-pbr: drop recipe
We often include our own versions of recipes in meta-virtualization and meta-cloud-services in order to satisfy specific version dependencies, ie. grouping recipes by usecase. Historically python-pbr versions have been extremely flexible (most recipes only specify the very old 1.6 as a minimum version) and python-pbr can arguably be seen as a core python package, so remove our version of the recipe in favor of the one in meta-python. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--meta-openstack/recipes-devtools/python/python-pbr_1.8.1.bb30
1 files changed, 0 insertions, 30 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-pbr_1.8.1.bb b/meta-openstack/recipes-devtools/python/python-pbr_1.8.1.bb
deleted file mode 100644
index 2018a1b..0000000
--- a/meta-openstack/recipes-devtools/python/python-pbr_1.8.1.bb
+++ /dev/null
@@ -1,30 +0,0 @@
1DESCRIPTION = "Python Build Reasonableness: PBR is a library that injects some useful and sensible default behaviors into your setuptools run"
2HOMEPAGE = "https://pypi.python.org/pypi/pbr"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
6
7SRCNAME = "pbr"
8
9SRC_URI = "https://pypi.python.org/packages/source/p/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
10
11SRC_URI[md5sum] = "c8f9285e1a4ca6f9654c529b158baa3a"
12SRC_URI[sha256sum] = "e2127626a91e6c885db89668976db31020f0af2da728924b56480fc7ccf09649"
13
14S = "${WORKDIR}/${SRCNAME}-${PV}"
15
16inherit setuptools
17
18# DEPENDS_default: python-pip
19
20DEPENDS += " \
21 python-pip \
22 "
23
24DEPENDS_class-native += ""
25
26# RDEPENDS_default:
27RDEPENDS_${PN} += " \
28 "
29
30BBCLASSEXTEND = "native"