summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Dudau <adrian.dudau@enea.com>2017-05-23 14:13:55 +0200
committerBruce Ashfield <bruce.ashfield@windriver.com>2017-06-01 11:59:14 -0400
commita7ee783c3d047c73409c30e0248c2bdbf195ed82 (patch)
tree43415e8f1660b80771a8204ee2d09a7cef35a3eb
parenta1a56e3f4d500979088a9b18a28b8cc8d42612ed (diff)
downloadmeta-cloud-services-a7ee783c3d047c73409c30e0248c2bdbf195ed82.tar.gz
python: Inherit setuptools instead of distutils for several packages
python-appdirs python-keystoneauth python-lesscpy python-os-client-config The setup scripts of these modules use setuptools instead of distutils, resulting in errors like this: | File "setup.py", line 5, in <module> | from setuptools import setup | ImportError: No module named setuptools Signed-off-by: Adrian Dudau <adrian.dudau@enea.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--meta-openstack/recipes-devtools/python/python-appdirs_git.bb2
-rw-r--r--meta-openstack/recipes-devtools/python/python-keystoneauth1_2.18.0.bb2
-rw-r--r--meta-openstack/recipes-devtools/python/python-lesscpy_0.10.2.bb2
-rw-r--r--meta-openstack/recipes-devtools/python/python-os-client-config_git.bb2
4 files changed, 4 insertions, 4 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-appdirs_git.bb b/meta-openstack/recipes-devtools/python/python-appdirs_git.bb
index 8e40f26..2482871 100644
--- a/meta-openstack/recipes-devtools/python/python-appdirs_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-appdirs_git.bb
@@ -12,7 +12,7 @@ SRC_URI = "git://github.com/ActiveState/${SRCNAME}.git"
12 12
13S = "${WORKDIR}/git" 13S = "${WORKDIR}/git"
14 14
15inherit distutils 15inherit setuptools
16 16
17DEPENDS += " \ 17DEPENDS += " \
18 python-pip \ 18 python-pip \
diff --git a/meta-openstack/recipes-devtools/python/python-keystoneauth1_2.18.0.bb b/meta-openstack/recipes-devtools/python/python-keystoneauth1_2.18.0.bb
index 1fdf9e1..83582c5 100644
--- a/meta-openstack/recipes-devtools/python/python-keystoneauth1_2.18.0.bb
+++ b/meta-openstack/recipes-devtools/python/python-keystoneauth1_2.18.0.bb
@@ -12,7 +12,7 @@ SRC_URI[sha256sum] = "075a9ca7a8877c5885fa2487699015e45260c4e6be119683effe0ad2ab
12 12
13S = "${WORKDIR}/${SRCNAME}-${PV}" 13S = "${WORKDIR}/${SRCNAME}-${PV}"
14 14
15inherit distutils 15inherit setuptools
16 16
17DEPENDS += " \ 17DEPENDS += " \
18 python-pbr \ 18 python-pbr \
diff --git a/meta-openstack/recipes-devtools/python/python-lesscpy_0.10.2.bb b/meta-openstack/recipes-devtools/python/python-lesscpy_0.10.2.bb
index 61ae935..71e0dc0 100644
--- a/meta-openstack/recipes-devtools/python/python-lesscpy_0.10.2.bb
+++ b/meta-openstack/recipes-devtools/python/python-lesscpy_0.10.2.bb
@@ -17,7 +17,7 @@ SRC_URI[sha256sum] = "ccad1ad2a89ced1875c5ca4e16e5478b791d31fb187fe29f1541859318
17 17
18S = "${WORKDIR}/${SRCNAME}-${PV}" 18S = "${WORKDIR}/${SRCNAME}-${PV}"
19 19
20inherit distutils 20inherit setuptools
21 21
22DISTUTILS_INSTALL_ARGS = "--root=${D} \ 22DISTUTILS_INSTALL_ARGS = "--root=${D} \
23 --prefix=${prefix} \ 23 --prefix=${prefix} \
diff --git a/meta-openstack/recipes-devtools/python/python-os-client-config_git.bb b/meta-openstack/recipes-devtools/python/python-os-client-config_git.bb
index 7b55dbb..5393bb7 100644
--- a/meta-openstack/recipes-devtools/python/python-os-client-config_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-os-client-config_git.bb
@@ -12,7 +12,7 @@ SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=stable/newton"
12 12
13S = "${WORKDIR}/git" 13S = "${WORKDIR}/git"
14 14
15inherit distutils 15inherit setuptools
16 16
17DEPENDS += " \ 17DEPENDS += " \
18 python-pbr \ 18 python-pbr \