summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2017-01-30 22:16:28 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2017-01-30 22:40:19 -0500
commita08071534296a5492b4283c27ce870aed93b0c61 (patch)
treed48e80247e8a400ea2fe86e43651ad93d2bac0a3
parentf7b521990e12b5cf69e97a4c062cae032e4bf5ea (diff)
downloadmeta-cloud-services-a08071534296a5492b4283c27ce870aed93b0c61.tar.gz
python-kombu: add version 3.0.37
The 4.x.x series requires the amqp>=2 which is outside of the range of amqp versions supported versions required for python-oslo.messaging therefore we need to continue support for the 3.0.x series and force its use via the layer.conf and PREFERRED_VERSION. This is an updated version of the python-kombu recipe for the 3.0.x series with updated license checksup (the license type remains the same) and updated runtime dependencies based on the packages requirements/default.txt. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--meta-openstack/conf/layer.conf1
-rw-r--r--meta-openstack/recipes-devtools/python/python-kombu_3.0.37.bb23
2 files changed, 24 insertions, 0 deletions
diff --git a/meta-openstack/conf/layer.conf b/meta-openstack/conf/layer.conf
index e940478..98282e2 100644
--- a/meta-openstack/conf/layer.conf
+++ b/meta-openstack/conf/layer.conf
@@ -20,5 +20,6 @@ PREFERRED_VERSION_python-netaddr = "0.7.19"
20PREFERRED_VERSION_python-sqlalchemy = "1.0.16" 20PREFERRED_VERSION_python-sqlalchemy = "1.0.16"
21PREFERRED_VERSION_python-requests = "2.12.0" 21PREFERRED_VERSION_python-requests = "2.12.0"
22PREFERRED_VERSION_python-amqp = "1.4.9" 22PREFERRED_VERSION_python-amqp = "1.4.9"
23PREFERRED_VERSION_python-kombu = "3.0.%"
23 24
24LICENSE_PATH += "${LAYERDIR}/licenses" 25LICENSE_PATH += "${LAYERDIR}/licenses"
diff --git a/meta-openstack/recipes-devtools/python/python-kombu_3.0.37.bb b/meta-openstack/recipes-devtools/python/python-kombu_3.0.37.bb
new file mode 100644
index 0000000..16e3f0a
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-kombu_3.0.37.bb
@@ -0,0 +1,23 @@
1DESCRIPTION = "A messaging framework for Python"
2HOMEPAGE = "http://kombu.readthedocs.org"
3SECTION = "devel/python"
4LICENSE = "BSD"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=ee3b641e9940ba25a4dd66b3942866cf"
6
7SRCNAME = "kombu"
8
9SRC_URI = "https://pypi.io/packages/source/k/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
10
11SRC_URI[md5sum] = "a1901036ba5e70e6b1733f7c2d5ee313"
12SRC_URI[sha256sum] = "e064a00c66b4d1058cd2b0523fb8d98c82c18450244177b6c0f7913016642650"
13
14S = "${WORKDIR}/${SRCNAME}-${PV}"
15
16inherit setuptools
17
18FILES_${PN}-doc += "${datadir}/${SRCNAME}"
19
20RDEPENDS_${PN} = " \
21 python-anyjson \
22 python-amqp \
23 "