summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2017-06-29 13:56:39 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2017-06-29 15:28:30 -0400
commit6535b4a3ec1f2c2c62dd394f17227a6fa18d03cb (patch)
tree9910165334e79448e36853130c9e92c473e88eb1
parent1efe010daaf766cbc26965c6e00df798a207a480 (diff)
downloadmeta-cloud-services-6535b4a3ec1f2c2c62dd394f17227a6fa18d03cb.tar.gz
python: satisfy setup.py 'setup_requires' for vcversioner
python-jsonschema has a 'setup_requires' for python vcversioner so we must have a -native version of python-vcversioner and DEPEND on it in order to avoid setup.py downloading the requires from PyPI. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--meta-openstack/recipes-devtools/python/python-jsonschema_2.5.1.bb5
-rw-r--r--meta-openstack/recipes-devtools/python/python-vcversioner_2.14.0.0.bb8
2 files changed, 13 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-jsonschema_2.5.1.bb b/meta-openstack/recipes-devtools/python/python-jsonschema_2.5.1.bb
index a3a7ec0..fef8d5f 100644
--- a/meta-openstack/recipes-devtools/python/python-jsonschema_2.5.1.bb
+++ b/meta-openstack/recipes-devtools/python/python-jsonschema_2.5.1.bb
@@ -17,3 +17,8 @@ S = "${WORKDIR}/${SRCNAME}-${PV}"
17inherit setuptools 17inherit setuptools
18 18
19DEPENDS += "python-vcversioner" 19DEPENDS += "python-vcversioner"
20
21# Satisfy setup.py 'setup_requires'
22DEPENDS += " \
23 python-vcversioner-native \
24 "
diff --git a/meta-openstack/recipes-devtools/python/python-vcversioner_2.14.0.0.bb b/meta-openstack/recipes-devtools/python/python-vcversioner_2.14.0.0.bb
index 2fe96ab..bcff6f3 100644
--- a/meta-openstack/recipes-devtools/python/python-vcversioner_2.14.0.0.bb
+++ b/meta-openstack/recipes-devtools/python/python-vcversioner_2.14.0.0.bb
@@ -14,3 +14,11 @@ SRC_URI[sha256sum] = "acd43686e92e6c8bbeb4f2eef54408567a7adea9692fa72d591eec5357
14S = "${WORKDIR}/${SRCNAME}-${PV}" 14S = "${WORKDIR}/${SRCNAME}-${PV}"
15 15
16inherit setuptools 16inherit setuptools
17
18
19DEPENDS_class-native += " \
20 python \
21 python-setuptools \
22 "
23
24BBCLASSEXTEND = "native"