summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2017-01-17 14:34:51 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2017-01-17 14:37:44 -0500
commit39087ecc8581227a7c469260485229f71511215d (patch)
tree93a309c6a945fc220bbe461bc9daea1be83370bf
parent844f0ad2aa79bf478f30a77dbbbf626471d7820f (diff)
downloadmeta-cloud-services-39087ecc8581227a7c469260485229f71511215d.tar.gz
python: satisfy setup.py 'setup_requires'
Python setuptools will attempt to satisfy the packages defined as 'setup_requires' in setup.py by first looking for the package availability locally and ultimately by downloading it from PyPI. This is actually a huge security hole and packages should move to using pip instead, but this is another story that the upstream packages have to address. This also disregards BB_NO_NETWORK and may prove to introduce host contamination. The best approach is to ensure we have the -native version of the 'setup_requires' packages present such that setup.py will not attempt to complete the download from PyPI. Make 'pbr' -native available and for packages which we have identified as having 'setup_requires' include 'pbr' add the necessary python-pbr-native DEPENDS. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--meta-openstack/recipes-devtools/python/python-cliff_1.15.0.bb5
-rw-r--r--meta-openstack/recipes-devtools/python/python-fixtures_1.3.1.bb5
-rw-r--r--meta-openstack/recipes-devtools/python/python-glanceclient_git.bb5
-rw-r--r--meta-openstack/recipes-devtools/python/python-heat_git.bb5
-rw-r--r--meta-openstack/recipes-devtools/python/python-heatclient_git.bb5
-rw-r--r--meta-openstack/recipes-devtools/python/python-keystoneclient_git.bb5
-rw-r--r--meta-openstack/recipes-devtools/python/python-lockfile_0.10.2.bb5
-rw-r--r--meta-openstack/recipes-devtools/python/python-mox3_0.9.0.bb5
-rw-r--r--meta-openstack/recipes-devtools/python/python-oslo.config_git.bb5
-rw-r--r--meta-openstack/recipes-devtools/python/python-oslo.context_git.bb5
-rw-r--r--meta-openstack/recipes-devtools/python/python-oslo.i18n_git.bb5
-rw-r--r--meta-openstack/recipes-devtools/python/python-oslo.log_git.bb5
-rw-r--r--meta-openstack/recipes-devtools/python/python-oslo.serialization_git.bb5
-rw-r--r--meta-openstack/recipes-devtools/python/python-oslo.utils_git.bb5
-rw-r--r--meta-openstack/recipes-devtools/python/python-pbr_1.8.1.bb4
-rw-r--r--meta-openstack/recipes-devtools/python/python-sqlalchemy-migrate_0.9.7.bb5
-rw-r--r--meta-openstack/recipes-devtools/python/python-stevedore_1.9.0.bb5
-rw-r--r--meta-openstack/recipes-devtools/python/python-swiftclient_git.bb5
-rw-r--r--meta-openstack/recipes-devtools/python/python-testscenarios_0.5.0.bb5
-rw-r--r--meta-openstack/recipes-devtools/python/python-testtools_1.8.0.bb8
-rw-r--r--meta-openstack/recipes-devtools/python/python-wsme_0.7.0.bb5
21 files changed, 105 insertions, 2 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-cliff_1.15.0.bb b/meta-openstack/recipes-devtools/python/python-cliff_1.15.0.bb
index c241ab4..2c9341f 100644
--- a/meta-openstack/recipes-devtools/python/python-cliff_1.15.0.bb
+++ b/meta-openstack/recipes-devtools/python/python-cliff_1.15.0.bb
@@ -19,6 +19,11 @@ DEPENDS += "\
19 python-pbr \ 19 python-pbr \
20 " 20 "
21 21
22# Satisfy setup.py 'setup_requires'
23DEPENDS += " \
24 python-pbr-native \
25 "
26
22RDEPENDS_${PN} += "python-prettytable \ 27RDEPENDS_${PN} += "python-prettytable \
23 python-cmd2 \ 28 python-cmd2 \
24 python-pbr \ 29 python-pbr \
diff --git a/meta-openstack/recipes-devtools/python/python-fixtures_1.3.1.bb b/meta-openstack/recipes-devtools/python/python-fixtures_1.3.1.bb
index c2b79e4..ac40e9d 100644
--- a/meta-openstack/recipes-devtools/python/python-fixtures_1.3.1.bb
+++ b/meta-openstack/recipes-devtools/python/python-fixtures_1.3.1.bb
@@ -25,6 +25,11 @@ DEPENDS += " \
25 python-pbr \ 25 python-pbr \
26 " 26 "
27 27
28# Satisfy setup.py 'setup_requires'
29DEPENDS += " \
30 python-pbr-native \
31 "
32
28RDEPENDS_${PN} += "python-testtools \ 33RDEPENDS_${PN} += "python-testtools \
29 python-pbr \ 34 python-pbr \
30 " 35 "
diff --git a/meta-openstack/recipes-devtools/python/python-glanceclient_git.bb b/meta-openstack/recipes-devtools/python/python-glanceclient_git.bb
index f9edf6d..22dc854 100644
--- a/meta-openstack/recipes-devtools/python/python-glanceclient_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-glanceclient_git.bb
@@ -24,6 +24,11 @@ inherit setuptools monitor rmargparse
24 24
25FILES_${PN} += "${datadir}/${SRCNAME}" 25FILES_${PN} += "${datadir}/${SRCNAME}"
26 26
27# Satisfy setup.py 'setup_requires'
28DEPENDS += " \
29 python-pbr-native \
30 "
31
27RDEPENDS_${PN} = "gmp \ 32RDEPENDS_${PN} = "gmp \
28 python-warlock \ 33 python-warlock \
29 python-pyopenssl \ 34 python-pyopenssl \
diff --git a/meta-openstack/recipes-devtools/python/python-heat_git.bb b/meta-openstack/recipes-devtools/python/python-heat_git.bb
index 6da768f..cccaf0a 100644
--- a/meta-openstack/recipes-devtools/python/python-heat_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-heat_git.bb
@@ -162,6 +162,11 @@ DEPENDS += " \
162 python-pbr \ 162 python-pbr \
163 " 163 "
164 164
165# Satisfy setup.py 'setup_requires'
166DEPENDS += " \
167 python-pbr-native \
168 "
169
165RDEPENDS_${PN} += " \ 170RDEPENDS_${PN} += " \
166 python-heatclient \ 171 python-heatclient \
167 python-sqlalchemy \ 172 python-sqlalchemy \
diff --git a/meta-openstack/recipes-devtools/python/python-heatclient_git.bb b/meta-openstack/recipes-devtools/python/python-heatclient_git.bb
index 10428c2..26d86be 100644
--- a/meta-openstack/recipes-devtools/python/python-heatclient_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-heatclient_git.bb
@@ -9,6 +9,11 @@ DEPENDS += " \
9 python-pbr \ 9 python-pbr \
10 " 10 "
11 11
12# Satisfy setup.py 'setup_requires'
13DEPENDS += " \
14 python-pbr-native \
15 "
16
12RDEPENDS_${PN} +="python-cliff \ 17RDEPENDS_${PN} +="python-cliff \
13 python-httplib2 \ 18 python-httplib2 \
14 python-iso8601 \ 19 python-iso8601 \
diff --git a/meta-openstack/recipes-devtools/python/python-keystoneclient_git.bb b/meta-openstack/recipes-devtools/python/python-keystoneclient_git.bb
index 495f1e3..0b67e40 100644
--- a/meta-openstack/recipes-devtools/python/python-keystoneclient_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-keystoneclient_git.bb
@@ -25,6 +25,11 @@ DEPENDS += " \
25 python-pbr \ 25 python-pbr \
26 " 26 "
27 27
28# Satisfy setup.py 'setup_requires'
29DEPENDS += " \
30 python-pbr-native \
31 "
32
28RDEPENDS_${PN} += " \ 33RDEPENDS_${PN} += " \
29 python-iso8601 \ 34 python-iso8601 \
30 python-prettytable \ 35 python-prettytable \
diff --git a/meta-openstack/recipes-devtools/python/python-lockfile_0.10.2.bb b/meta-openstack/recipes-devtools/python/python-lockfile_0.10.2.bb
index 5ae891b..9ba93df 100644
--- a/meta-openstack/recipes-devtools/python/python-lockfile_0.10.2.bb
+++ b/meta-openstack/recipes-devtools/python/python-lockfile_0.10.2.bb
@@ -19,6 +19,11 @@ DEPENDS += "\
19 python-pbr \ 19 python-pbr \
20 " 20 "
21 21
22# Satisfy setup.py 'setup_requires'
23DEPENDS += " \
24 python-pbr-native \
25 "
26
22RDEPENDS_${PN} += "\ 27RDEPENDS_${PN} += "\
23 python-pbr \ 28 python-pbr \
24 " 29 "
diff --git a/meta-openstack/recipes-devtools/python/python-mox3_0.9.0.bb b/meta-openstack/recipes-devtools/python/python-mox3_0.9.0.bb
index 6d58573..7eb948e 100644
--- a/meta-openstack/recipes-devtools/python/python-mox3_0.9.0.bb
+++ b/meta-openstack/recipes-devtools/python/python-mox3_0.9.0.bb
@@ -20,6 +20,11 @@ DEPENDS += "\
20 python-pbr \ 20 python-pbr \
21 " 21 "
22 22
23# Satisfy setup.py 'setup_requires'
24DEPENDS += " \
25 python-pbr-native \
26 "
27
23RDEPENDS_${PN} += " \ 28RDEPENDS_${PN} += " \
24 python-pbr \ 29 python-pbr \
25 python-fixtures \ 30 python-fixtures \
diff --git a/meta-openstack/recipes-devtools/python/python-oslo.config_git.bb b/meta-openstack/recipes-devtools/python/python-oslo.config_git.bb
index a8e6a68..ade23ba 100644
--- a/meta-openstack/recipes-devtools/python/python-oslo.config_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-oslo.config_git.bb
@@ -19,6 +19,11 @@ DEPENDS += " \
19 python-pip \ 19 python-pip \
20 " 20 "
21 21
22# Satisfy setup.py 'setup_requires'
23DEPENDS += " \
24 python-pbr-native \
25 "
26
22RDEPENDS_${PN} += " \ 27RDEPENDS_${PN} += " \
23 python-pbr \ 28 python-pbr \
24 python-netaddr \ 29 python-netaddr \
diff --git a/meta-openstack/recipes-devtools/python/python-oslo.context_git.bb b/meta-openstack/recipes-devtools/python/python-oslo.context_git.bb
index 3543cae..28285ad 100644
--- a/meta-openstack/recipes-devtools/python/python-oslo.context_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-oslo.context_git.bb
@@ -19,6 +19,11 @@ DEPENDS += " \
19 python-pbr \ 19 python-pbr \
20 " 20 "
21 21
22# Satisfy setup.py 'setup_requires'
23DEPENDS += " \
24 python-pbr-native \
25 "
26
22# RDEPENDS_default: 27# RDEPENDS_default:
23RDEPENDS_${PN} += " \ 28RDEPENDS_${PN} += " \
24 bash \ 29 bash \
diff --git a/meta-openstack/recipes-devtools/python/python-oslo.i18n_git.bb b/meta-openstack/recipes-devtools/python/python-oslo.i18n_git.bb
index c820bc8..8b6db29 100644
--- a/meta-openstack/recipes-devtools/python/python-oslo.i18n_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-oslo.i18n_git.bb
@@ -21,6 +21,11 @@ DEPENDS += " \
21 python-pbr \ 21 python-pbr \
22 " 22 "
23 23
24# Satisfy setup.py 'setup_requires'
25DEPENDS += " \
26 python-pbr-native \
27 "
28
24# RDEPENDS_default: 29# RDEPENDS_default:
25RDEPENDS_${PN} += " \ 30RDEPENDS_${PN} += " \
26 python-babel \ 31 python-babel \
diff --git a/meta-openstack/recipes-devtools/python/python-oslo.log_git.bb b/meta-openstack/recipes-devtools/python/python-oslo.log_git.bb
index d4f7fe0..b290863 100644
--- a/meta-openstack/recipes-devtools/python/python-oslo.log_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-oslo.log_git.bb
@@ -19,6 +19,11 @@ DEPENDS += " \
19 python-pbr \ 19 python-pbr \
20 " 20 "
21 21
22# Satisfy setup.py 'setup_requires'
23DEPENDS += " \
24 python-pbr-native \
25 "
26
22# RDEPENDS_default: 27# RDEPENDS_default:
23RDEPENDS_${PN} += " \ 28RDEPENDS_${PN} += " \
24 bash \ 29 bash \
diff --git a/meta-openstack/recipes-devtools/python/python-oslo.serialization_git.bb b/meta-openstack/recipes-devtools/python/python-oslo.serialization_git.bb
index 32b1cc3..1bf11f4 100644
--- a/meta-openstack/recipes-devtools/python/python-oslo.serialization_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-oslo.serialization_git.bb
@@ -20,6 +20,11 @@ DEPENDS += " \
20 python-pbr \ 20 python-pbr \
21 " 21 "
22 22
23# Satisfy setup.py 'setup_requires'
24DEPENDS += " \
25 python-pbr-native \
26 "
27
23# RDEPENDS_default: 28# RDEPENDS_default:
24RDEPENDS_${PN} += " \ 29RDEPENDS_${PN} += " \
25 python-pbr \ 30 python-pbr \
diff --git a/meta-openstack/recipes-devtools/python/python-oslo.utils_git.bb b/meta-openstack/recipes-devtools/python/python-oslo.utils_git.bb
index a833f6c..3bacd7c 100644
--- a/meta-openstack/recipes-devtools/python/python-oslo.utils_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-oslo.utils_git.bb
@@ -20,6 +20,11 @@ DEPENDS += " \
20 python-pbr \ 20 python-pbr \
21 " 21 "
22 22
23# Satisfy setup.py 'setup_requires'
24DEPENDS += " \
25 python-pbr-native \
26 "
27
23# RDEPENDS_default: 28# RDEPENDS_default:
24RDEPENDS_${PN} += " \ 29RDEPENDS_${PN} += " \
25 python-pbr \ 30 python-pbr \
diff --git a/meta-openstack/recipes-devtools/python/python-pbr_1.8.1.bb b/meta-openstack/recipes-devtools/python/python-pbr_1.8.1.bb
index fdf80b3..2018a1b 100644
--- a/meta-openstack/recipes-devtools/python/python-pbr_1.8.1.bb
+++ b/meta-openstack/recipes-devtools/python/python-pbr_1.8.1.bb
@@ -21,6 +21,10 @@ DEPENDS += " \
21 python-pip \ 21 python-pip \
22 " 22 "
23 23
24DEPENDS_class-native += ""
25
24# RDEPENDS_default: 26# RDEPENDS_default:
25RDEPENDS_${PN} += " \ 27RDEPENDS_${PN} += " \
26 " 28 "
29
30BBCLASSEXTEND = "native"
diff --git a/meta-openstack/recipes-devtools/python/python-sqlalchemy-migrate_0.9.7.bb b/meta-openstack/recipes-devtools/python/python-sqlalchemy-migrate_0.9.7.bb
index 32ecdb3..5c3636e 100644
--- a/meta-openstack/recipes-devtools/python/python-sqlalchemy-migrate_0.9.7.bb
+++ b/meta-openstack/recipes-devtools/python/python-sqlalchemy-migrate_0.9.7.bb
@@ -20,6 +20,11 @@ DEPENDS += " \
20 python-pbr \ 20 python-pbr \
21 " 21 "
22 22
23# Satisfy setup.py 'setup_requires'
24DEPENDS += " \
25 python-pbr-native \
26 "
27
23RDEPENDS_${PN} += "python-sqlalchemy \ 28RDEPENDS_${PN} += "python-sqlalchemy \
24 python-decorator \ 29 python-decorator \
25 python-tempita \ 30 python-tempita \
diff --git a/meta-openstack/recipes-devtools/python/python-stevedore_1.9.0.bb b/meta-openstack/recipes-devtools/python/python-stevedore_1.9.0.bb
index bdacb14..0029c2a 100644
--- a/meta-openstack/recipes-devtools/python/python-stevedore_1.9.0.bb
+++ b/meta-openstack/recipes-devtools/python/python-stevedore_1.9.0.bb
@@ -20,6 +20,11 @@ DEPENDS += " \
20 python-pbr \ 20 python-pbr \
21 " 21 "
22 22
23# Satisfy setup.py 'setup_requires'
24DEPENDS += " \
25 python-pbr-native \
26 "
27
23RDEPENDS_${PN} += " \ 28RDEPENDS_${PN} += " \
24 python-pbr \ 29 python-pbr \
25 python-argparse \ 30 python-argparse \
diff --git a/meta-openstack/recipes-devtools/python/python-swiftclient_git.bb b/meta-openstack/recipes-devtools/python/python-swiftclient_git.bb
index 1c506a8..5f423c4 100644
--- a/meta-openstack/recipes-devtools/python/python-swiftclient_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-swiftclient_git.bb
@@ -24,6 +24,11 @@ DEPENDS += " \
24 python-pbr \ 24 python-pbr \
25 " 25 "
26 26
27# Satisfy setup.py 'setup_requires'
28DEPENDS += " \
29 python-pbr-native \
30 "
31
27RDEPENDS_${PN} += " \ 32RDEPENDS_${PN} += " \
28 python-simplejson \ 33 python-simplejson \
29 python-pbr \ 34 python-pbr \
diff --git a/meta-openstack/recipes-devtools/python/python-testscenarios_0.5.0.bb b/meta-openstack/recipes-devtools/python/python-testscenarios_0.5.0.bb
index 994b6b5..a777b31 100644
--- a/meta-openstack/recipes-devtools/python/python-testscenarios_0.5.0.bb
+++ b/meta-openstack/recipes-devtools/python/python-testscenarios_0.5.0.bb
@@ -20,6 +20,11 @@ DEPENDS += "\
20 python-pbr \ 20 python-pbr \
21 " 21 "
22 22
23# Satisfy setup.py 'setup_requires'
24DEPENDS += " \
25 python-pbr-native \
26 "
27
23RDEPENDS_${PN} += "\ 28RDEPENDS_${PN} += "\
24 python-testtools \ 29 python-testtools \
25 python-pbr \ 30 python-pbr \
diff --git a/meta-openstack/recipes-devtools/python/python-testtools_1.8.0.bb b/meta-openstack/recipes-devtools/python/python-testtools_1.8.0.bb
index fe03a5f..3138aae 100644
--- a/meta-openstack/recipes-devtools/python/python-testtools_1.8.0.bb
+++ b/meta-openstack/recipes-devtools/python/python-testtools_1.8.0.bb
@@ -16,10 +16,14 @@ SRC_URI[sha256sum] = "8afd6400fb4e75adb0b29bd09695ecb2024cd7befab4677a58c147701a
16S = "${WORKDIR}/${SRCNAME}-${PV}" 16S = "${WORKDIR}/${SRCNAME}-${PV}"
17 17
18inherit setuptools 18inherit setuptools
19
20DEPENDS += " \ 19DEPENDS += " \
21 python-pbr \ 20 python-pbr \
22" 21 "
22
23# Satisfy setup.py 'setup_requires'
24DEPENDS += " \
25 python-pbr-native \
26 "
23 27
24RDEPENDS_${PN} += "\ 28RDEPENDS_${PN} += "\
25 python-extras \ 29 python-extras \
diff --git a/meta-openstack/recipes-devtools/python/python-wsme_0.7.0.bb b/meta-openstack/recipes-devtools/python/python-wsme_0.7.0.bb
index 523c3df..db89474 100644
--- a/meta-openstack/recipes-devtools/python/python-wsme_0.7.0.bb
+++ b/meta-openstack/recipes-devtools/python/python-wsme_0.7.0.bb
@@ -20,6 +20,11 @@ DEPENDS += " \
20 python-pbr \ 20 python-pbr \
21 " 21 "
22 22
23# Satisfy setup.py 'setup_requires'
24DEPENDS += " \
25 python-pbr-native \
26 "
27
23RDEPENDS_${PN} += "\ 28RDEPENDS_${PN} += "\
24 python-pbr \ 29 python-pbr \
25 " 30 "