summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2017-01-20 16:59:33 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2017-01-21 23:17:03 -0500
commit2d14b1fc9eac7e22f6d4a305fe9bdf94ef46dcbc (patch)
tree207b082689ef0c052c455e27157349ccd0bc8df2
parentb3c4115e60abe92bf45eef35a4696de0efe3712c (diff)
downloadmeta-cloud-services-2d14b1fc9eac7e22f6d4a305fe9bdf94ef46dcbc.tar.gz
python-requestsexceptions: add new recipe
This is required for the uprev of python-os-client-config to the latest stable/newton. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--meta-openstack/recipes-devtools/python/python-requestsexceptions_1.1.3.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-requestsexceptions_1.1.3.bb b/meta-openstack/recipes-devtools/python/python-requestsexceptions_1.1.3.bb
new file mode 100644
index 0000000..4975e52
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-requestsexceptions_1.1.3.bb
@@ -0,0 +1,30 @@
1DESCRIPTION = "Import exceptions from potentially bundled packages in requests."
2HOMEPAGE = "https://www.openstack.org/"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=d273d63619c9aeaf15cdaf76422c4f87"
6
7PR = "r0"
8
9SRCNAME = "requestsexceptions"
10SRC_URI = "http://pypi.io/packages/source/r/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
11
12SRC_URI[md5sum] = "edf208c247261157bf7a97d7c792d914"
13SRC_URI[sha256sum] = "d678b872f51f76d875e00e6667f4ddbf013b3a99490ae5fe07cf3e4f846e283e"
14
15S = "${WORKDIR}/${SRCNAME}-${PV}"
16
17inherit setuptools
18
19# conflicting file prevention
20do_install_append() {
21 rm -f ${D}${libdir}/python*/site-packages/tests/*
22}
23
24DEPENDS += " \
25 python-pbr-native \
26 "
27
28RDEPENDS_${PN} += " \
29 python-pbr \
30 "