summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2017-01-30 22:16:17 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2017-01-30 22:40:19 -0500
commit200890de2bae26f139fc0ca32a8dbde5ef896de8 (patch)
treeb9e21022de44f03206f56d91155eb45a4b9b4017
parenta08071534296a5492b4283c27ce870aed93b0c61 (diff)
downloadmeta-cloud-services-200890de2bae26f139fc0ca32a8dbde5ef896de8.tar.gz
python-alembic: uprev to 0.8.10
This uprev is required to support python-oslo.db uprev to stable/newton. The license is still MIT though the md5sum required being updated. Runtime dependencies were updated based on requires.txt. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--meta-openstack/recipes-devtools/python/python-alembic_0.8.10.bb23
-rw-r--r--meta-openstack/recipes-devtools/python/python-alembic_0.8.3.bb22
2 files changed, 23 insertions, 22 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-alembic_0.8.10.bb b/meta-openstack/recipes-devtools/python/python-alembic_0.8.10.bb
new file mode 100644
index 0000000..69fa495
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-alembic_0.8.10.bb
@@ -0,0 +1,23 @@
1DESCRIPTION = "A database migration tool for SQLAlchemy."
2HOMEPAGE = "http://bitbucket.org/zzzeek/alembic"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=d07407716fd24408b5747b0fa2262775"
6
7SRCNAME = "alembic"
8
9SRC_URI = "https://pypi.io/packages/source/a/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
10
11SRC_URI[md5sum] = "21b344a70ce637699c18bf074a080649"
12SRC_URI[sha256sum] = "0e3b50e96218283ec7443fb661199f5a81f5879f766967a8a2d25e8f9d4e7919"
13
14S = "${WORKDIR}/${SRCNAME}-${PV}"
15
16inherit setuptools
17
18RDEPENDS_${PN} += " \
19 python-sqlalchemy \
20 python-mako \
21 python-python-editor \
22 "
23
diff --git a/meta-openstack/recipes-devtools/python/python-alembic_0.8.3.bb b/meta-openstack/recipes-devtools/python/python-alembic_0.8.3.bb
deleted file mode 100644
index 01214e4..0000000
--- a/meta-openstack/recipes-devtools/python/python-alembic_0.8.3.bb
+++ /dev/null
@@ -1,22 +0,0 @@
1DESCRIPTION = "A database migration tool for SQLAlchemy."
2HOMEPAGE = "http://bitbucket.org/zzzeek/alembic"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=8faea05c89b6ff4ad5a9fa082f540719"
6
7SRCNAME = "alembic"
8
9SRC_URI = "https://pypi.python.org/packages/source/a/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
10
11SRC_URI[md5sum] = "2e4ef17675316af9f09d749b0aee390e"
12SRC_URI[sha256sum] = "eeac36589c1bf393e2040de01514a0d101ef17039957300209b0b44f3ddffce9"
13
14S = "${WORKDIR}/${SRCNAME}-${PV}"
15
16inherit setuptools
17
18RDEPENDS_${PN} += " \
19 python-sqlalchemy \
20 python-python-editor \
21 "
22