summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAmy Fong <amy.fong@windriver.com>2017-06-27 16:23:00 +0800
committerBruce Ashfield <bruce.ashfield@windriver.com>2017-06-29 15:28:25 -0400
commit1efe010daaf766cbc26965c6e00df798a207a480 (patch)
treee03d4c300e51e723b363999ea0721f286f6f0477
parent0e69d346e4158cd501bc6a9f3a44e60123e9ba7b (diff)
downloadmeta-cloud-services-1efe010daaf766cbc26965c6e00df798a207a480.tar.gz
python-greenlet: uprev to 0.4.9
python-greenlet bugfixes from 0.3.4 - unstable issues. This resulted in the docker-registry (in some build scenarios) crashing repeatedly. Traceback (most recent call last): File "/usr/lib64/python2.7/site-packages/gunicorn/arbiter.py", line 507, in spawn_worker worker.init_process() File "/usr/lib64/python2.7/site-packages/gunicorn/workers/ggevent.py", line 193, in init_process super(GeventWorker, self).init_process() File "/usr/lib64/python2.7/site-packages/gunicorn/workers/base.py", line 120, in init_process self.run() File "/usr/lib64/python2.7/site-packages/gunicorn/workers/ggevent.py", line 117, in run gevent.sleep(1.0) File "/usr/lib64/python2.7/site-packages/gevent/hub.py", line 75, in sleep hub.wait(loop.timer(seconds, ref=ref)) File "/usr/lib64/python2.7/site-packages/gevent/hub.py", line 341, in wait result = waiter.get() File "/usr/lib64/python2.7/site-packages/gevent/hub.py", line 568, in get return self.hub.switch() File "/usr/lib64/python2.7/site-packages/gevent/hub.py", line 331, in switch return greenlet.switch(self) SystemError: NULL result without error in PyObject_Call <repeat> Signed-off-by: Amy Fong <amy.fong@windriver.com> Signed-off-by: He Zhe <zhe.he@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--recipes-devtools/python/python-greenlet_0.4.9.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-greenlet_0.4.9.bb b/recipes-devtools/python/python-greenlet_0.4.9.bb
new file mode 100644
index 0000000..fa35fa8
--- /dev/null
+++ b/recipes-devtools/python/python-greenlet_0.4.9.bb
@@ -0,0 +1,14 @@
1SUMMARY = "Python lightweight in-process concurrent programming"
2HOMEPAGE = "http://pypi.python.org/pypi/greenlet"
3SECTION = "devel/python"
4LICENSE = "MIT & PSF"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=03143d7a1a9f5d8a0fee825f24ca9c36 \
6 file://LICENSE.PSF;md5=c106931d9429eda0492617f037b8f69a"
7SRC_URI = "http://pypi.python.org/packages/source/g/greenlet/greenlet-${PV}.tar.gz"
8SRC_URI[md5sum] = "00bb1822d8511cc85f052e89d1fd919b"
9SRC_URI[sha256sum] = "79f9b8bbbb1c599c66aed5e643e8b53bae697cae46e0acfc4ee461df48a90012"
10
11S = "${WORKDIR}/greenlet-${PV}"
12
13inherit distutils
14