diff options
author | Bruce Ashfield <bruce.ashfield@gmail.com> | 2024-10-12 03:16:54 +0000 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@gmail.com> | 2024-10-12 03:16:54 +0000 |
commit | b53ad3d7308ad2e85496fce8af27a59ec076f958 (patch) | |
tree | 8e9df6c67c8b176f240c06b6e12188c3f2f69d3c | |
parent | f63bba0cba3ef549507d3258f6f5b1265d121c50 (diff) | |
download | meta-cloud-services-b53ad3d7308ad2e85496fce8af27a59ec076f958.tar.gz |
python: drop recipes provided elsewhere
Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
15 files changed, 0 insertions, 197 deletions
diff --git a/meta-openstack/recipes-devtools/python/python3-arrow_0.17.0.bb b/meta-openstack/recipes-devtools/python/python3-arrow_0.17.0.bb deleted file mode 100644 index 9ef1d8f..0000000 --- a/meta-openstack/recipes-devtools/python/python3-arrow_0.17.0.bb +++ /dev/null | |||
@@ -1,14 +0,0 @@ | |||
1 | DESCRIPTION = "Better dates and times for Python" | ||
2 | HOMEPAGE = "https://github.com/crsmithdev/arrow" | ||
3 | SECTION = "devel/python" | ||
4 | LICENSE = "Apache-2.0" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=62e977be69cd001d6545038b6bb1575c" | ||
6 | |||
7 | SRC_URI[md5sum] = "76d66d0d03effad1407fb4dcebce9566" | ||
8 | SRC_URI[sha256sum] = "ff08d10cda1d36c68657d6ad20d74fbea493d980f8b2d45344e00d6ed2bf6ed4" | ||
9 | |||
10 | inherit setuptools3 pypi | ||
11 | |||
12 | RDEPENDS:${PN} += " \ | ||
13 | ${PYTHON_PN}-dateutil \ | ||
14 | " | ||
diff --git a/meta-openstack/recipes-devtools/python/python3-eventlet_0.25.1.bb b/meta-openstack/recipes-devtools/python/python3-eventlet_0.25.1.bb deleted file mode 100644 index c5fe598..0000000 --- a/meta-openstack/recipes-devtools/python/python3-eventlet_0.25.1.bb +++ /dev/null | |||
@@ -1,2 +0,0 @@ | |||
1 | inherit setuptools3 | ||
2 | require python-eventlet.inc | ||
diff --git a/meta-openstack/recipes-devtools/python/python3-extras_1.0.0.bb b/meta-openstack/recipes-devtools/python/python3-extras_1.0.0.bb deleted file mode 100644 index a7ed407..0000000 --- a/meta-openstack/recipes-devtools/python/python3-extras_1.0.0.bb +++ /dev/null | |||
@@ -1,10 +0,0 @@ | |||
1 | DESCRIPTION = "Useful extra bits for Python - things that should be in the standard library" | ||
2 | HOMEPAGE = "https://pypi.python.org/pypi/extras/" | ||
3 | SECTION = "devel/python" | ||
4 | LICENSE = "Apache-2.0" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=6d108f338b2f68fe48ac366c4650bd8b" | ||
6 | |||
7 | SRC_URI[md5sum] = "3a63ad60cf8f0186c9e3a02f55ec5b14" | ||
8 | SRC_URI[sha256sum] = "132e36de10b9c91d5d4cc620160a476e0468a88f16c9431817a6729611a81b4e" | ||
9 | |||
10 | inherit setuptools3 pypi | ||
diff --git a/meta-openstack/recipes-devtools/python/python3-jmespath_0.10.0.bb b/meta-openstack/recipes-devtools/python/python3-jmespath_0.10.0.bb deleted file mode 100644 index 24546cf..0000000 --- a/meta-openstack/recipes-devtools/python/python3-jmespath_0.10.0.bb +++ /dev/null | |||
@@ -1,16 +0,0 @@ | |||
1 | DESCRIPTION = "JSON Matching Expressions" | ||
2 | HOMEPAGE = "https://pypi.org/project/jmespath/" | ||
3 | SECTION = "devel/python" | ||
4 | LICENSE = "MIT" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=2683790f5fabb41a3f75b70558799eb4" | ||
6 | |||
7 | SRC_URI[md5sum] = "65bdcb5fa5bcf1cc710ffa508e78e408" | ||
8 | SRC_URI[sha256sum] = "b85d0567b8666149a93172712e68920734333c0ce7e89b78b3e987f71e5ed4f9" | ||
9 | |||
10 | inherit setuptools3 pypi | ||
11 | |||
12 | RDEPENDS:${PN} += " \ | ||
13 | python3-math \ | ||
14 | python3-json \ | ||
15 | python3-numbers \ | ||
16 | " | ||
diff --git a/meta-openstack/recipes-devtools/python/python3-jsonpath-rw_1.4.0.bb b/meta-openstack/recipes-devtools/python/python3-jsonpath-rw_1.4.0.bb deleted file mode 100644 index 77366f3..0000000 --- a/meta-openstack/recipes-devtools/python/python3-jsonpath-rw_1.4.0.bb +++ /dev/null | |||
@@ -1,10 +0,0 @@ | |||
1 | DESCRIPTION = "A robust and significantly extended implementation of JSONPath for Python" | ||
2 | HOMEPAGE = "https://github.com/kennknowles/python-jsonpath-rw" | ||
3 | SECTION = "devel/python" | ||
4 | LICENSE = "BSD+" | ||
5 | LIC_FILES_CHKSUM = "file://README.rst;md5=02384665f821c394981e0dd1faec9a7d" | ||
6 | |||
7 | SRC_URI[md5sum] = "3a807e05c2c12158fc6bb0a402fd5778" | ||
8 | SRC_URI[sha256sum] = "05c471281c45ae113f6103d1268ec7a4831a2e96aa80de45edc89b11fac4fbec" | ||
9 | |||
10 | inherit setuptools3 pypi | ||
diff --git a/meta-openstack/recipes-devtools/python/python3-lockfile_0.12.2.bb b/meta-openstack/recipes-devtools/python/python3-lockfile_0.12.2.bb deleted file mode 100644 index ba44638..0000000 --- a/meta-openstack/recipes-devtools/python/python3-lockfile_0.12.2.bb +++ /dev/null | |||
@@ -1,23 +0,0 @@ | |||
1 | DESCRIPTION = "Platform-independent file locking module" | ||
2 | HOMEPAGE = "http://code.google.com/p/pylockfile/" | ||
3 | SECTION = "devel/python" | ||
4 | LICENSE = "MIT" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=2340dffbbfea534b58f1349984eeef72" | ||
6 | |||
7 | SRC_URI[md5sum] = "a6a1a82957a23afdf44cfdd039b65ff9" | ||
8 | SRC_URI[sha256sum] = "6aed02de03cba24efabcd600b30540140634fc06cfa603822d508d5361e9f799" | ||
9 | |||
10 | inherit setuptools3 pypi | ||
11 | |||
12 | DEPENDS += "\ | ||
13 | python3-pbr \ | ||
14 | " | ||
15 | |||
16 | # Satisfy setup.py 'setup_requires' | ||
17 | DEPENDS += " \ | ||
18 | python3-pbr-native \ | ||
19 | " | ||
20 | |||
21 | RDEPENDS:${PN} += "\ | ||
22 | python3-pbr \ | ||
23 | " | ||
diff --git a/meta-openstack/recipes-devtools/python/python3-oauth2client_4.1.3.bb b/meta-openstack/recipes-devtools/python/python3-oauth2client_4.1.3.bb deleted file mode 100644 index 7943e39..0000000 --- a/meta-openstack/recipes-devtools/python/python3-oauth2client_4.1.3.bb +++ /dev/null | |||
@@ -1,18 +0,0 @@ | |||
1 | DESCRIPTION = "OAuth 2.0 client library" | ||
2 | AUTHOR = "Google Inc." | ||
3 | HOMEPAGE = "http://github.com/google/oauth2client/" | ||
4 | LICENSE = "Apache-2.0" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=038e1390e94fe637991fa5569daa62bc" | ||
6 | |||
7 | inherit setuptools3 pypi | ||
8 | |||
9 | SRC_URI[md5sum] = "3a9eb781f685949c04946f6c09e4c11d" | ||
10 | SRC_URI[sha256sum] = "d486741e451287f69568a4d26d70d9acd73a2bbfa275746c535b4209891cccc6" | ||
11 | |||
12 | RDEPENDS:${PN} += " \ | ||
13 | ${PYTHON_PN}-httplib2 \ | ||
14 | ${PYTHON_PN}-pyasn1 \ | ||
15 | ${PYTHON_PN}-pyasn1-modules \ | ||
16 | ${PYTHON_PN}-rsa \ | ||
17 | ${PYTHON_PN}-six \ | ||
18 | " | ||
diff --git a/meta-openstack/recipes-devtools/python/python3-pastedeploy_2.1.0.bb b/meta-openstack/recipes-devtools/python/python3-pastedeploy_2.1.0.bb deleted file mode 100644 index 7fc062a..0000000 --- a/meta-openstack/recipes-devtools/python/python3-pastedeploy_2.1.0.bb +++ /dev/null | |||
@@ -1,19 +0,0 @@ | |||
1 | DESCRIPTION = "Load, configure, and compose WSGI applications and servers" | ||
2 | HOMEPAGE = "http://pythonpaste.org/deploy/" | ||
3 | SECTION = "devel/python" | ||
4 | LICENSE = "MIT" | ||
5 | LIC_FILES_CHKSUM = "file://PKG-INFO;md5=57609488f8ad28ebf6844a5169a85215" | ||
6 | |||
7 | PYPI_PACKAGE = "PasteDeploy" | ||
8 | |||
9 | SRC_URI[md5sum] = "f1e62dc76092433b7ae150cd81603fbd" | ||
10 | SRC_URI[sha256sum] = "e7559878b6e92023041484be9bcb6d767cf4492fc3de7257a5dae76a7cc11a9b" | ||
11 | |||
12 | inherit setuptools3 pypi | ||
13 | |||
14 | DEPENDS += "${PYTHON_PN}-pytest-runner-native" | ||
15 | |||
16 | RDEPENDS:${PN} += " \ | ||
17 | ${PYTHON_PN}-paste \ | ||
18 | ${PYTHON_PN}-setuptools \ | ||
19 | " | ||
diff --git a/meta-openstack/recipes-devtools/python/python3-posix-ipc_1.0.4.bb b/meta-openstack/recipes-devtools/python/python3-posix-ipc_1.0.4.bb deleted file mode 100644 index bd010ac..0000000 --- a/meta-openstack/recipes-devtools/python/python3-posix-ipc_1.0.4.bb +++ /dev/null | |||
@@ -1,25 +0,0 @@ | |||
1 | DESCRIPTION = "POSIX IPC primitives (semaphores, shared memory and message queues) for Python" | ||
2 | HOMEPAGE = "http://semanchuk.com/philip/posix_ipc/" | ||
3 | SECTION = "devel/python" | ||
4 | LICENSE = "BSD" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=dc089fb2f37e90799a54c19a20c9880f" | ||
6 | |||
7 | PYPI_PACKAGE = "posix_ipc" | ||
8 | |||
9 | # Archived version so we need to overwrite what the pypi class will derive | ||
10 | PYPI_SRC_URI = "https://pypi.python.org/packages/source/p/${PYPI_PACKAGE}/${PYPI_PACKAGE}-${PV}.tar.gz" | ||
11 | |||
12 | SRC_URI[md5sum] = "c4fd0065244ccb2f59cb8ceedf287cf6" | ||
13 | SRC_URI[sha256sum] = "ff6c9077633fc62a491d6997c43b094d885bb45a7ca1f36c9a0d647c54b74b14" | ||
14 | |||
15 | inherit setuptools3 pypi | ||
16 | |||
17 | # DEPENDS_default: python-pip | ||
18 | |||
19 | DEPENDS += " \ | ||
20 | ${PYTHON_PN}-pip \ | ||
21 | " | ||
22 | |||
23 | # RDEPENDS:default: | ||
24 | RDEPENDS:${PN} += " \ | ||
25 | " | ||
diff --git a/meta-openstack/recipes-devtools/python/python3-semantic-version_2.8.5.bb b/meta-openstack/recipes-devtools/python/python3-semantic-version_2.8.5.bb deleted file mode 100644 index b91b655..0000000 --- a/meta-openstack/recipes-devtools/python/python3-semantic-version_2.8.5.bb +++ /dev/null | |||
@@ -1,13 +0,0 @@ | |||
1 | DESCRIPTION = "A library which provides a few tools to handle SemVer in Python." | ||
2 | HOMEPAGE = "http://pypi.python.org/pypi/semantic_version" | ||
3 | SECTION = "devel/python" | ||
4 | LICENSE = "BSD" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=4fb31e3c1c7eeb8b5e8c07657cdd54e2" | ||
6 | |||
7 | PYPI_PACKAGE = "semantic_version" | ||
8 | |||
9 | SRC_URI[md5sum] = "76d7364def7ee487b6153d40b13de904" | ||
10 | SRC_URI[sha256sum] = "d2cb2de0558762934679b9a104e82eca7af448c9f4974d1f3eeccff651df8a54" | ||
11 | |||
12 | inherit setuptools3 pypi | ||
13 | |||
diff --git a/meta-openstack/recipes-devtools/python/python3-subunit_1.4.0.bb b/meta-openstack/recipes-devtools/python/python3-subunit_1.4.0.bb deleted file mode 100644 index 02a6b2e..0000000 --- a/meta-openstack/recipes-devtools/python/python3-subunit_1.4.0.bb +++ /dev/null | |||
@@ -1,12 +0,0 @@ | |||
1 | DESCRIPTION = "Python implementation of subunit test streaming protocol" | ||
2 | HOMEPAGE = "https://pypi.python.org/pypi/python-subunit/" | ||
3 | SECTION = "devel/python" | ||
4 | LICENSE = "Apache-2.0" | ||
5 | LIC_FILES_CHKSUM = "file://PKG-INFO;md5=b5969d1df4dc7ff4882889baa132a694" | ||
6 | |||
7 | PYPI_PACKAGE = "python-subunit" | ||
8 | |||
9 | SRC_URI[md5sum] = "30f1ab20651d94442dd9a7f8c9e8d633" | ||
10 | SRC_URI[sha256sum] = "042039928120fbf392e8c983d60f3d8ae1b88f90a9f8fd7188ddd9c26cad1e48" | ||
11 | |||
12 | inherit setuptools3 pypi | ||
diff --git a/meta-openstack/recipes-devtools/python/python3-termcolor_1.1.0.bb b/meta-openstack/recipes-devtools/python/python3-termcolor_1.1.0.bb deleted file mode 100644 index 127287a..0000000 --- a/meta-openstack/recipes-devtools/python/python3-termcolor_1.1.0.bb +++ /dev/null | |||
@@ -1,18 +0,0 @@ | |||
1 | # | ||
2 | # Copyright (C) 2014 Wind River Systems, Inc. | ||
3 | # | ||
4 | DESCRIPTION = "ANSII Color formatting for output in terminal" | ||
5 | HOMEPAGE = "https://pypi.python.org/pypi/termcolor" | ||
6 | SECTION = "devel/python" | ||
7 | LICENSE = "MIT" | ||
8 | LIC_FILES_CHKSUM = "file://COPYING.txt;md5=809e8749b63567978acfbd81d9f6a27d" | ||
9 | |||
10 | SRC_URI[md5sum] = "043e89644f8909d462fbbfa511c768df" | ||
11 | SRC_URI[sha256sum] = "1d6d69ce66211143803fbc56652b41d73b4a400a2891d7bf7a1cdf4c02de613b" | ||
12 | |||
13 | inherit setuptools3 pypi | ||
14 | |||
15 | DEPENDS += " \ | ||
16 | python3-pip \ | ||
17 | " | ||
18 | |||
diff --git a/meta-openstack/recipes-devtools/python/python3-thrift_0.9.2.bb b/meta-openstack/recipes-devtools/python/python3-thrift_0.9.2.bb deleted file mode 100644 index ec76885..0000000 --- a/meta-openstack/recipes-devtools/python/python3-thrift_0.9.2.bb +++ /dev/null | |||
@@ -1,10 +0,0 @@ | |||
1 | DESCRIPTION = "Python bindings for the Apache Thrift RPC system" | ||
2 | HOMEPAGE = "https://pypi.python.org/pypi/amqp/" | ||
3 | SECTION = "devel/python" | ||
4 | LICENSE = "Apache-2.0" | ||
5 | LIC_FILES_CHKSUM = "file://PKG-INFO;md5=df17a59cc9e1327ec49c2285e13ac477" | ||
6 | |||
7 | SRC_URI[md5sum] = "91f1c224c46a257bb428431943387dfd" | ||
8 | SRC_URI[sha256sum] = "08f665e4b033c9d2d0b6174d869273104362c80e77ee4c01054a74141e378afa" | ||
9 | |||
10 | inherit setuptools3 pypi | ||
diff --git a/meta-openstack/recipes-devtools/python/python3-tox_3.14.3.bb b/meta-openstack/recipes-devtools/python/python3-tox_3.14.3.bb deleted file mode 100644 index 678413a..0000000 --- a/meta-openstack/recipes-devtools/python/python3-tox_3.14.3.bb +++ /dev/null | |||
@@ -1,5 +0,0 @@ | |||
1 | inherit setuptools3 | ||
2 | require python-tox.inc | ||
3 | |||
4 | SRC_URI[md5sum] = "8b695d482786dd51643e10953bbd8c89" | ||
5 | SRC_URI[sha256sum] = "06ba73b149bf838d5cd25dc30c2dd2671ae5b2757cf98e5c41a35fe449f131b3" | ||
diff --git a/meta-openstack/recipes-devtools/python/python3-virtualenv_1.11.4.bb b/meta-openstack/recipes-devtools/python/python3-virtualenv_1.11.4.bb deleted file mode 100644 index f053af7..0000000 --- a/meta-openstack/recipes-devtools/python/python3-virtualenv_1.11.4.bb +++ /dev/null | |||
@@ -1,2 +0,0 @@ | |||
1 | require python-virtualenv.inc | ||
2 | inherit setuptools3 | ||