summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2017-01-23 16:39:34 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2017-01-25 14:30:00 -0500
commit8197c918ddbf091009066bdf77b6d4269a267650 (patch)
tree3af167cec3d91afa1854822d3ae21b08d99f54e3
parent5329c2bbb33c3d5f6cb87362ce0bbe0dd50b2876 (diff)
downloadmeta-cloud-services-8197c918ddbf091009066bdf77b6d4269a267650.tar.gz
python-xstatic-objectpath: initial version
This package is required to support the stable/newton uprev of python-horizon. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--meta-openstack/recipes-devtools/python/python-xstatic-objectpath_1.2.1.0.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-xstatic-objectpath_1.2.1.0.bb b/meta-openstack/recipes-devtools/python/python-xstatic-objectpath_1.2.1.0.bb
new file mode 100644
index 0000000..71e5fa4
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-xstatic-objectpath_1.2.1.0.bb
@@ -0,0 +1,25 @@
1DESCRIPTION = "objectpath packaged for setuptools (easy_install) / pip."
2HOMEPAGE = "https://pypi.python.org/pypi/XStatic-objectpath"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://PKG-INFO;md5=98f106ed7f6916011689fc3699a6dabd"
6
7SRCNAME = "XStatic-objectpath"
8SRC_URI = "http://pypi.io/packages/source/X/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
9
10SRC_URI[md5sum] = "680a5e23a3d362db0b0721e5620dd6fc"
11SRC_URI[sha256sum] = "cd1e9f502482afcdd028821148843b07b4065c8dcea8e5cc33abb9ae1cf20b20"
12
13S = "${WORKDIR}/${SRCNAME}-${PV}"
14
15inherit setuptools
16
17# DEPENDS_default: python-pip
18
19DEPENDS += " \
20 python-pip \
21 "
22
23# RDEPENDS_default:
24RDEPENDS_${PN} += " \
25 "