summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Dudau <adrian.dudau@enea.com>2017-10-26 16:44:52 +0200
committerAdrian Dudau <adrian.dudau@enea.com>2017-11-02 15:56:47 +0100
commitf56d20b5f4f5ce625ec9d69ae99568d6aa326912 (patch)
tree82f0dc747ebe169398c913e9fbaf9ee8a9472685
parent27af4badfa45d187046c5f523cb8e4618bca4bf0 (diff)
downloadmeta-cloud-services-f56d20b5f4f5ce625ec9d69ae99568d6aa326912.tar.gz
python-neutron: Fix unescaped quotes in ovsdb agent implementation
Signed-off-by: Adrian Dudau <adrian.dudau@enea.com>
-rw-r--r--meta-openstack/recipes-devtools/python/python-neutron/0001-Escape-quotes-in-ovsdb-agent-implementation.patch30
-rw-r--r--meta-openstack/recipes-devtools/python/python-neutron_git.bb1
2 files changed, 31 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-neutron/0001-Escape-quotes-in-ovsdb-agent-implementation.patch b/meta-openstack/recipes-devtools/python/python-neutron/0001-Escape-quotes-in-ovsdb-agent-implementation.patch
new file mode 100644
index 0000000..d734e67
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-neutron/0001-Escape-quotes-in-ovsdb-agent-implementation.patch
@@ -0,0 +1,30 @@
1From 0facdc911f721a6ad86f93f8bad8da210e71709f Mon Sep 17 00:00:00 2001
2From: Adrian Dudau <adrian.dudau@enea.com>
3Date: Thu, 26 Oct 2017 16:35:53 +0200
4Subject: [PATCH] Escape quotes in ovsdb agent implementation
5
6This fixes a parsing error.
7
8Upstream-Status: Pending
9
10Signed-off-by: Adrian Dudau <adrian.dudau@enea.com>
11---
12 neutron/agent/ovsdb/impl_vsctl.py | 2 +-
13 1 file changed, 1 insertion(+), 1 deletion(-)
14
15diff --git a/neutron/agent/ovsdb/impl_vsctl.py b/neutron/agent/ovsdb/impl_vsctl.py
16index 51d19cc..1462ed0 100644
17--- a/neutron/agent/ovsdb/impl_vsctl.py
18+++ b/neutron/agent/ovsdb/impl_vsctl.py
19@@ -165,7 +165,7 @@ class OvsdbVsctl(ovsdb.API):
20
21 def add_manager(self, connection_uri):
22 # This will add a new manager without overriding existing ones.
23- conn_uri = 'target="%s"' % connection_uri
24+ conn_uri = 'target=\"%s\"' % connection_uri
25 args = ['create', 'Manager', conn_uri, '--', 'add', 'Open_vSwitch',
26 '.', 'manager_options', '@manager']
27 return BaseCommand(self.context, '--id=@manager', args=args)
28--
292.7.4
30
diff --git a/meta-openstack/recipes-devtools/python/python-neutron_git.bb b/meta-openstack/recipes-devtools/python/python-neutron_git.bb
index 70b59b1..0133168 100644
--- a/meta-openstack/recipes-devtools/python/python-neutron_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-neutron_git.bb
@@ -13,6 +13,7 @@ SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=stable/newton \
13 file://dhcp_agent.ini \ 13 file://dhcp_agent.ini \
14 file://metadata_agent.ini \ 14 file://metadata_agent.ini \
15 file://neutron-dhcp-agent-netns-cleanup.cron \ 15 file://neutron-dhcp-agent-netns-cleanup.cron \
16 file://0001-Escape-quotes-in-ovsdb-agent-implementation.patch \
16 " 17 "
17 18
18# TBD: update or drop 19# TBD: update or drop