summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Dudau <adrian.dudau@enea.com>2017-09-01 14:34:23 +0200
committerAdrian Dudau <adrian.dudau@enea.com>2017-09-01 14:34:23 +0200
commit45b67f57f89721e38921d8ace7a2fb842870f0c3 (patch)
treecbbb5be0af33dd710a6ab4f89f29a93e6a21ed78
parent4d91fef4dc8a2a528a1127fabe9eaf78e1d906b9 (diff)
downloadmeta-cloud-services-45b67f57f89721e38921d8ace7a2fb842870f0c3.tar.gz
python-ceilometer: Install sysv init scripts regardless of init system
This is to avoid having empty packages (like ceilometer-compute) which cause image packaging errors. This is a temporary hack, proper systemd services need to be installed instead to ensure functionality. Signed-off-by: Adrian Dudau <adrian.dudau@enea.com>
-rw-r--r--meta-openstack/recipes-devtools/python/python-ceilometer_git.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-ceilometer_git.bb b/meta-openstack/recipes-devtools/python/python-ceilometer_git.bb
index 862488b..319315f 100644
--- a/meta-openstack/recipes-devtools/python/python-ceilometer_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-ceilometer_git.bb
@@ -76,7 +76,8 @@ do_install_append() {
76 sed -e "s:%ADMIN_PASSWORD%:${ADMIN_PASSWORD}:g" -i ${CEILOMETER_CONF_DIR}/ceilometer.conf 76 sed -e "s:%ADMIN_PASSWORD%:${ADMIN_PASSWORD}:g" -i ${CEILOMETER_CONF_DIR}/ceilometer.conf
77 sed -e "s:%SERVICE_TENANT_NAME%:${SERVICE_TENANT_NAME}:g" -i ${CEILOMETER_CONF_DIR}/ceilometer.conf 77 sed -e "s:%SERVICE_TENANT_NAME%:${SERVICE_TENANT_NAME}:g" -i ${CEILOMETER_CONF_DIR}/ceilometer.conf
78 78
79 if ${@bb.utils.contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)}; then 79 if true; then
80 #if ${@bb.utils.contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)}; then
80 install -d ${D}${sysconfdir}/init.d 81 install -d ${D}${sysconfdir}/init.d
81 82
82 sed 's:@suffix@:api:' < ${WORKDIR}/ceilometer.init >${WORKDIR}/ceilometer-api.init.sh 83 sed 's:@suffix@:api:' < ${WORKDIR}/ceilometer.init >${WORKDIR}/ceilometer-api.init.sh