summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Dudau <adrian.dudau@enea.com>2017-08-10 12:33:30 +0200
committerAdrian Dudau <adrian.dudau@enea.com>2017-08-10 15:23:23 +0200
commit1e2cec416f84ed982738e9bab1455fbddca4548e (patch)
treee7cde44dcec7274c145df6ecfb0eff230215a000
parente61f457c2d140d3dbbf2c5717c4a6d14e9ff05e6 (diff)
downloadmeta-cloud-services-1e2cec416f84ed982738e9bab1455fbddca4548e.tar.gz
python-pycrypto: Drop recipe
Same version of the recipe is maintained in meta-python. Signed-off-by: Adrian Dudau <adrian.dudau@enea.com>
-rw-r--r--meta-openstack/recipes-devtools/python/python-pycrypto/cross-compiling.patch23
-rw-r--r--meta-openstack/recipes-devtools/python/python-pycrypto_2.6.1.bb35
2 files changed, 0 insertions, 58 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-pycrypto/cross-compiling.patch b/meta-openstack/recipes-devtools/python/python-pycrypto/cross-compiling.patch
deleted file mode 100644
index 712f3e8..0000000
--- a/meta-openstack/recipes-devtools/python/python-pycrypto/cross-compiling.patch
+++ /dev/null
@@ -1,23 +0,0 @@
1Index: pycrypto-2.6/setup.py
2===================================================================
3--- pycrypto-2.6.orig/setup.py
4+++ pycrypto-2.6/setup.py
5@@ -271,7 +271,8 @@ class PCTBuildConfigure(Command):
6 if not os.path.exists("config.status"):
7 if os.system("chmod 0755 configure") != 0:
8 raise RuntimeError("chmod error")
9- cmd = "sh configure" # we use "sh" here so that it'll work on mingw32 with standard python.org binaries
10+ host = os.environ.get("HOST_SYS")
11+ cmd = "ac_cv_func_malloc_0_nonnull=yes sh configure --host " + host # we use "sh" here so that it'll work on mingw32 with standard python.org binaries
12 if self.verbose < 1:
13 cmd += " -q"
14 if os.system(cmd) != 0:
15@@ -370,7 +371,7 @@ kw = {'name':"pycrypto",
16 'ext_modules': plat_ext + [
17 # _fastmath (uses GNU mp library)
18 Extension("Crypto.PublicKey._fastmath",
19- include_dirs=['src/','/usr/include/'],
20+ include_dirs=['src/'],
21 libraries=['gmp'],
22 sources=["src/_fastmath.c"]),
23
diff --git a/meta-openstack/recipes-devtools/python/python-pycrypto_2.6.1.bb b/meta-openstack/recipes-devtools/python/python-pycrypto_2.6.1.bb
deleted file mode 100644
index b823224..0000000
--- a/meta-openstack/recipes-devtools/python/python-pycrypto_2.6.1.bb
+++ /dev/null
@@ -1,35 +0,0 @@
1DESCRIPTION = "Cryptographic modules for Python."
2HOMEPAGE = "http://www.pycrypto.org/"
3SECTION = "devel/python"
4LICENSE = "PSFv2"
5LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=35f354d199e8cb7667b059a23578e63d"
6
7SRCNAME = "pycrypto"
8
9SRC_URI = "https://pypi.python.org/packages/source/p/${SRCNAME}/${SRCNAME}-${PV}.tar.gz \
10 file://cross-compiling.patch"
11
12SRC_URI[md5sum] = "55a61a054aa66812daf5161a0d5d7eda"
13SRC_URI[sha256sum] = "f2ce1e989b272cfcb677616763e0a2e7ec659effa67a88aa92b3a65528f60a3c"
14
15S = "${WORKDIR}/${SRCNAME}-${PV}"
16
17inherit distutils
18
19export STAGING_INCDIR
20export STAGING_LIBDIR
21export BUILD_SYS
22export HOST_SYS
23
24inherit autotools autotools-brokensep distutils
25
26DEPENDS += " gmp"
27
28do_compile[noexec] = "1"
29
30# We explicitly call distutils_do_install, since we want it to run, but
31# *don't* want the autotools install to run, since this package doesn't
32# provide a "make install" target.
33do_install() {
34 distutils_do_install
35}