summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Calianu <adrian.calianu@enea.com>2018-01-31 15:46:29 +0100
committerAdrian Dudau <adrian.dudau@enea.com>2018-02-01 15:22:50 +0100
commit1c224ec04452ca69a09153cb1abf14be4ab8a383 (patch)
treed1b03050f18133e7fbdb724675ff1d4aa67032fd
parent2cdb661fb79a2b16bce6255596a7ab144f382d39 (diff)
downloadmeta-cloud-services-1c224ec04452ca69a09153cb1abf14be4ab8a383.tar.gz
cloud-init: fix run-time dependeciespyro-nfvaccess
Signed-off-by: Adrian Calianu <adrian.calianu@enea.com> Signed-off-by: Adrian Dudau <adrian.dudau@enea.com>
-rw-r--r--meta-openstack/recipes-extended/cloud-init/cloud-init_0.7.6.bb11
1 files changed, 10 insertions, 1 deletions
diff --git a/meta-openstack/recipes-extended/cloud-init/cloud-init_0.7.6.bb b/meta-openstack/recipes-extended/cloud-init/cloud-init_0.7.6.bb
index c6b3529..c24b62b 100644
--- a/meta-openstack/recipes-extended/cloud-init/cloud-init_0.7.6.bb
+++ b/meta-openstack/recipes-extended/cloud-init/cloud-init_0.7.6.bb
@@ -36,10 +36,12 @@ do_install_append() {
36 ln -s ${libdir}/${BPN}/write-ssh-key-fingerprints ${D}${sysconfdir}/cloud/write-ssh-key-fingerprints 36 ln -s ${libdir}/${BPN}/write-ssh-key-fingerprints ${D}${sysconfdir}/cloud/write-ssh-key-fingerprints
37} 37}
38 38
39inherit setuptools update-rc.d 39inherit setuptools update-rc.d systemd
40 40
41PACKAGES += "${PN}-systemd" 41PACKAGES += "${PN}-systemd"
42 42
43SYSTEMD_SERVICE_${PN} = "cloud-init.service cloud-init-local.service cloud-config.service cloud-final.service"
44
43FILES_${PN} += "${sysconfdir}/* \ 45FILES_${PN} += "${sysconfdir}/* \
44 ${datadir}/*" 46 ${datadir}/*"
45 47
@@ -50,4 +52,11 @@ INITSCRIPT_NAME_${BPN} = "cloud-init"
50 52
51RDEPENDS_${PN} = "sysklogd \ 53RDEPENDS_${PN} = "sysklogd \
52 python \ 54 python \
55 python-modules \
56 python-pyyaml \
57 python-requests \
58 python-jsonpatch \
59 python-jsonschema \
60 python-six \
61 python-prettytable \
53 " 62 "