summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2017-01-21 22:48:46 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2017-01-21 23:17:12 -0500
commitc5432f5b16e050a5719b145456bbe25d12cc3a31 (patch)
tree79157e8634b124f880ccfa18e2b09faa217828f2
parent989bb39ce87eb879a8bf994160b8ebf552421627 (diff)
downloadmeta-cloud-services-c5432f5b16e050a5719b145456bbe25d12cc3a31.tar.gz
python-amqp: bring back the 1.x.x series
The stable/newton version of python-oslo.messaging requires python-amqp <2.0.0 so we will bring back the latest version of the 1.x.x series (removed by commit 3af287f179a0), uprev to v1.4.9 and make it the PREF version. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--meta-openstack/conf/layer.conf1
-rw-r--r--meta-openstack/recipes-devtools/python/python-amqp_1.4.9.bb16
2 files changed, 17 insertions, 0 deletions
diff --git a/meta-openstack/conf/layer.conf b/meta-openstack/conf/layer.conf
index 4007cb9..e940478 100644
--- a/meta-openstack/conf/layer.conf
+++ b/meta-openstack/conf/layer.conf
@@ -19,5 +19,6 @@ PREFERRED_VERSION_python-django = "1.8.6"
19PREFERRED_VERSION_python-netaddr = "0.7.19" 19PREFERRED_VERSION_python-netaddr = "0.7.19"
20PREFERRED_VERSION_python-sqlalchemy = "1.0.16" 20PREFERRED_VERSION_python-sqlalchemy = "1.0.16"
21PREFERRED_VERSION_python-requests = "2.12.0" 21PREFERRED_VERSION_python-requests = "2.12.0"
22PREFERRED_VERSION_python-amqp = "1.4.9"
22 23
23LICENSE_PATH += "${LAYERDIR}/licenses" 24LICENSE_PATH += "${LAYERDIR}/licenses"
diff --git a/meta-openstack/recipes-devtools/python/python-amqp_1.4.9.bb b/meta-openstack/recipes-devtools/python/python-amqp_1.4.9.bb
new file mode 100644
index 0000000..9768e09
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-amqp_1.4.9.bb
@@ -0,0 +1,16 @@
1DESCRIPTION = "Low-level AMQP client for Python"
2HOMEPAGE = "https://pypi.python.org/pypi/amqp/"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1702a92c723f09e3fab3583b165a8d90"
6
7SRCNAME = "amqp"
8
9SRC_URI = "https://pypi.io/packages/source/a/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
10
11SRC_URI[md5sum] = "df57dde763ba2dea25b3fa92dfe43c19"
12SRC_URI[sha256sum] = "2dea4d16d073c902c3b89d9b96620fb6729ac0f7a923bbc777cb4ad827c0c61a"
13
14S = "${WORKDIR}/${SRCNAME}-${PV}"
15
16inherit setuptools