summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2017-01-23 22:09:01 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2017-01-25 14:30:00 -0500
commit8464ccecda8d527a921f115c76e1a4add2fd2cdc (patch)
treecfbeb56be8e559937faa476e7c96f8e69dbcf144
parentd80e19f2dae2b7b4b476a34dce917505a7617c0b (diff)
downloadmeta-cloud-services-8464ccecda8d527a921f115c76e1a4add2fd2cdc.tar.gz
python-osc-lib: initial version
This is required for the uprev of python-heatclient to stable/newton. The version is selected based on all version requirements. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--meta-openstack/recipes-devtools/python/python-osc-lib_1.1.0.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-osc-lib_1.1.0.bb b/meta-openstack/recipes-devtools/python/python-osc-lib_1.1.0.bb
new file mode 100644
index 0000000..70582f7
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-osc-lib_1.1.0.bb
@@ -0,0 +1,32 @@
1DESCRIPTION = "OpenStackClient Library"
2HOMEPAGE = "http://opensource.perlig.de/rcssmin/"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
6
7SRCNAME = "osc-lib"
8
9SRC_URI = "https://pypi.io/packages/source/o/${SRCNAME}/${SRCNAME}-${PV}.tar.gz \
10"
11
12SRC_URI[md5sum] = "08bf2b46089da52240893d99a3892897"
13SRC_URI[sha256sum] = "e06ca111b2702d442f5cf70c754b6331cc7742231f0fe0b634cbd03c502610ba"
14
15S = "${WORKDIR}/${SRCNAME}-${PV}"
16
17inherit setuptools
18
19RDEPENDS_${PN} += " \
20 python-pbr \
21 python-six \
22 python-babel \
23 python-cliff \
24 python-keystoneauth1 \
25 python-os-client-config \
26 python-oslo.i18n \
27 python-oslo.utils \
28 python-simplejson \
29 python-stevedore \
30 "
31
32CLEANBROKEN = "1"