summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHuang Qiyu <huangqy.fnst@cn.fujitsu.com>2017-01-23 16:25:25 +0800
committerBruce Ashfield <bruce.ashfield@windriver.com>2017-01-25 14:29:59 -0500
commit525981124be70e314db8dd5df570ddeaf4fc5517 (patch)
tree64661de60d4c6594e1606f309b6e978a34100b23
parent8ce045d04712053561e22b70e76223d17df215b7 (diff)
downloadmeta-cloud-services-525981124be70e314db8dd5df570ddeaf4fc5517.tar.gz
python-psycopg2: 2.6.1 -> 2.6.2
1) Upgrade python-psycopg2 from 2.6.1 to 2.6.2. 2) Modify remove-pg-config.patch, since the data has been changed. Signed-off-by: Huang Qiyu <huangqy.fnst@cn.fujitsu.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--meta-openstack/recipes-devtools/python/python-psycopg2/remove-pg-config.patch34
-rw-r--r--meta-openstack/recipes-devtools/python/python-psycopg2_2.6.2.bb (renamed from meta-openstack/recipes-devtools/python/python-psycopg2_2.6.1.bb)6
2 files changed, 17 insertions, 23 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-psycopg2/remove-pg-config.patch b/meta-openstack/recipes-devtools/python/python-psycopg2/remove-pg-config.patch
index b2f94dd..37acc30 100644
--- a/meta-openstack/recipes-devtools/python/python-psycopg2/remove-pg-config.patch
+++ b/meta-openstack/recipes-devtools/python/python-psycopg2/remove-pg-config.patch
@@ -1,37 +1,31 @@
1From 392c4581da49f133938e70f6215bfebba28ecc56 Mon Sep 17 00:00:00 2001 1From 92d42775735d1555449b860c214ca7265d7ad75b Mon Sep 17 00:00:00 2001
2From: Mark Asselstine <mark.asselstine@windriver.com> 2From: Mark Asselstine <mark.asselstine@windriver.com>
3Date: Tue, 4 Aug 2015 20:59:18 -0400 3Date: Tue, 24 Jan 2017 00:43:35 +0900
4Subject: [PATCH] setup: don't use pg_config 4Subject: [PATCH] setup: don't use pg_config
5 5
6The package uses the pg_config command to detect the libdir and
7includedir path. Commented the lines because the command is not
8available at buildtime and the package succesfully build without them.
9
10Signed-off-by: Mark Asselstine <bruce.ashfield@windriver.com>
11Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> 6Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com>
7Signed-off-by: Huang Qiyu <huangqy.fnst@cn.fujitsu.com>
12--- 8---
13 setup.cfg | 2 +- 9 setup.cfg | 1 +
14 setup.py | 5 +---- 10 setup.py | 5 +----
15 2 files changed, 2 insertions(+), 5 deletions(-) 11 2 files changed, 2 insertions(+), 4 deletions(-)
16 12
17diff --git a/setup.cfg b/setup.cfg 13diff --git a/setup.cfg b/setup.cfg
18index 90a47dd..986871b 100644 14index d00ce92..4b45aac 100644
19--- a/setup.cfg 15--- a/setup.cfg
20+++ b/setup.cfg 16+++ b/setup.cfg
21@@ -9,7 +9,7 @@ define= 17@@ -1,5 +1,6 @@
22 # build psycopg2. If pg_config is not in the path or is installed under a 18 [build_ext]
23 # different name uncomment the following option and set it to the pg_config 19 define =
24 # full path.
25-#pg_config=
26+pg_config="/bin/true" 20+pg_config="/bin/true"
21 use_pydatetime = 1
22 have_ssl = 0
27 23
28 # Set to 1 to use Python datetime objects for default date/time representation.
29 use_pydatetime=1
30diff --git a/setup.py b/setup.py 24diff --git a/setup.py b/setup.py
31index 975fe10..85502ca 100644 25index d71d489..b101696 100644
32--- a/setup.py 26--- a/setup.py
33+++ b/setup.py 27+++ b/setup.py
34@@ -389,16 +389,13 @@ class psycopg_build_ext(build_ext): 28@@ -398,16 +398,13 @@ class psycopg_build_ext(build_ext):
35 self.libraries.append("pq") 29 self.libraries.append("pq")
36 30
37 try: 31 try:
@@ -50,5 +44,5 @@ index 975fe10..85502ca 100644
50 verre = re.compile( 44 verre = re.compile(
51 r"(\d+)\.(\d+)(?:(?:\.(\d+))|(devel|(alpha|beta|rc)\d+))") 45 r"(\d+)\.(\d+)(?:(?:\.(\d+))|(devel|(alpha|beta|rc)\d+))")
52-- 46--
532.1.4 472.7.4
54 48
diff --git a/meta-openstack/recipes-devtools/python/python-psycopg2_2.6.1.bb b/meta-openstack/recipes-devtools/python/python-psycopg2_2.6.2.bb
index 1d78afa..2cdb138 100644
--- a/meta-openstack/recipes-devtools/python/python-psycopg2_2.6.1.bb
+++ b/meta-openstack/recipes-devtools/python/python-psycopg2_2.6.2.bb
@@ -8,12 +8,12 @@ DEPENDS = "postgresql"
8PR = "r0" 8PR = "r0"
9SRCNAME = "psycopg2" 9SRCNAME = "psycopg2"
10 10
11SRC_URI = "https://pypi.python.org/packages/source/p/${SRCNAME}/${SRCNAME}-${PV}.tar.gz \ 11SRC_URI = "https://pypi.python.org/packages/7b/a8/dc2d50a6f37c157459cd18bab381c8e6134b9381b50fbe969997b2ae7dbc/${SRCNAME}-${PV}.tar.gz \
12 file://remove-pg-config.patch \ 12 file://remove-pg-config.patch \
13 " 13 "
14 14
15SRC_URI[md5sum] = "842b44f8c95517ed5b792081a2370da1" 15SRC_URI[md5sum] = "4a392949ba31a378a18ed3e775a4693f"
16SRC_URI[sha256sum] = "6acf9abbbe757ef75dc2ecd9d91ba749547941abaffbe69ff2086a9e37d4904c" 16SRC_URI[sha256sum] = "70490e12ed9c5c818ecd85d185d363335cc8a8cbf7212e3c185431c79ff8c05c"
17 17
18S = "${WORKDIR}/${SRCNAME}-${PV}" 18S = "${WORKDIR}/${SRCNAME}-${PV}"
19 19