summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2016-02-03 20:41:41 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2016-02-05 14:42:18 -0500
commite0c82f9b1a4867056aa334ee53f9eb93982acf48 (patch)
tree4376e68bc3a3e3955063a89f0373bd7d11557d0f
parent35583d3dafa9894aeb27c6fc6177a4ed9dc89a09 (diff)
downloadmeta-cloud-services-e0c82f9b1a4867056aa334ee53f9eb93982acf48.tar.gz
python-oauthlib: allow apache to read requires.txt
Apache will error with: IOError: [Errno 13] Permission denied: \ '/usr/lib/python2.7/site-packages/oauthlib-0.7.2-py2.7.egg-info/requires.txt' when attempting to login to horizon. Set more permissive permissions for this file to avoid this. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--meta-openstack/recipes-devtools/python/python-oauthlib_0.7.2.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-oauthlib_0.7.2.bb b/meta-openstack/recipes-devtools/python/python-oauthlib_0.7.2.bb
index 01c2ac2..c8a9147 100644
--- a/meta-openstack/recipes-devtools/python/python-oauthlib_0.7.2.bb
+++ b/meta-openstack/recipes-devtools/python/python-oauthlib_0.7.2.bb
@@ -27,7 +27,7 @@ RDEPENDS_${PN} += " \
27 " 27 "
28 28
29do_install_append() { 29do_install_append() {
30 perm_files=`find "${D}${PYTHON_SITEPACKAGES_DIR}/" -name "top_level.txt"` 30 perm_files=`find "${D}${PYTHON_SITEPACKAGES_DIR}/" -name "top_level.txt" -o -name "requires.txt"`
31 for f in $perm_files; do 31 for f in $perm_files; do
32 chmod 644 "${f}" 32 chmod 644 "${f}"
33 done 33 done